Re: [Freedreno] [DPU PATCH] drm/msm/dsi: add only dsi nodes with a valid device to list

2018-06-18 Thread abhinavk
Hi Jordan Thanks for the review. Comments inline. Abhinav On 2018-06-18 07:23, Jordan Crouse wrote: On Fri, Jun 15, 2018 at 11:05:57PM -0700, Abhinav Kumar wrote: Before adding a DSI node to the private list check if the node has a valid device connected to it through an endpoint. This is re

Re: [Freedreno] [PATCH] gpu: drm: msm: Change return type to vm_fault_t

2018-06-18 Thread Rob Clark
On Sun, Jun 17, 2018 at 11:40 PM, Souptick Joarder wrote: > On Thu, May 31, 2018 at 11:29 PM, Jordan Crouse > wrote: >> On Mon, May 28, 2018 at 12:38:41PM +0530, Souptick Joarder wrote: >>> On Mon, May 21, 2018 at 10:59 PM, Souptick Joarder >>> wrote: >>> > Use new return type vm_fault_t for f

[Freedreno] [PATCH] drm/msm: avoid using 'timespec'

2018-06-18 Thread Arnd Bergmann
The timespec structure and associated interfaces are deprecated and will be removed in the future because of the y2038 overflow. The use of ktime_to_timespec() in timeout_to_jiffies() does not suffer from that overflow, but is easy to avoid by just converting the ktime_t into jiffies directly. Si

Re: [Freedreno] [PATCH 2/3] drm/msm: Replace drm_gem_object_{un/reference} with put, get functions

2018-06-18 Thread Jordan Crouse
On Mon, Jun 18, 2018 at 03:02:19PM +0200, Thomas Zimmermann wrote: > This patch unifies the naming of DRM functions for reference counting > of struct drm_gem_object. The resulting code is more aligned with the > rest of the Linux kernel interfaces. Thanks for doing this. > Signed-off-by: Thomas

Re: [Freedreno] [DPU PATCH] drm/msm/dsi: add only dsi nodes with a valid device to list

2018-06-18 Thread Jordan Crouse
On Fri, Jun 15, 2018 at 11:05:57PM -0700, Abhinav Kumar wrote: > Before adding a DSI node to the private list check if the > node has a valid device connected to it through an endpoint. > > This is required in cases where the chipset supports multiple > DSI hosts but only one of them is being used

[Freedreno] [DPU PATCH v2 13/14] drm/msm/dpu: add atomic private object to dpu kms

2018-06-18 Thread Sravanthi Kollukuduru
From: Jeykumar Sankaran Subclass drm private state for DPU for handling driver specific data. Adds atomic private object and private object lock to dpu kms. Provides helper function to retrieve DPU private data from current atomic state. changes in v2: - fix return value while retrieving dp

[Freedreno] [DPU PATCH v2 14/14] drm/msm/dpu: use private obj to track hw resources

2018-06-18 Thread Sravanthi Kollukuduru
From: Jeykumar Sankaran Switch to state based resource management. This patch overhauls the resource manager and HW allocation methods by maintaining the global resource pool and allocated hw blocks in respective drm component states. Global resource manager(RM) is tracked in private object. All

[Freedreno] [DPU PATCH v2 10/14] drm/msm/dpu: rename hw_ctl to lm_ctl

2018-06-18 Thread Sravanthi Kollukuduru
From: Jeykumar Sankaran Prep change for state based resource management. Rename hw_ctl to lm_ctl to mean the ctl associated with the hw layer mixer block. changes in v2: - none Signed-off-by: Jeykumar Sankaran Signed-off-by: Sravanthi Kollukuduru --- drivers/gpu/drm/msm/disp/dpu1/dpu_c

[Freedreno] [DPU PATCH v2 04/14] drm/msm/dpu: program master-slave encoders explicitly

2018-06-18 Thread Sravanthi Kollukuduru
From: Jeykumar Sankaran Identify slave-master encoders and program them explicitly. changes in v2: - none Signed-off-by: Jeykumar Sankaran Signed-off-by: Sravanthi Kollukuduru --- drivers/gpu/drm/msm/disp/dpu1/dpu_encoder.c | 41 - 1 file changed, 23 insertio

[Freedreno] [DPU PATCH v2 12/14] drm/msm/dpu: remove display H_TILE from encoder

2018-06-18 Thread Sravanthi Kollukuduru
From: Jeykumar Sankaran Encoder H_TILE values are not used for allocating the hw blocks. no. of hw_intf blocks provides the info. changes in v2: - none Signed-off-by: Jeykumar Sankaran Signed-off-by: Sravanthi Kollukuduru --- drivers/gpu/drm/msm/disp/dpu1/dpu_encoder.c | 5 - driver

[Freedreno] [DPU PATCH v2 05/14] drm/msm/dpu: use kms stored hw mdp block

2018-06-18 Thread Sravanthi Kollukuduru
From: Jeykumar Sankaran Avoid querying RM for hw mdp block. Use the one stored in KMS during initialization. changes in v2: - none Signed-off-by: Jeykumar Sankaran Signed-off-by: Sravanthi Kollukuduru --- drivers/gpu/drm/msm/disp/dpu1/dpu_encoder_phys_cmd.c | 12 +--- drivers/gp

[Freedreno] [DPU PATCH v2 09/14] drm/msm/dpu: move hw resource tracking to crtc state

2018-06-18 Thread Sravanthi Kollukuduru
From: Jeykumar Sankaran Prep changes for state based resource management. Moves all the hw block tracking for the crtc to the state object. changes in v2: - none Signed-off-by: Jeykumar Sankaran Signed-off-by: Sravanthi Kollukuduru --- drivers/gpu/drm/msm/disp/dpu1/dpu_crtc.c | 76

[Freedreno] [DPU PATCH v2 11/14] drm/msm/dpu: remove topology name

2018-06-18 Thread Sravanthi Kollukuduru
From: Jeykumar Sankaran Strip down the support for topology enums. It can be replaced with simple hw count checks. changes in v2: - none Signed-off-by: Jeykumar Sankaran Signed-off-by: Sravanthi Kollukuduru --- drivers/gpu/drm/msm/disp/dpu1/dpu_encoder.c | 3 --- drivers/gpu/d

[Freedreno] [DPU PATCH v2 07/14] drm/msm/dpu: iterate for assigned hw ctl in virtual encoder

2018-06-18 Thread Sravanthi Kollukuduru
From: Jeykumar Sankaran Instead of iterating for hw ctrl per physical encoder, this patch moves the iterations and assignment to the virtual encoder. changes in v2: - none Signed-off-by: Jeykumar Sankaran Signed-off-by: Sravanthi Kollukuduru --- drivers/gpu/drm/msm/disp/dpu1/dpu_encoder

[Freedreno] [DPU PATCH v2 08/14] drm/msm/dpu: avoid querying for hw intf before assignment

2018-06-18 Thread Sravanthi Kollukuduru
From: Jeykumar Sankaran hw intf blocks are needed only during encoder enable to program timing engines(for video panels). encoder->enable is triggered only after atomic_modeset at which point we assign the resources for the display pipeline. This patch defers the hw_intf look-up until encoder ena

[Freedreno] [DPU PATCH v2 06/14] drm/msm/dpu: remove stale encoder code

2018-06-18 Thread Sravanthi Kollukuduru
From: Jeykumar Sankaran Remove helper function used only by writeback connectors to trigger final flush before disabling. Now that write back connectors are stripped down, the helper is not used. changes in v2: - none Signed-off-by: Jeykumar Sankaran Signed-off-by: Sravanthi Kollukuduru

[Freedreno] [DPU PATCH v2 03/14] drm/msm/dpu: remove ping pong split topology variables

2018-06-18 Thread Sravanthi Kollukuduru
From: Jeykumar Sankaran Remove left out variables of previous ping pong split topology cleanup. changes in v2: - none Signed-off-by: Jeykumar Sankaran Signed-off-by: Sravanthi Kollukuduru --- drivers/gpu/drm/msm/disp/dpu1/dpu_crtc.h | 2 -- 1 file changed, 2 deletions(-) diff --git a/d

[Freedreno] [DPU PATCH v2 02/14] drm/msm/dpu: remove resource pool manager

2018-06-18 Thread Sravanthi Kollukuduru
From: Jeykumar Sankaran resource pool manager utility was introduced to manage rotator sessions. Removing the support as the rotator feature doesn't exist. changes in v2: - none Signed-off-by: Jeykumar Sankaran Signed-off-by: Sravanthi Kollukuduru --- drivers/gpu/drm/msm/disp/dpu1/dpu_c

[Freedreno] [DPU PATCH v2 01/14] drm/msm/dpu: remove scalar config definitions

2018-06-18 Thread Sravanthi Kollukuduru
From: Jeykumar Sankaran cleans up left out scalar config definitions from headers changes in v2: - none Signed-off-by: Jeykumar Sankaran Signed-off-by: Sravanthi Kollukuduru --- drivers/gpu/drm/msm/disp/dpu1/dpu_crtc.h| 2 -- drivers/gpu/drm/msm/disp/dpu1/dpu_hw_util.h | 10

[Freedreno] [DPU PATCH v2 00/14] Atomic resource management

2018-06-18 Thread Sravanthi Kollukuduru
This patchset introduces drm private object in KMS to manage HW resource management. It modifies the resource manager by introducing API's to do per DRM object resource allocation/cleanups. The patchset is based on: https://patchwork.kernel.org/patch/10461375/ major changes in v2: - Fix retur

[Freedreno] [PATCH 2/3] drm/msm: Replace drm_gem_object_{un/reference} with put, get functions

2018-06-18 Thread Thomas Zimmermann
This patch unifies the naming of DRM functions for reference counting of struct drm_gem_object. The resulting code is more aligned with the rest of the Linux kernel interfaces. Signed-off-by: Thomas Zimmermann --- drivers/gpu/drm/msm/adreno/a5xx_debugfs.c | 4 ++-- drivers/gpu/drm/msm/adreno/a5x

[Freedreno] [PATCH 1/3] drm/msm: Replace drm_framebuffer_{un/reference} with put, get functions

2018-06-18 Thread Thomas Zimmermann
This patch unifies the naming of DRM functions for reference counting of struct drm_framebuffer. The resulting code is more aligned with the rest of the Linux kernel interfaces. Signed-off-by: Thomas Zimmermann --- drivers/gpu/drm/msm/disp/mdp5/mdp5_plane.c | 4 ++-- 1 file changed, 2 insertions

[Freedreno] [PATCH 0/3] drm/msm: Replace {un/reference} with {put, get} functions

2018-06-18 Thread Thomas Zimmermann
This patch set replaces functions named {un,reference} by their {put,get} counterparts. Affected data types are struct struct drm_framebuffer, struct drm_gem_object, and struct drm_device. With the reference-counting functions being named {put,get}, the DRM interface is more aligned to Linux kerne

[Freedreno] [PATCH 3/3] drm/msm: Replace drm_dev_unref with drm_dev_put

2018-06-18 Thread Thomas Zimmermann
This patch unifies the naming of DRM functions for reference counting of struct drm_device. The resulting code is more aligned with the rest of the Linux kernel interfaces. Signed-off-by: Thomas Zimmermann --- drivers/gpu/drm/msm/msm_drv.c | 8 1 file changed, 4 insertions(+), 4 deletio

[Freedreno] [PATCH 4.14 038/189] drm/msm: dont deref error pointer in the msm_fbdev_create error path

2018-06-18 Thread Greg Kroah-Hartman
4.14-stable review patch. If anyone has any objections, please let me know. -- From: Emil Velikov [ Upstream commit 789d4c300e10eb2096ee83c3497118e67ccc951e ] Currently the error pointer returned by msm_alloc_stolen_fb gets passed to drm_framebuffer_remove. The latter handles

[Freedreno] [PATCH 4.16 059/279] drm/msm: dont deref error pointer in the msm_fbdev_create error path

2018-06-18 Thread Greg Kroah-Hartman
4.16-stable review patch. If anyone has any objections, please let me know. -- From: Emil Velikov [ Upstream commit 789d4c300e10eb2096ee83c3497118e67ccc951e ] Currently the error pointer returned by msm_alloc_stolen_fb gets passed to drm_framebuffer_remove. The latter handles