Re: [Freedreno] [PATCH 2/2] drm/msm/dp: do not re initialize of audio_comp

2021-04-12 Thread Stephen Boyd
Quoting Kuogee Hsieh (2021-04-12 10:03:23) > At dp_display_disable(), do not re initialize audio_comp if > hdp_state == ST_DISCONNECT_PENDING (unplug event) to avoid > race condition which cause 5 second timeout expired. More details please. > Also > add abort mechanism to reduce time spinning

Re: [Freedreno] [PATCH 1/2] drm/msm/dp: check sink_count before update is_connected status

2021-04-12 Thread Stephen Boyd
Quoting Kuogee Hsieh (2021-04-12 10:02:51) > At pm_resume check link sisnk_count before update is_connected status > base on HPD real time link status. Also print out error message only > when either EV_CONNECT_PENDING_TIMEOUT or EV_DISCONNECT_PENDING_TIMEOUT > happen. > > Signed-off-by: Kuogee

Re: [Freedreno] [PATCH 1/2] drm/msm/dp: check sink_count before update is_connected status

2021-04-12 Thread Stephen Boyd
Quoting Kuogee Hsieh (2021-04-12 10:02:51) > At pm_resume check link sisnk_count before update is_connected status s/sisnk_count/sink_count/ > base on HPD real time link status. Also print out error message only > when either EV_CONNECT_PENDING_TIMEOUT or EV_DISCONNECT_PENDING_TIMEOUT > happen.

[Freedreno] [PATCH 1/2] drm/msm/dp: check sink_count before update is_connected status

2021-04-12 Thread Kuogee Hsieh
At pm_resume check link sisnk_count before update is_connected status base on HPD real time link status. Also print out error message only when either EV_CONNECT_PENDING_TIMEOUT or EV_DISCONNECT_PENDING_TIMEOUT happen. Signed-off-by: Kuogee Hsieh --- drivers/gpu/drm/msm/dp/dp_display.c | 6

[Freedreno] [PATCH 2/2] drm/msm/dp: do not re initialize of audio_comp

2021-04-12 Thread Kuogee Hsieh
At dp_display_disable(), do not re initialize audio_comp if hdp_state == ST_DISCONNECT_PENDING (unplug event) to avoid race condition which cause 5 second timeout expired. Also add abort mechanism to reduce time spinning at dp_aux_transfer() during dpcd read if type-c connection had been broken.

Re: [Freedreno] [PATCH 0/8] drm/msm: Swappable GEM objects

2021-04-12 Thread Daniel Vetter
On Mon, Apr 12, 2021 at 08:23:33AM -0700, Rob Clark wrote: > On Mon, Apr 12, 2021 at 7:28 AM Daniel Vetter wrote: > > > > On Thu, Apr 08, 2021 at 08:23:42AM -0700, Rob Clark wrote: > > > On Thu, Apr 8, 2021 at 4:15 AM Daniel Vetter wrote: > > > > > > > > On Mon, Apr 05, 2021 at 10:45:23AM -0700,

[Freedreno] [PATCH AUTOSEL 4.19 10/28] drm/msm: Fix a5xx/a6xx timestamps

2021-04-12 Thread Sasha Levin
From: Rob Clark [ Upstream commit 9fbd3088351b92e8c2cef6e37a39decb12a8d5bb ] They were reading a counter that was configured to ALWAYS_COUNT (ie. cycles that the GPU is doing something) rather than ALWAYS_ON. This isn't the thing that userspace is looking for. Signed-off-by: Rob Clark

[Freedreno] [PATCH AUTOSEL 5.4 16/39] drm/msm: Fix a5xx/a6xx timestamps

2021-04-12 Thread Sasha Levin
From: Rob Clark [ Upstream commit 9fbd3088351b92e8c2cef6e37a39decb12a8d5bb ] They were reading a counter that was configured to ALWAYS_COUNT (ie. cycles that the GPU is doing something) rather than ALWAYS_ON. This isn't the thing that userspace is looking for. Signed-off-by: Rob Clark

[Freedreno] [PATCH AUTOSEL 5.10 20/46] drm/msm: Fix a5xx/a6xx timestamps

2021-04-12 Thread Sasha Levin
From: Rob Clark [ Upstream commit 9fbd3088351b92e8c2cef6e37a39decb12a8d5bb ] They were reading a counter that was configured to ALWAYS_COUNT (ie. cycles that the GPU is doing something) rather than ALWAYS_ON. This isn't the thing that userspace is looking for. Signed-off-by: Rob Clark

[Freedreno] [PATCH AUTOSEL 5.11 24/51] drm/msm: Fix a5xx/a6xx timestamps

2021-04-12 Thread Sasha Levin
From: Rob Clark [ Upstream commit 9fbd3088351b92e8c2cef6e37a39decb12a8d5bb ] They were reading a counter that was configured to ALWAYS_COUNT (ie. cycles that the GPU is doing something) rather than ALWAYS_ON. This isn't the thing that userspace is looking for. Signed-off-by: Rob Clark

Re: [Freedreno] [PATCH 0/8] drm/msm: Swappable GEM objects

2021-04-12 Thread Rob Clark
On Mon, Apr 12, 2021 at 7:28 AM Daniel Vetter wrote: > > On Thu, Apr 08, 2021 at 08:23:42AM -0700, Rob Clark wrote: > > On Thu, Apr 8, 2021 at 4:15 AM Daniel Vetter wrote: > > > > > > On Mon, Apr 05, 2021 at 10:45:23AM -0700, Rob Clark wrote: > > > > From: Rob Clark > > > > > > > > One would

Re: [Freedreno] [PATCH 0/8] drm/msm: Swappable GEM objects

2021-04-12 Thread Daniel Vetter
On Thu, Apr 08, 2021 at 08:23:42AM -0700, Rob Clark wrote: > On Thu, Apr 8, 2021 at 4:15 AM Daniel Vetter wrote: > > > > On Mon, Apr 05, 2021 at 10:45:23AM -0700, Rob Clark wrote: > > > From: Rob Clark > > > > > > One would normally hope not to be under enough memory pressure to need > > > to