Hi Kuogee,
On 13-12-21, 15:47, Kuogee Hsieh wrote:
> From: Kuogee Hsieh
The patch is sent by Kuogee Hsieh , the patch
author is Kuogee Hsieh and s-o-b Kuogee Hsieh
.
Sorry but they need to match before I can pick this.
(Hint: git commit --amend --reset-author would do so provided gitconfig
has
The code that uses variable mdss has been removed, So the declaration
and assignment of the variable can be removed.
Eliminate the following clang warning:
drivers/gpu/drm/msm/msm_drv.c:513:19: warning: variable 'mdss' set but
not used [-Wunused-but-set-variable]
Reported-by: Abaci Robot
Fixes:
Add the missing layer mixer register dump information to
dpu snapshot to assist debugging.
Reviewed-by: Dmitry Baryshkov
Signed-off-by: Abhinav Kumar
---
drivers/gpu/drm/msm/disp/dpu1/dpu_kms.c | 5 +
1 file changed, 5 insertions(+)
diff --git a/drivers/gpu/drm/msm/disp/dpu1/dpu_kms.c
b/d
On 15/12/2021 20:45, Rob Clark wrote:
From: Rob Clark
We'll re-use this for debugfs.
Signed-off-by: Rob Clark
---
drivers/gpu/drm/msm/disp/msm_disp_snapshot.c | 28 +++-
drivers/gpu/drm/msm/disp/msm_disp_snapshot.h | 10 +++
2 files changed, 31 insertions(+), 7 deletio
On 12/9/2021 4:19 PM, Dmitry Baryshkov wrote:
On 10/12/2021 01:27, Abhinav Kumar wrote:
On 12/9/2021 2:18 PM, Abhinav Kumar wrote:
On 12/1/2021 2:26 PM, Dmitry Baryshkov wrote:
We are preparing to change DPU plane implementation. Move SSPP debugfs
code from dpu_plane.c to dpu_hw_sspp.c,
On 12/15/2021 8:09 AM, Dmitry Baryshkov wrote:
Implement plane's atomic_print_state() callback, printing DPU-specific
plane state: blending stage, SSPP and multirect mode and index.
Signed-off-by: Dmitry Baryshkov
Reviewed-by: Abhinav Kumar
---
drivers/gpu/drm/msm/disp/dpu1/dpu_plane.c
On 12/15/2021 8:09 AM, Dmitry Baryshkov wrote:
Implement CRTC's atomic_print_state() callback, printing DPU-specific
CRTC state (LM, CTL and DSPP ids).
Signed-off-by: Dmitry Baryshkov
Reviewed-by: Abhinav Kumar
---
drivers/gpu/drm/msm/disp/dpu1/dpu_crtc.c | 15 +++
1 file c
Quoting Dmitry Baryshkov (2021-12-15 12:02:37)
> On 14/12/2021 22:46, Marijn Suijten wrote:
> > Hi all,
> >
> > On 2021-09-18 16:40:38, Marijn Suijten wrote:
> >> On 2021-09-14 14:44:01, Stephen Boyd wrote:
> >>> Quoting Marijn Suijten (2021-09-11 06:19:19)
> All DSI PHY/PLL drivers were refe
On Wed, 15 Dec 2021 at 23:09, Rob Clark wrote:
>
> On Wed, Dec 15, 2021 at 11:17 AM Dmitry Baryshkov
> wrote:
> >
> > On Wed, 15 Dec 2021 at 20:49, Rob Clark wrote:
> > >
> > > From: Rob Clark
> > >
> > > Add UTS_RELEASE and show timestamp the same way for consistency.
> > >
> > > Signed-off-by
On Wed, Dec 15, 2021 at 8:45 AM Dmitry Baryshkov
wrote:
>
> Hi,
>
> On 09/12/2021 00:23, Rob Clark wrote:
> > On Wed, Dec 8, 2021 at 10:01 AM Dmitry Baryshkov
> > wrote:
> >>
> >> msm_ioremap() functions take additional argument dbgname used to output
> >> single debug line telling IO range. Drop
On Wed, Dec 15, 2021 at 11:17 AM Dmitry Baryshkov
wrote:
>
> On Wed, 15 Dec 2021 at 20:49, Rob Clark wrote:
> >
> > From: Rob Clark
> >
> > Add UTS_RELEASE and show timestamp the same way for consistency.
> >
> > Signed-off-by: Rob Clark
>
> Reviewed-by: Dmitry Baryshkov
>
> > ---
> > drivers
On Wed, Dec 15, 2021 at 11:10 AM Stephen Boyd wrote:
>
> Quoting Rob Clark (2021-12-15 09:59:02)
> > From: Rob Clark
> >
> > No functional change, as we only actually enable autosuspend for the GPU
> > device. But lets not encourage thinking that autosuspend is a good idea
> > for anything displ
On 14/12/2021 22:46, Marijn Suijten wrote:
Hi all,
On 2021-09-18 16:40:38, Marijn Suijten wrote:
On 2021-09-14 14:44:01, Stephen Boyd wrote:
Quoting Marijn Suijten (2021-09-11 06:19:19)
All DSI PHY/PLL drivers were referencing their VCO parent clock by a
global name, most of which don't exist
On 11/09/2021 16:19, Marijn Suijten wrote:
All DSI PHY/PLL drivers were referencing their VCO parent clock by a
global name, most of which don't exist or have been renamed. These
clock drivers seem to function fine without that except the 14nm driver
for sdm6xx [1].
At the same time all DTs pro
On 15/12/2021 20:45, Rob Clark wrote:
From: Rob Clark
Signed-off-by: Rob Clark
Reviewed-by: Dmitry Baryshkov
---
v2: Drop unneeded msm_kms_show_priv [Dmitry B]
drivers/gpu/drm/msm/msm_debugfs.c | 75 +++
1 file changed, 75 insertions(+)--
With best wishes
Quoting cgel@gmail.com (2021-12-15 00:55:54)
> From: Changcheng Deng
>
> Remove unneeded variable used to store return value.
>
> Reported-by: Zeal Robot
> Signed-off-by: Changcheng Deng
> ---
Reviewed-by: Stephen Boyd
Quoting Dmitry Baryshkov (2021-12-15 08:09:12)
> Implement plane's atomic_print_state() callback, printing DPU-specific
> plane state: blending stage, SSPP and multirect mode and index.
>
> Signed-off-by: Dmitry Baryshkov
> ---
Same const comment applies here
Reviewed-by: Stephen Boyd
Quoting Dmitry Baryshkov (2021-12-15 08:09:11)
> Implement CRTC's atomic_print_state() callback, printing DPU-specific
> CRTC state (LM, CTL and DSPP ids).
>
> Signed-off-by: Dmitry Baryshkov
> ---
> drivers/gpu/drm/msm/disp/dpu1/dpu_crtc.c | 15 +++
> 1 file changed, 15 insertions(+)
On Wed, 15 Dec 2021 at 20:49, Rob Clark wrote:
>
> From: Rob Clark
>
> We'll re-use this for debugfs.
>
> Signed-off-by: Rob Clark
Reviewed-by: Dmitry Baryshkov
> ---
> drivers/gpu/drm/msm/disp/msm_disp_snapshot.c | 28 +++-
> drivers/gpu/drm/msm/disp/msm_disp_snapshot.h | 10
On Wed, 15 Dec 2021 at 20:49, Rob Clark wrote:
>
> From: Rob Clark
>
> Add UTS_RELEASE and show timestamp the same way for consistency.
>
> Signed-off-by: Rob Clark
Reviewed-by: Dmitry Baryshkov
> ---
> drivers/gpu/drm/msm/disp/msm_disp_snapshot.h | 4 ++--
> drivers/gpu/drm/msm/disp/ms
On Wed, 15 Dec 2021 at 22:10, Stephen Boyd wrote:
>
> Quoting Rob Clark (2021-12-15 09:59:02)
> > From: Rob Clark
> >
> > No functional change, as we only actually enable autosuspend for the GPU
> > device. But lets not encourage thinking that autosuspend is a good idea
> > for anything display
Quoting Rob Clark (2021-12-15 09:59:02)
> From: Rob Clark
>
> No functional change, as we only actually enable autosuspend for the GPU
> device. But lets not encourage thinking that autosuspend is a good idea
> for anything display related.
I'd prefer to see a small blurb about why it's not a go
From: Rob Clark
No functional change, as we only actually enable autosuspend for the GPU
device. But lets not encourage thinking that autosuspend is a good idea
for anything display related.
Signed-off-by: Rob Clark
---
drivers/gpu/drm/msm/dsi/dsi_host.c | 8
drivers/gpu/drm/msm/
From: Rob Clark
Signed-off-by: Rob Clark
---
v2: Drop unneeded msm_kms_show_priv [Dmitry B]
drivers/gpu/drm/msm/msm_debugfs.c | 75 +++
1 file changed, 75 insertions(+)
diff --git a/drivers/gpu/drm/msm/msm_debugfs.c
b/drivers/gpu/drm/msm/msm_debugfs.c
index 956b1e
From: Rob Clark
We'll re-use this for debugfs.
Signed-off-by: Rob Clark
---
drivers/gpu/drm/msm/disp/msm_disp_snapshot.c | 28 +++-
drivers/gpu/drm/msm/disp/msm_disp_snapshot.h | 10 +++
2 files changed, 31 insertions(+), 7 deletions(-)
diff --git a/drivers/gpu/drm/msm/dis
From: Rob Clark
Add UTS_RELEASE and show timestamp the same way for consistency.
Signed-off-by: Rob Clark
---
drivers/gpu/drm/msm/disp/msm_disp_snapshot.h | 4 ++--
drivers/gpu/drm/msm/disp/msm_disp_snapshot_util.c | 9 ++---
2 files changed, 8 insertions(+), 5 deletions(-)
diff --gi
From: Rob Clark
This series adds a "kms" debugfs file to dump display register + atomic
state, which is useful for debugging issues that don't trigger a display
error irq (such as dsi phy misconfiguration).
Rob Clark (3):
drm/msm/disp: Tweak display snapshot to match gpu snapshot
drm/msm/dis
On 15/12/2021 14:49, Dan Carpenter wrote:
The "dp_bridge" pointer is allocated with devm_kzalloc() so it will be
freed automatically. Kfreeing it here will only lead to a double free.
Fixes: 8a3b4c17f863 ("drm/msm/dp: employ bridge mechanism for display enable and
disable")
Signed-off-by: Dan
Hi,
On 09/12/2021 00:23, Rob Clark wrote:
On Wed, Dec 8, 2021 at 10:01 AM Dmitry Baryshkov
wrote:
msm_ioremap() functions take additional argument dbgname used to output
single debug line telling IO range. Drop that extra argument, use
resource name instead.
For some history, the dbgname tr
Implement plane's atomic_print_state() callback, printing DPU-specific
plane state: blending stage, SSPP and multirect mode and index.
Signed-off-by: Dmitry Baryshkov
---
drivers/gpu/drm/msm/disp/dpu1/dpu_plane.c | 41 +++
1 file changed, 41 insertions(+)
diff --git a/driver
Implement CRTC's atomic_print_state() callback, printing DPU-specific
CRTC state (LM, CTL and DSPP ids).
Signed-off-by: Dmitry Baryshkov
---
drivers/gpu/drm/msm/disp/dpu1/dpu_crtc.c | 15 +++
1 file changed, 15 insertions(+)
diff --git a/drivers/gpu/drm/msm/disp/dpu1/dpu_crtc.c
b/d
The "dp_bridge" pointer is allocated with devm_kzalloc() so it will be
freed automatically. Kfreeing it here will only lead to a double free.
Fixes: 8a3b4c17f863 ("drm/msm/dp: employ bridge mechanism for display enable
and disable")
Signed-off-by: Dan Carpenter
---
drivers/gpu/drm/msm/dp/dp_dr
Hi
Am 15.12.21 um 12:04 schrieb Jani Nikula:
On Wed, 15 Dec 2021, Thomas Zimmermann wrote:
* move DP helper code into dp/ (Jani)
I suggested adding the subdirectory, but I'm going to bikeshed the name,
which I didn't suggest.
$ find drivers/gpu/drm -mindepth 1 -maxdepth 1 -type d |
On Wed, 15 Dec 2021, Thomas Zimmermann wrote:
> * move DP helper code into dp/ (Jani)
I suggested adding the subdirectory, but I'm going to bikeshed the name,
which I didn't suggest.
$ find drivers/gpu/drm -mindepth 1 -maxdepth 1 -type d | wc -l
68
Assuming we move more of the drm modules
Split the DP declarations from other helpers before moving the
DP functions into a separate module.
v2:
* forward-declare struct drm_dp_aux (Jani)
* add include guards in drm_dp_helper_internal.h
Signed-off-by: Thomas Zimmermann
---
drivers/gpu/drm/drm_crtc_helper_internal.h | 2
Move drm_dp_aux_bus.c and its header file into the DP subdirectory
and update all users. No functional changes.
Signed-off-by: Thomas Zimmermann
---
drivers/gpu/drm/Makefile | 2 --
drivers/gpu/drm/bridge/parade-ps8640.c | 2 +-
drivers/gpu/drm/bridge/ti-sn65dsi
Move all public DisplayPort headers into dp and update users. No
functional changes.
Signed-off-by: Thomas Zimmermann
---
drivers/gpu/drm/amd/amdgpu/amdgpu_connectors.c | 2 +-
drivers/gpu/drm/amd/amdgpu/amdgpu_mode.h| 4 ++--
drivers/gpu/drm/amd/amdgpu/atombios_
Fix coding style.
Signed-off-by: Thomas Zimmermann
---
drivers/gpu/drm/drm_dp_mst_topology.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/gpu/drm/drm_dp_mst_topology.c
b/drivers/gpu/drm/drm_dp_mst_topology.c
index f3d79eda94bb..7f0ff96261cf 100644
--- a/drivers/gp
Move DisplayPort functions into a separate module to reduce the size
of the KMS helpers. Select DRM_DP_HELPER for all users of the code. To
avoid naming conflicts, rename drm_dp_helper.c to drm_dp.c
This change can help to reduce the size of the kernel binary. Some
numbers from a x86-64 test build
Split-off DisplayPort functions from KMS helper library and move them
into their own module. Reduces the size of drm_kms_helper.ko by ~50%.
This patchset is part of an on-going effort to reduce the minimum
binary size of the DRM core and helpers. It's helpful for systems with
early-boot DRM graphi
On Mon, 13 Dec 2021, Thomas Zimmermann wrote:
> Hi
>
> Am 13.12.21 um 14:34 schrieb Jani Nikula:
>> On Mon, 13 Dec 2021, Thomas Zimmermann wrote:
>>> Split-off DisplayPort functions from KMS helper library and move them
>>> into their own module. Reduces the size of drm_kms_helper.ko by ~50%.
>>>
From: Changcheng Deng
Remove unneeded variable used to store return value.
Reported-by: Zeal Robot
Signed-off-by: Changcheng Deng
---
drivers/gpu/drm/msm/dp/dp_display.c | 3 +--
1 file changed, 1 insertion(+), 2 deletions(-)
diff --git a/drivers/gpu/drm/msm/dp/dp_display.c
b/drivers/gpu/dr
42 matches
Mail list logo