Re: [Freedreno] [PATCH v2 5/6] drm/panfrost: Implement generic DRM object RSS reporting function

2023-08-31 Thread Adrián Larumbe
On 30.08.2023 12:52, Boris Brezillon wrote: >On Thu, 24 Aug 2023 02:34:48 +0100 >Adrián Larumbe wrote: > >> BO's RSS is updated every time new pages are allocated and mapped for the >> object, either in its entirety at creation time for non-heap buffers, or >> else on demand for heap buffers at

Re: [Freedreno] [PATCH v2 2/6] drm/panfrost: Add fdinfo support GPU load metrics

2023-08-31 Thread Adrián Larumbe
On 30.08.2023 12:17, Boris Brezillon wrote: >On Thu, 24 Aug 2023 02:34:45 +0100 >Adrián Larumbe wrote: > >> The drm-stats fdinfo tags made available to user space are drm-engine, >> drm-cycles, drm-max-freq and drm-curfreq, one per job slot. > >Pretty sure this has already been discussed, but

Re: [Freedreno] [PATCH v2 3/6] drm/panfrost: Add fdinfo support for memory stats

2023-08-31 Thread Adrián Larumbe
On 30.08.2023 12:31, Boris Brezillon wrote: >On Thu, 24 Aug 2023 02:34:46 +0100 >Adrián Larumbe wrote: > >> A new DRM GEM object function is added so that drm_show_memory_stats can >> provider more accurate memory usage numbers. > > s/provider/provide/ > >> >> Ideally, in panfrost_gem_status,

[Freedreno] [PATCH] MAINTAINERS: Add Jessica as a reviewer for drm/panel

2023-08-31 Thread Jessica Zhang
As I participate more actively in the drm/panel subsystem, I would like to get notified about new changes in this area. Since I have contributed and continue to contribute to drm/panel, add myself as a reviewer for the DRM panel drivers to help the review process Signed-off-by: Jessica Zhang

Re: [Freedreno] [PATCH v2 2/6] drm/panfrost: Add fdinfo support GPU load metrics

2023-08-31 Thread Adrián Larumbe
On 31.08.2023 16:54, Steven Price wrote: >On 24/08/2023 02:34, Adrián Larumbe wrote: >> The drm-stats fdinfo tags made available to user space are drm-engine, >> drm-cycles, drm-max-freq and drm-curfreq, one per job slot. >> >> This deviates from standard practice in other DRM drivers, where a

Re: [Freedreno] [PATCH 7/7] drm/msm/dp: Remove dp_display_is_ds_bridge()

2023-08-31 Thread Kuogee Hsieh
On 8/29/2023 11:47 AM, Stephen Boyd wrote: This function is simply drm_dp_is_branch() so use that instead of open-coding it. Cc: Vinod Polimera Cc: Kuogee Hsieh Signed-off-by: Stephen Boyd Tested-by: Kuogee Hsieh Reviewed-by: Kuogee Hsieh --- drivers/gpu/drm/msm/dp/dp_display.c | 9

Re: [Freedreno] [PATCH 4/7] drm/msm/dp: Remove aux_cfg_update_done and related code

2023-08-31 Thread Kuogee Hsieh
On 8/29/2023 11:47 AM, Stephen Boyd wrote: The member 'aux_cfg_update_done' is always false. This is dead code that never runs. Remove it. Cc: Vinod Polimera Cc: Kuogee Hsieh Signed-off-by: Stephen Boyd Tested-by: Kuogee Hsieh Reviewed-by: Kuogee Hsieh ---

Re: [Freedreno] [PATCH 5/7] drm/msm/dp: Simplify with drm_dp_{max_link_rate, max_lane_count}()

2023-08-31 Thread Kuogee Hsieh
On 8/29/2023 11:47 AM, Stephen Boyd wrote: These are open-coded versions of common functions. Replace them with the common code to improve readability. Cc: Vinod Polimera Cc: Kuogee Hsieh Signed-off-by: Stephen Boyd Tested-by: Kuogee Hsieh Reviewed-by: Kuogee Hsieh ---

Re: [Freedreno] [PATCH 6/7] drm/msm/dp: Inline dp_link_parse_sink_count()

2023-08-31 Thread Kuogee Hsieh
On 8/29/2023 11:47 AM, Stephen Boyd wrote: The function dp_link_parse_sink_count() is really just drm_dp_read_sink_count(). It debug prints out the bit for content protection (DP_SINK_CP_READY), but that is not useful beyond debug because 'link->dp_link.sink_count' is overwritten to only

Re: [Freedreno] [PATCH 3/7] drm/msm/dp: Remove dead code related to downstream cap info

2023-08-31 Thread Kuogee Hsieh
On 8/29/2023 11:47 AM, Stephen Boyd wrote: We read the downstream port count and capability info but never use it anywhere. Remove 'ds_port_cnt' and 'ds_cap_info' and any associated code from this driver. Fold the check for 'dfp_present' into a call to drm_dp_is_branch() at the one place it is

Re: [Freedreno] [PATCH 3/7] drm/msm/dp: Remove dead code related to downstream cap info

2023-08-31 Thread Kuogee Hsieh
On 8/29/2023 11:47 AM, Stephen Boyd wrote: We read the downstream port count and capability info but never use it anywhere. Remove 'ds_port_cnt' and 'ds_cap_info' and any associated code from this driver. Fold the check for 'dfp_present' into a call to drm_dp_is_branch() at the one place it is

Re: [Freedreno] [PATCH 2/7] drm/msm/dp: Use drm_dp_read_sink_count() helper

2023-08-31 Thread Kuogee Hsieh
On 8/29/2023 11:47 AM, Stephen Boyd wrote: Use the common function drm_dp_read_sink_count() instead of open-coding it. This shrinks the kernel text a tiny bit. Cc: Vinod Polimera Cc: Kuogee Hsieh Signed-off-by: Stephen Boyd Tested-by: Kuogee Hsieh Reviewed-by: Kuogee Hsieh ---

Re: [Freedreno] [PATCH 1/7] drm/msm/dp: Replace open-coded drm_dp_read_dpcd_caps()

2023-08-31 Thread Kuogee Hsieh
On 8/29/2023 11:47 AM, Stephen Boyd wrote: This function duplicates the common function drm_dp_read_dpcd_caps(). The array of DPCD registers filled in is one size larger than the function takes, but from what I can tell that extra byte was never used. Resize the array and use the common