[Freedreno] [PATCH -next] drm/msm/adreno: adreno_gpu: Switch to memdup_user_nul() helper

2023-08-10 Thread Ruan Jinjie
Use memdup_user_nul() helper instead of open-coding to simplify the code. Signed-off-by: Ruan Jinjie --- drivers/gpu/drm/msm/adreno/adreno_gpu.c | 14 +++--- 1 file changed, 3 insertions(+), 11 deletions(-) diff --git a/drivers/gpu/drm/msm/adreno/adreno_gpu.c b/drivers/gpu/drm/msm

[Freedreno] [PATCH -next 6/7] drm/format-helper: Remove unnecessary NULL values

2023-08-08 Thread Ruan Jinjie
The NULL initialization of the pointers assigned by kunit_kzalloc() first is not necessary, because if kunit_kzalloc() failed, the pointers will be assigned NULL, otherwise it works as usual. so remove it. Signed-off-by: Ruan Jinjie --- .../gpu/drm/tests/drm_format_helper_test.c| 28

[Freedreno] [PATCH -next 7/7] drm: Remove unnecessary NULL values

2023-08-08 Thread Ruan Jinjie
The NULL initialization of the pointers assigned by kzalloc() first is not necessary, because if the kzalloc() failed, the pointers will be assigned NULL, otherwise it works as usual. so remove it. Signed-off-by: Ruan Jinjie --- drivers/gpu/drm/drm_agpsupport.c | 2 +- drivers/gpu/drm

[Freedreno] [PATCH -next 4/7] drm/radeon: Remove unnecessary NULL values

2023-08-08 Thread Ruan Jinjie
The NULL initialization of the pointers assigned by kzalloc() first is not necessary, because if the kzalloc() failed, the pointers will be assigned NULL, otherwise it works as usual. so remove it. Signed-off-by: Ruan Jinjie --- drivers/gpu/drm/radeon/radeon_agp.c | 2 +- drivers

[Freedreno] [PATCH -next 5/7] drm/virtio: Remove an unnecessary NULL value

2023-08-08 Thread Ruan Jinjie
The NULL initialization of the pointer assigned by kzalloc() first is not necessary, because if the kzalloc() failed, the pointer will be assigned NULL, otherwise it works as usual. so remove it. Signed-off-by: Ruan Jinjie --- drivers/gpu/drm/virtio/virtgpu_submit.c | 2 +- 1 file changed, 1

[Freedreno] [PATCH -next 3/7] drm/msm: Remove unnecessary NULL values

2023-08-08 Thread Ruan Jinjie
The NULL initialization of the pointers assigned by kzalloc() first is not necessary, because if the kzalloc() failed, the pointers will be assigned NULL, otherwise it works as usual. so remove it. Signed-off-by: Ruan Jinjie --- drivers/gpu/drm/msm/disp/dpu1/dpu_crtc.c | 2 +- drivers/gpu/drm

[Freedreno] [PATCH -next 2/7] drm/amd/display: Remove unnecessary NULL values

2023-08-08 Thread Ruan Jinjie
The NULL initialization of the pointers assigned by kzalloc() first is not necessary, because if the kzalloc() failed, the pointers will be assigned NULL, otherwise it works as usual. so remove it. Signed-off-by: Ruan Jinjie --- drivers/gpu/drm/amd/display/dc/bios/bios_parser.c | 4

[Freedreno] [PATCH -next 1/7] drm/amdkfd: Remove unnecessary NULL values

2023-08-08 Thread Ruan Jinjie
The NULL initialization of the pointers assigned by kzalloc() first is not necessary, because if the kzalloc() failed, the pointers will be assigned NULL, otherwise it works as usual. so remove it. Signed-off-by: Ruan Jinjie --- drivers/gpu/drm/amd/amdkfd/kfd_mqd_manager.c | 4 ++-- 1 file

[Freedreno] [PATCH -next 0/7] drm: Remove many unnecessary NULL values

2023-08-08 Thread Ruan Jinjie
The NULL initialization of the pointers assigned by kzalloc() or kunit_kzalloc() first is not necessary, because if the kzalloc() or kunit_kzalloc() failed, the pointers will be assigned NULL, otherwise it works as usual. so remove it. Ruan Jinjie (7): drm/amdkfd: Remove unnecessary NULL values

[Freedreno] [PATCH -next] drm/msm: Remove redundant DRM_DEV_ERROR()

2023-07-26 Thread Ruan Jinjie
There is no need to call the DRM_DEV_ERROR() function directly to print a custom message when handling an error from platform_get_irq() function as it is going to display an appropriate error message in case of a failure. Signed-off-by: Ruan Jinjie --- drivers/gpu/drm/msm/disp/mdp4/mdp4_kms.c