Re: [RFC] LTO Dead Field Elimination and LTO Field Reordering

2020-08-20 Thread Erick Ochoa
Thanks Tamar, as a note: I just pushed the changes that removes GCC's compile time warnings (as in building these transformations will output less warnings.) Fuzzying the code found no random programs out of 50,000 that triggered errors with field reordering and dead field elimination (i.e. -

assume","at","ate","atm","attached","attachment

2020-08-20 Thread Bear 4sythe via Gcc
Bear's iPhone

[RFC] Add new flag to specify output constraint in match.pd

2020-08-20 Thread Feng Xue OS via Gcc
Hi, There is a match-folding issue derived from pr94234. A piece of code like: int foo (int n) { int t1 = 8 * n; int t2 = 8 * (n - 1); return t1 - t2; } It can be perfectly caught by the rule "(A * C) +- (B * C) -> (A +- B) * C", and be folded to constant "8". But thi

gcc-8-20200820 is now available

2020-08-20 Thread GCC Administrator via Gcc
Snapshot gcc-8-20200820 is now available on https://gcc.gnu.org/pub/gcc/snapshots/8-20200820/ and on various mirrors, see http://gcc.gnu.org/mirrors.html for details. This snapshot has been generated from the GCC 8 git branch with the following options: git://gcc.gnu.org/git/gcc.git branch

RE: [RFC] LTO Dead Field Elimination and LTO Field Reordering

2020-08-20 Thread Tamar Christina
Hi Erick, Thanks for updating the branch! From some initial testing it seems to result in some nice gains for mcf but also in lower peak memory usage and smaller binaries even for benchmarks that don't show an improvement in runtime though I haven't looked at these more closely yet. I think y

Re: Clobber REG_CC only for some constraint alternatives?

2020-08-20 Thread Hans-Peter Nilsson
On Thu, 20 Aug 2020, Senthil Kumar Selvaraj wrote: > What I didn't understand was the (set-attr "cc") > part - as far I can tell, this results in (set_attr "cc_enabled" ...) in > all of the three substituted patterns, so I wondered why not just have > (set_attr "cc_enabled" ...) in the original de

Re: Clobber REG_CC only for some constraint alternatives?

2020-08-20 Thread Senthil Kumar Selvaraj via Gcc
Pip Cet writes: > On Tue, Aug 18, 2020 at 6:52 AM Senthil Kumar Selvaraj > wrote: >> > recognize such insns, but as it stands that define_insn would >> > recognize the incorrect insn: >> > >> > [(set (reg:QI 0) (const_int 0)) >> > (clobber (scratch:CC))] >> >> get_cc_reg_clobber_rtx also looks

Re: Clobber REG_CC only for some constraint alternatives?

2020-08-20 Thread Pip Cet via Gcc
On Tue, Aug 18, 2020 at 6:52 AM Senthil Kumar Selvaraj wrote: > > recognize such insns, but as it stands that define_insn would > > recognize the incorrect insn: > > > > [(set (reg:QI 0) (const_int 0)) > > (clobber (scratch:CC))] > > get_cc_reg_clobber_rtx also looks at the insn itself (i.e. what

Re: Clobber REG_CC only for some constraint alternatives?

2020-08-20 Thread H.J. Lu via Gcc
On Thu, Aug 20, 2020 at 1:53 AM Andrew Stubbs wrote: > > On 20/08/2020 06:40, Senthil Kumar Selvaraj via Gcc wrote: > > What I didn't understand was the (set-attr "cc") > > part - as far I can tell, this results in (set_attr "cc_enabled" ...) in > > all of the three substituted patterns, so I wond

Question about Gimple Variables named D.[0-9]*

2020-08-20 Thread Erick Ochoa
Hello, I am looking at the dump for the build_alias pass. I see a lot of variables with the naming convention D.[0-9]* in the points-to sets being printed. When I compile with -fdump-tree-all-all I can see that the suffix D.[0-9]* is appended to some gimple variables. I initially imagined

Re: Clobber REG_CC only for some constraint alternatives?

2020-08-20 Thread Andrew Stubbs
On 20/08/2020 06:40, Senthil Kumar Selvaraj via Gcc wrote: What I didn't understand was the (set-attr "cc") part - as far I can tell, this results in (set_attr "cc_enabled" ...) in all of the three substituted patterns, so I wondered why not just have (set_attr "cc_enabled" ...) in the original d