in "obstack.h" in the \include dir of the GCC 4.1.2 release, the macro
definition for the obstack_int_grow_fast function is as follows:

# define obstack_int_grow_fast(h,aint)                                  \
  (((int *) ((h)->next_free += sizeof (int)))[-1] = (aptr))

shouldn't the right side of the assignment in the second line be "aint"
instead?


-- 
           Summary: obstack.h typo
           Product: gcc
           Version: 4.1.2
            Status: UNCONFIRMED
          Severity: normal
          Priority: P3
         Component: c
        AssignedTo: unassigned at gcc dot gnu dot org
        ReportedBy: george at houseofellery dot com


http://gcc.gnu.org/bugzilla/show_bug.cgi?id=31233

Reply via email to