>At 2013-01-22 19:58:43,"Ramana Radhakrishnan" wrote:>
> > On 01/22/13 09:21, Xinyu Qi wrote:
> > > Ping,
> > >
> > > Fix ChangeLog
> >
> > The ChangeLog format includes .
> >
> >
> >
> > If you want a patch accepted in the future, please help by creating
> > the Changelog entry in the correc
Hi,
as I mentioned a few days ago, since this function grew rather big, I
hope to clean it up a bit. For now at least nothing ground shaking: I
moved together some declarations and initializations; in other cases
exploited the opportunity C++ gives to defer declarations; consistently
changed
> Looks fine, including the factor of 2 distinction between Kind and Star for
> Complex types. I don't have any opinion on how complete
> this is, someone who uses Fortran more extensively will know whether other
> interface types might be useful.
Thanks Ed.
So Tobias: you can go ahead and commi
Looks fine, including the factor of 2 distinction between Kind and Star for
Complex types. I don't have any opinion on how complete
this is, someone who uses Fortran more extensively will know whether other
interface types might be useful.
Ed
On Mar 19, 2013, at 5:51 PM, Arnaud Charlet wrote
> I would like if some of the Ada/GNAT experts could have a look - as
> this is really my first look at Ada code.
Patch looks reasonable to me at first sight, but I'm not a Fortran specialist.
Ed, Robert, could you have a look?
> 2013-03-19 Tobias Burnus
>
> * i-fortra.ads: Update comm
> -Original Message-
> From: Michael Eager [mailto:ea...@eagerm.com]
> Sent: Wednesday, 20 March 2013 3:05 am
> To: David Holsgrove
> Cc: gcc-patches@gcc.gnu.org; Edgar Iglesias; John Williams; Vinod Kathail;
> Vidhumouli Hunsigida; Nagaraju Mekala; Tom Shui
> Subject: Re: [Patch, microbla
> -Original Message-
> From: Richard Sandiford [mailto:rdsandif...@googlemail.com]
> Sent: Tuesday, March 19, 2013 3:26 PM
> To: Moore, Catherine
> Cc: gcc-patches@gcc.gnu.org; Rozycki, Maciej
> Subject: Re: FW: [PATCH] [MIPS] microMIPS gcc support
>
> "Moore, Catherine" writes:
> >> >>
"Moore, Catherine" writes:
>> -Original Message-
>> From: Richard Sandiford [mailto:rdsandif...@googlemail.com]
>> Sent: Tuesday, March 19, 2013 3:26 PM
>> To: Moore, Catherine
>> Cc: gcc-patches@gcc.gnu.org; Rozycki, Maciej
>> Subject: Re: FW: [PATCH] [MIPS] microMIPS gcc support
>>
>> "
On 03/16/2013 06:29 AM, Andi Kleen wrote:
> 2013-03-15 Andi Kleen
>
> * gcas.c: (EXACT_INLINE): Use __ATOMIC_SEQ_CST.
> * gexch.c: (EXACT_INLINE): Use __ATOMIC_SEQ_CST.
> * gload.c: (EXACT_INLINE): Use __ATOMIC_SEQ_CST.
> * gstore.c: (EXACT_INLINE): Use __ATOMIC_SEQ_CST.
On 03/16/2013 06:29 AM, Andi Kleen wrote:
> 2013-03-15 Andi Kleen
>
> * local_atomic (__always_inline): Add.
> (__calculate_memory_order, atomic_thread_fence,
>atomic_signal_fence, test_and_set, clear, store, load,
> exchange, compare_exchange_weak, compare_exchange
On 03/16/2013 06:29 AM, Andi Kleen wrote:
> +"Non constant memory model: Assuming __ATOMIC_SEQ_CST");
Warnings and error messages are all lower case. Otherwise it seems...
well, I didn't want to say "ok", but certainly "unavoidable".
r~
On 03/19/2013 08:47 AM, Marc Glisse wrote:
> (define_insn_and_split "avx__"
>[(set (match_operand:AVX256MODE2P 0 "nonimmediate_operand" "=x,m")
> - (unspec:AVX256MODE2P
> - [(match_operand: 1 "nonimmediate_operand" "xm,x")]
> - UNSPEC_CAST))]
> + (subreg:AVX256MODE2P
> +
On Tue, 19 Mar 2013 12:01:12 +0100, Tobias Burnus wrote:
Am 07.03.2013 17:35, schrieb Tilo Schwarz:
On Thu, 07 Mar 2013 12:46:10 +0100, Tobias Burnus
wrote:
Tilo Schwarz wrote:
this patch fixes PR 48618.
Built and regtested on Linux 3.2.0-4-686-pae.
Thanks for the patch, which mostly loo
Dear Paul, dear all,
On February 24, 2013 Paul Richard Thomas wrote:
The attached patch represents progress to date. It fixes the original
problem in this PR and allows John Reid's version of
iso_varying_string/vocabulary_word_count.f90 to compile and run
correctly. It even bootstraps and regt
"Moore, Catherine" writes:
>> >> -Original Message-
>> >> From: Richard Sandiford [mailto:rdsandif...@googlemail.com]
>> >> Sent: Tuesday, March 05, 2013 4:06 PM
>> >> To: Moore, Catherine
>> >> Cc: gcc-patches@gcc.gnu.org; Rozycki, Maciej
>> >> Subject: Re: FW: [PATCH] [MIPS] microMIPS gc
On Tue, Mar 19, 2013 at 7:31 PM, Jeff Law wrote:
> On 03/19/2013 11:58 AM, Ian Lance Taylor wrote:
>>
>> On Tue, Mar 19, 2013 at 8:33 AM, David Miller wrote:
>>>
>>>
>>> So this patch tries to rework the semantics of hard register classes,
>>> such that if a hard register is present in the set it i
This patch updates one comment regarding "logical":
* The Fortran standard requires that (default-kind) "logical" and
"integer" have the same size; that's generally the case, i.e. also for
arrays or in structures (derived types)
* Fortran does not use zero/nonzero semantics but only .true. and
Hello!
Attached patch slightly improves {TF,DF,SF,TI,DI,SI}mode move patterns
by calculating various attributes in a more clear way, the patch
reorders operand alternatives to avoid checks for interleaved
"alternatives" and implements various other janitorial improvements.
In addition, the patch f
On 03/19/2013 11:58 AM, Ian Lance Taylor wrote:
On Tue, Mar 19, 2013 at 8:33 AM, David Miller wrote:
So this patch tries to rework the semantics of hard register classes,
such that if a hard register is present in the set it is implied that
the rest of the registers in a multi-register group a
On 13-03-16 10:40 PM, Jason Merrill wrote:
On 03/16/2013 03:28 PM, Jason Merrill wrote:
I have no idea why the existing code tried to deduce the desired quals
from current_class_ref rather than just look at the object it has.
Well, maybe now I do; when I tested all my changes again before chec
On Tue, Mar 19, 2013 at 07:05:12PM +0100, Tobias Burnus wrote:
> I assume, you will create the gomp-4_0-branch when gcc.gnu.org is
> fully operational. Additionally, I presume, the change-log
> information should go to the file ChangeLog.gomp and not to
> ChangeLog.
Yes and yes.
> 2013-03-19 Tob
Jakub Jelinek wrote:
+#include
+#include /* For PRIu64. */
stdio.h is fine, but inttypes.h needs to be
#ifdef HAVE_INTTYPES_H
# include
#endif
for portability (libgomp/configure already checks for that).
Good point. Attached the updated patch.
I assume, you will create the gomp-4_0-b
On Tue, Mar 19, 2013 at 8:33 AM, David Miller wrote:
>
> So this patch tries to rework the semantics of hard register classes,
> such that if a hard register is present in the set it is implied that
> the rest of the registers in a multi-register group are present as
> well. So we can add a regis
On Tue, Mar 19, 2013 at 05:10:22PM +0100, Jakub Jelinek wrote:
> On Tue, Mar 19, 2013 at 08:51:21AM -0700, Andi Kleen wrote:
> > > Using __always_inline as the name of the macro is a bad idea, glibc
> > > headers use that macro already. Just use something else in public headers
> > > that aren't p
Am 19.03.2013 13:15, schrieb Janne Blomqvist:
now that the Fortran frontend is C++ we can use the primitive bool
type instead of inventing our own.
Well, C99's "bool" (_Bool) was already used before. The advantage of
FAILURE and SUCCESS is that they immediately make clear whether some
call wa
On Tue, Mar 19, 2013 at 04:24:04PM +0100, Tobias Burnus wrote:
> 2013-03-19 Tobias Burnus
>
> * env.c (handle_omp_display_env): New function.
> (initialize_env): Use it.
>
> diff --git a/libgomp/env.c b/libgomp/env.c
> index 65cbba8..e228bd9 100644
> --- a/libgomp/env.c
> +++ b/lib
Rainer Orth wrote:
As discussed in PR fortran/54932, the gfortran.dg/do_1.f90 execution
tests recently stated to XPASS at all optimization levels, adding lots
of testsuite noise. The following patch removes the xfail, allowing all
tests to pass.
Tested with the appropriate runtest invocations o
Hello,
as explained in the PR, the goal of this patch is to have a more canonical
form for RTL expressions, so it is easier to model them with a small
number of patterns.
This patch passes bootstrap+testsuite on x86_64-linux-gnu. Using the
opposite arbitrary order in compare_commutative_oper
On 03/18/2013 05:47 AM, David Holsgrove wrote:
Add DWARF exception handling support for MicroBlaze.
Changelog
2013-03-18 Edgar E. Iglesias
David Holsgrove
* common/config/microblaze/microblaze-common.c: Remove
TARGET_EXCEPT_UNWIND_INFO definition.
* config/microblaze/mi
On Tue, 19 Mar 2013, Jeff Law wrote:
On 03/19/2013 10:08 AM, Marc Glisse wrote:
Hello,
this patch extends the property that x*x is non-negative, which was
already known for floats, to integers with undefined overflow.
2013-03-19 Marc Glisse
PR tree-optimization/56355
gcc/
* fold
On Tue, Mar 19, 2013 at 05:34:08PM +0100, Tobias Burnus wrote:
> This patch adds documentation for OMP_DISPLAY_ENV, which was added
> by previously submitted patch, and it documents GOMP_SPINCOUNT,
> which was added 2010-12-02 but not yet documented.
>
> Additionally, I have updated the section re
This patch adds documentation for OMP_DISPLAY_ENV, which was added by
previously submitted patch, and it documents GOMP_SPINCOUNT, which was
added 2010-12-02 but not yet documented.
Additionally, I have updated the section references to OpenMP 4.0 (but
only for the environment section) and did
On 03/19/2013 10:08 AM, Marc Glisse wrote:
Hello,
this patch extends the property that x*x is non-negative, which was
already known for floats, to integers with undefined overflow.
2013-03-19 Marc Glisse
PR tree-optimization/56355
gcc/
* fold-const.c (tree_binary_nonnegative_warnv
On Tue, Mar 19, 2013 at 08:51:21AM -0700, Andi Kleen wrote:
> > Using __always_inline as the name of the macro is a bad idea, glibc
> > headers use that macro already. Just use something else in public headers
> > that aren't part of glibc.
>
> That's why I had the ifdef, but ok. I'll use __forc
Hello,
this patch extends the property that x*x is non-negative, which was
already known for floats, to integers with undefined overflow.
2013-03-19 Marc Glisse
PR tree-optimization/56355
gcc/
* fold-const.c (tree_binary_nonnegative_warnv_p) :
Also handle integers w
> Using __always_inline as the name of the macro is a bad idea, glibc
> headers use that macro already. Just use something else in public headers
> that aren't part of glibc.
That's why I had the ifdef, but ok. I'll use __force_inline then.
-Andi
Hello,
the following patch passes bootstrap+testsuite on x86_64-linux-gnu. I
don't see any particular reason to forbid vector subregs of vectors, since
we can already do it through a scalar. And not using unspecs helps avoid
unnecessary copies.
2013-01-03 Marc Glisse
PR target/50
On Tue, 19 Mar 2013, Jakub Jelinek wrote:
> On Tue, Mar 19, 2013 at 04:21:46PM +0100, Richard Biener wrote:
> >
> > This fixes fallout reported for "Fix ???s in find_uses_to_rename".
> >
> > Bootstrapped and tested on x86_64-unknown-linux-gnu, scheduled for
> > commit.
> >
> > Richard.
> >
> >
On Tue, Mar 19, 2013 at 04:21:46PM +0100, Richard Biener wrote:
>
> This fixes fallout reported for "Fix ???s in find_uses_to_rename".
>
> Bootstrapped and tested on x86_64-unknown-linux-gnu, scheduled for
> commit.
>
> Richard.
>
> 2013-03-19 Richard Biener
>
> PR tree-optimization/
This is very much a work in progress, but I think it has potential
to solve the problem at hand.
A major blocker for using LRA on sparc is a fundamental limitation of
register classes as currently implemented.
If you have an instruction that requires an evenly aligned hard
register pair, you can
Attached is a first shot for OMP_DISPLAY_ENV. One could think about how
to handle GOMP_CPU_AFFINITY and OMP_WAIT_POLICY. I currently print an
empty list for affinity (although using GOMP_CPU_AFFINITY='' leads to a
warning that the list is empty) and for OMP_WAIT_POLICY, an unset
variable is han
This fixes fallout reported for "Fix ???s in find_uses_to_rename".
Bootstrapped and tested on x86_64-unknown-linux-gnu, scheduled for
commit.
Richard.
2013-03-19 Richard Biener
PR tree-optimization/
* tree-vect-loop-manip.c (slpeel_can_duplicate_loop_p): Do not
check
On Thu, Dec 6, 2012 at 6:19 PM, Marc Glisse wrote:
> Hello,
>
> this patch (for 4.9) introduces a property so we can check if vector
> operations have been lowered yet. It mimics the complex lowering property,
> and this required moving the -O0 vector lowering pass (otherwise it breaks
> many test
On Tue, Mar 19, 2013 at 9:06 AM, Marc Glisse wrote:
> Hello,
>
> new version of the patch. Note that for the simplification from {-1,-1}?a:b
> to a, I removed the test that b has no side effects and call
> pedantic_omit_one_operand_loc instead.
>
>
> Bootstrap + testsuite on x86_64-linux-gnu.
Ok.
On Tue, 19 Mar 2013, Richard Biener wrote:
>
> This adds a GC collection point after each pass instead just after
> those with TODO_ggc_collect in their todo. The patch will possibly
> slow-down gcac checking a bit (80 passes have TODO_ggc_collect,
> I didn't try to enumerate those that do not,
As discussed in PR fortran/54932, the gfortran.dg/do_1.f90 execution
tests recently stated to XPASS at all optimization levels, adding lots
of testsuite noise. The following patch removes the xfail, allowing all
tests to pass.
Tested with the appropriate runtest invocations on
x86_64-unknown-linu
This adds a GC collection point after each pass instead just after
those with TODO_ggc_collect in their todo. The patch will possibly
slow-down gcac checking a bit (80 passes have TODO_ggc_collect,
I didn't try to enumerate those that do not, but a grep shows we
may have up to 212 passes. OTOH g
As described in
Don't use DWARF 4 on Solaris
http://gcc.gnu.org/ml/gcc-patches/2012-05/msg00445.html
the Solaris linker couldn't handle CIEv3 in .eh_frame, so we defaulted
to DWARF 2 on Solaris in any configuration (Sun or GNU ld). This has
changed in Solaris 11.1, where the nece
The following fixes the most annoying ICE during loop verification
(get_loop_body ICEing) and re-structures things a bit. It also
fixes an ICE that occurs when trying to graph a corrupt loop tree
(I'm using that heavily, and ICEing within the graphing is
annoying - this doesn't fix the correspond
On Fri, Jan 18, 2013 at 1:32 AM, Steve Kargl
wrote:
> On Fri, Jan 18, 2013 at 01:19:37AM +0200, Janne Blomqvist wrote:
>>
>> the attached patch gets rid of the "enum try" in the Fortran runtime
>> library, replacing its usage with the standard C99 _Bool/bool.
>>
>> Regtested on x86_64-unknown-linu
Am 07.03.2013 17:35, schrieb Tilo Schwarz:
On Thu, 07 Mar 2013 12:46:10 +0100, Tobias Burnus
wrote:
Tilo Schwarz wrote:
this patch fixes PR 48618.
Built and regtested on Linux 3.2.0-4-686-pae.
Thanks for the patch, which mostly looks okay.
A few remarks:
Thank you for the feedback.
I incor
On Tue, Mar 19, 2013 at 9:35 AM, Jakub Jelinek wrote:
>> Attached patch merges TImode and DImode move patterns using x64 and
>> nox64 isa attributes.
>>
>> 2013-03-19 Uros Bizjak
>>
>> * config/i386/i386.md (*movti_internal): Merge from
>> *movti_internal_rex64 and *movti_internal_
On Mon, 18 Mar 2013, Richard Biener wrote:
>
> This moves VRP after late DOM. This is because VRP has a hard
> time dealing with non-copyproped (and not CSEd) IL and conveniently
> DOM provides both. I noticed this when working on PR56273 where
> we miss quite some VRP opportunities because of
Hi,
libstdc++ configure will check "shl_load". If shared library is disabled in
gcc and uclibc configure, the libstdc++ configure will fail for options like
-mthumb -march=armv7-r. The fail logs like:
.../libgcc.a(unwind-arm.o): In function `unwind_phase2_forced':
unwind-arm.c:(.text+0x282): unde
On Tue, Mar 19, 2013 at 08:40:04AM +0100, Uros Bizjak wrote:
> Attached patch merges TImode and DImode move patterns using x64 and
> nox64 isa attributes.
>
> 2013-03-19 Uros Bizjak
>
> * config/i386/i386.md (*movti_internal): Merge from
> *movti_internal_rex64 and *movti_internal_
Hello,
new version of the patch. Note that for the simplification from
{-1,-1}?a:b to a, I removed the test that b has no side effects and call
pedantic_omit_one_operand_loc instead.
Bootstrap + testsuite on x86_64-linux-gnu.
2013-03-19 Marc Glisse
gcc/
* tree.h (VECTOR_TYPE_P):
Hello!
Attached patch merges TImode and DImode move patterns using x64 and
nox64 isa attributes.
2013-03-19 Uros Bizjak
* config/i386/i386.md (*movti_internal): Merge from
*movti_internal_rex64 and *movti_internal_sse. Use x64 isa attribute.
(*movdi_internal): Merge w
On 19/03/2013, at 3:38 PM, rbmj wrote:
> On 16-Feb-13 23:21, Maxim Kuvyrkov wrote:
>> On 14/02/2013, at 10:18 AM, rbmj wrote:
>>> Here's the updated, (trivial) patch.
>>
>> Thanks. I'll apply this once 4.8 branches and trunk is back into
>> development mode.
>>
>
> Since GCC 4.9 has branched
On Mon, Mar 18, 2013 at 04:28:13PM +, Jonathan Wakely wrote:
> On 16 March 2013 13:29, Andi Kleen wrote:
> >
> > With inline __attribute__((always_inline)) these functions
> > get inlined even with -O0.
> >
> > I hardcoded the attribute in the header for now, assuming
> > that all compilers tha
59 matches
Mail list logo