Re: [Patch] regex_iterator and regex_token_iterator implementation

2013-07-21 Thread Paolo Carlini
Hi, >Great. This is the fixed version. Patch is Ok with me but before committing please give a chance to Jon and other interested parties to have a look. Two more general comments: when you opencode more than a few lines don't hesitate to add comments too (remember that the new code must be

Re: [Patch] regex_iterator and regex_token_iterator implementation

2013-07-21 Thread Tim Shen
On Mon, Jul 22, 2013 at 1:29 PM, Paolo Carlini wrote: > Definitely. For the usual reason that if somebody in user code has a macro > with the same name before including the header the code is busted. Of course > _M_ or _S_ (vs _uppercase) is our specific convention for data members and > statis

[ping] [PATCH] Fix pr57637

2013-07-21 Thread Zhenqiang Chen
Ping? Is the updated patch OK for trunk? Thanks! -Zhenqiang On 16 July 2013 17:29, Zhenqiang Chen wrote: > On 11 July 2013 18:31, Eric Botcazou wrote: >>> Shrink-wrap optimization sinks some instructions for more >>> opportunities. It uses DF_LR_BB_INFO (bb)->def to check whether BB >>> clobbe

Re: [Patch] regex_iterator and regex_token_iterator implementation

2013-07-21 Thread Paolo Carlini
Hi, >Should I change them all to "_M_" or "__" format, and why? Definitely. For the usual reason that if somebody in user code has a macro with the same name before including the header the code is busted. Of course _M_ or _S_ (vs _uppercase) is our specific convention for data members and st

Re: [Patch] regex_iterator and regex_token_iterator implementation

2013-07-21 Thread Tim Shen
On Mon, Jul 22, 2013 at 9:12 AM, Paolo Carlini wrote: > Also you are wrongly "un-uglyfying" many names, eg: > > - position_iterator __position; > - const value_type* __result; > - value_type__suffix; > - std::size_t __n; > - std::vector __subs; > > > Remembe

Re: testsuite patches (1/14): Request dwarf-2 output where needed

2013-07-21 Thread Jakub Jelinek
On Mon, Jul 22, 2013 at 10:31:03AM +0530, Senthil Kumar Selvaraj wrote: > On Sat, Jul 20, 2013 at 01:45:37AM -0400, Joern Rennecke wrote: > > Although the gcc.dg/debug/dwarf2/dwarf2.exp generally requests dwarf-2 > > information, so that the test will work with targets that have a different > > def

Re: testsuite patches (1/14): Request dwarf-2 output where needed

2013-07-21 Thread Senthil Kumar Selvaraj
On Sat, Jul 20, 2013 at 01:45:37AM -0400, Joern Rennecke wrote: > Although the gcc.dg/debug/dwarf2/dwarf2.exp generally requests dwarf-2 > information, so that the test will work with targets that have a different > default output format, that doesn't happen where the test specifies specific > targ

Re: [ubsan] Add libcall arguments

2013-07-21 Thread Jason Merrill
On 07/21/2013 02:26 PM, Marek Polacek wrote: (pointer_sized_type_node): Define. Let's call it pointer_sized_int_node. Jason

Re: RFC: Gimple combine/folding interface

2013-07-21 Thread Andrew Pinski
On Fri, Jul 19, 2013 at 5:09 PM, Andrew Pinski wrote: > I was creating a new gimple/folding interface and wanted some opinions > on the interface. > > typedef double_int (*nonzerobits_t)(tree var); > typedef tree (*valueizer_t)(tree var); > > class gimple_combine > { > public: > gimple_combine(n

[Patch, PR 57790] Waste work in can_move_insns_across()

2013-07-21 Thread pchang9
Hi, The problem appears in revision 201034 in version 4.9. I attached a one-line patch that fixes it. I also reported this problem at http://gcc.gnu.org/bugzilla/show_bug.cgi?id=57790 I bootstrapped and ran the regression tests for this patch on x86_64-linux and all tests pass. In method "can_

Re: [Patch] regex_iterator and regex_token_iterator implementation

2013-07-21 Thread Paolo Carlini
On 07/22/2013 02:47 AM, Tim Shen wrote: http://gcc.gnu.org/bugzilla/show_bug.cgi?id=57513 is already in the testsuite and can passed(even before this patch?). To fully test it, a fully regex_search implementation is required. I'm working on a (damning) backtracking engine for it. A couple of com

[Patch] regex_iterator and regex_token_iterator implementation

2013-07-21 Thread Tim Shen
http://gcc.gnu.org/bugzilla/show_bug.cgi?id=57513 is already in the testsuite and can passed(even before this patch?). To fully test it, a fully regex_search implementation is required. I'm working on a (damning) backtracking engine for it. -- Tim Shen iterators.patch Description: Binary data

Re: [Patch] Partially implement regex_search

2013-07-21 Thread Paolo Carlini
-- Tim, while you work on these improvements, I think it would nice to also commit, when appropriate, testcases which came with bug reports which we closed as duplicates of the "std::regex is not implemented yet" report. I'm not referring to this specific commit, just a general comment. Than

Re: [Patch] Partially implement regex_search

2013-07-21 Thread Tim Shen
On Mon, Jul 22, 2013 at 1:48 AM, Jonathan Wakely wrote: > OK. The rest of the patch is fine - would you like me to commit it for > you, with those fixes? I can commit on my own. I've already been a write-after-approval. Thank you again for reviewing! -- Tim Shen

Re: [PATCH 1/*] Fix common typos.

2013-07-21 Thread Joseph S. Myers
On Sun, 21 Jul 2013, Mike Stump wrote: > > diff --git a/libiberty/regex.c b/libiberty/regex.c > > index 17091ce..8a2dd41 100644 > > --- a/libiberty/regex.c > > +++ b/libiberty/regex.c > > @@ -3396,7 +3396,7 @@ PREFIX(regex_compile) (const char > > *ARG_PREFIX(pattern), > >

Re: [PATCH 1/*] Fix common typos.

2013-07-21 Thread Joseph S. Myers
On Sun, 21 Jul 2013, Mike Stump wrote: > > diff --git a/gcc/testsuite/c-c++-common/pr41779.c > > b/gcc/testsuite/c-c++-common/pr41779.c > > index 80c8e6b..f80412c 100644 > > --- a/gcc/testsuite/c-c++-common/pr41779.c > > +++ b/gcc/testsuite/c-c++-common/pr41779.c > > @@ -1,4 +1,4 @@ > > -/* PR417

Re: [PATCH 1/*] Fix common typos.

2013-07-21 Thread Joseph S. Myers
On Sun, 21 Jul 2013, Mike Stump wrote: > I've reviewed and applied the gcc/doc changes that were trivial. The > only patches not applied were the ok->OK patches. *For formal documentation* such as gcc/doc, I think changing ok->OK is appropriate; the formal documentation should be more conserva

Re: [patch] proposed fix for libstdc++/54352

2013-07-21 Thread Jonathan Wakely
On 16 June 2013 15:35, Jonathan Wakely wrote: > In order to conform to [thread.condition.condvarany]/5 and fix this > PR we need an ABI change to std::condition_variable_any, so that its > internal mutex can outlive the condition_variable_any while there are > threads blocked on the mutex, which t

Re: [PATCH 1/*] Fix common typos.

2013-07-21 Thread Mike Stump
On Jul 21, 2013, at 11:31 AM, Mike Stump wrote: > On Jul 21, 2013, at 7:32 AM, Ondřej Bílka wrote: >> This is series of typo fixing patches. > > I reviewed gcc/[a-i]* and checked in those I thought were trivial. So, I checked in the potentially controversial thru -> through in gcc/ada. I'll l

Re: [PATCH 1/*] Fix common typos.

2013-07-21 Thread Mike Stump
On Jul 21, 2013, at 7:32 AM, Ondřej Bílka wrote: > This is series of typo fixing patches. I reviewed gcc/[a-i]* and checked in those I thought were trivial.

Re: [PATCH 1/*] Fix common typos.

2013-07-21 Thread Mike Stump
On Jul 21, 2013, at 7:32 AM, Ondřej Bílka wrote: > gcc/c/c-decl.c | 4 +- > > gcc/c/c-objc-common.c | 4 +- >

Re: [ubsan] Add libcall arguments

2013-07-21 Thread Marek Polacek
On Sat, Jul 20, 2013 at 08:17:34PM -0400, Jason Merrill wrote: > On 07/20/2013 10:27 AM, Jakub Jelinek wrote: > >So, the middle-end can only use > >some other type, say build_nonstandard_integer_type (POINTER_SIZE, 1); > >which often will be the same type as uintptr_type_node, but perhaps not on >

Re: [PATCH 1/*] Fix common typos.

2013-07-21 Thread Mike Stump
On Jul 21, 2013, at 7:32 AM, Ondřej Bílka wrote: > This is series of typo fixing patches. I checked in the fixes to gcc/[l-t]* that were trivial. (ok->OK being the usual exclusion).

Re: [PATCH 1/*] Fix common typos.

2013-07-21 Thread Mike Stump
On Jul 21, 2013, at 7:32 AM, Ondřej Bílka wrote: > This is series of typo fixing patches. I reviewed and checked in all that changes to gcc/tree\* that were trivial. I left out ok->OK, and --- a/gcc/tree-ssa-pre.c

Re: [PATCH 1/*] Fix common typos.

2013-07-21 Thread Tobias Burnus
Ondřej Bílka wrote: This is series of typo fixing patches. They are generated with stylepp https://github.com/neleai/stylepp which makes patch generation very effective. [...] Then I ran script/stylepp_fix_spell which produced following 300kb patch: http://kam.mff.cuni.cz/~ondra/0001-Fix-common

Re: [PATCH 1/*] Fix common typos.

2013-07-21 Thread Mike Stump
On Jul 21, 2013, at 7:32 AM, Ondřej Bílka wrote: > This is series of typo fixing patches. I checked in all the changes to gcc/cp that were trivial.

Re: [Patch] Partially implement regex_search

2013-07-21 Thread Jonathan Wakely
On 18 July 2013 11:06, Tim Shen wrote: > > These will be fixed when commit to SVN. OK. The rest of the patch is fine - would you like me to commit it for you, with those fixes?

Re: [PATCH 1/*] Fix common typos.

2013-07-21 Thread Mike Stump
On Jul 21, 2013, at 7:32 AM, Ondřej Bílka wrote: > This is series of typo fixing patches. I reviewed and applied all the trivial patches in gcc/config. Excluded were ok->OK, and /* My current feeling is that r14 should go to the end and maybe even r12.

Re: [PATCH 1/*] Fix common typos.

2013-07-21 Thread Ondřej Bílka
On Sun, Jul 21, 2013 at 04:44:40PM +0200, Marc Glisse wrote: > On Sun, 21 Jul 2013, Ondřej Bílka wrote: > > >Then I ran script/stylepp_fix_spell which produced following 300kb patch: > > > >http://kam.mff.cuni.cz/~ondra/0001-Fix-common-typos.patch > > There are still some wrong fixes, humans real

Re: [PATCH 1/*] Fix common typos.

2013-07-21 Thread Mike Stump
On Jul 21, 2013, at 7:32 AM, Ondřej Bílka wrote: > This is series of typo fixing patches. I've reviewed and applied the gcc/doc changes that were trivial. The only patches not applied were the ok->OK patches.

Re: [PATCH 1/*] Fix common typos.

2013-07-21 Thread Mike Stump
I've applied these fixes, to ensure that they are not corrected incorrectly, thanks for the corrections. On Jul 21, 2013, at 8:37 AM, Marek Polacek wrote: > diff --git a/gcc/ipa.c b/gcc/ipa.c > index 7c0d495..d44cf38 100644 > --- a/gcc/ipa.c > +++ b/gcc/ipa.c > @@ -548,7 +548,7 @@ static bool >

Re: [PATCH 1/*] Fix common typos.

2013-07-21 Thread Mike Stump
On Jul 21, 2013, at 8:37 AM, Marek Polacek wrote: > diff --git a/gcc/ada/gcc-interface/utils2.c b/gcc/ada/gcc-interface/utils2.c > index 3f39a43..7f7f6af 100644 > --- a/gcc/ada/gcc-interface/utils2.c > +++ b/gcc/ada/gcc-interface/utils2.c > @@ -1902,7 +1902,7 @@ build_simple_component_ref (tree re

Re: [PATCH 1/*] Fix common typos.

2013-07-21 Thread Mike Stump
On Jul 21, 2013, at 7:32 AM, Ondřej Bílka wrote: > This is series of typo fixing patches. They are generated with stylepp > https://github.com/neleai/stylepp > which makes patch generation very effective. I've checked in most changes to Objective-C things and test suite things after reviewing al

Re: [PATCH 1/*] Fix common typos.

2013-07-21 Thread Ondřej Bílka
On Sun, Jul 21, 2013 at 09:09:37AM -0700, Mike Stump wrote: > On Jul 21, 2013, at 7:32 AM, Ondřej Bílka wrote: > > + * c-c++-common/raw-string-13.c: Likewise. > > > > + * c-c++-common/raw-string-14.c: Likewis

Re: [PATCH 1/*] Fix common typos.

2013-07-21 Thread Ondřej Bílka
On Sun, Jul 21, 2013 at 05:37:23PM +0200, Marek Polacek wrote: > > A few comments: > snip > diff --git a/gcc/ipa.c b/gcc/ipa.c > index 7c0d495..d44cf38 100644 > --- a/gcc/ipa.c > +++ b/gcc/ipa.c > @@ -548,7 +548,7 @@ static bool > comdat_can_be_unshared_p_1 (symtab_node node) > { >/* When a

Re: [PATCH 1/*] Fix common typos.

2013-07-21 Thread Mike Stump
On Jul 21, 2013, at 7:32 AM, Ondřej Bílka wrote: > + * c-c++-common/raw-string-13.c: Likewise. > > + * c-c++-common/raw-string-14.c: Likewise. >

Re: [PATCH 1/*] Fix common typos.

2013-07-21 Thread Marek Polacek
On Sun, Jul 21, 2013 at 04:32:04PM +0200, Ondřej Bílka wrote: > Hi, > > This is series of typo fixing patches. They are generated with stylepp > https://github.com/neleai/stylepp > which makes patch generation very effective. > > This series should be applied in sequence to avoid reviewing duplic

Re: RFC: Add of type-demotion pass

2013-07-21 Thread Richard Biener
Marc Glisse wrote: >On Fri, 19 Jul 2013, Jeff Law wrote: > >> It's also worth noting that fold-const.c also does some type >> hoisting/sinking. > >fold-const.c does everything ;-) > >> Ideally that code should just be going away. > >Like most of the code from fold-const.c that isn't about foldin

Re: [PATCH] FPU IEEE 754 for MIPS r5900

2013-07-21 Thread Jürgen Urban
Hello Richard, > "Jürgen Urban" writes: > >> "Jürgen Urban" writes: > >> >> "Jürgen Urban" writes: > >> >> > I used the SPU code in GCC as example for creating an > >> >> > r5900_single_format structure. The patch is attached to the e-mail. I > >> >> > want to submit this patch. > >> >> > >> >>

Re: [Patch, Fortran] PR35862 - add input I/O rounding support - by setting the CPU rounding mode

2013-07-21 Thread Tobias Burnus
Tobias Burnus wrote: I have now committed the patch (Rev. 201093). I missed the attached patch, which fixes the build. (Rev. 201095) Tobias Index: libgfortran/ChangeLog === --- libgfortran/ChangeLog (Revision 201094) +++ libgfortra

Re: [PATCH 1/*] Fix common typos.

2013-07-21 Thread Joseph S. Myers
I do not believe such fixes in testsuites make sense. They are definitely inappropriate in testsuite input data (as opposed to comments) without specific rationale in the patch posting for why the change is OK. Changes to gcc/go/gofrontend/ and libgo/ have their own rules as those directories

Re: [PATCH 1/*] Fix common typos.

2013-07-21 Thread Marc Glisse
On Sun, 21 Jul 2013, Ondřej Bílka wrote: This is series of typo fixing patches. They are generated with stylepp https://github.com/neleai/stylepp which makes patch generation very effective. This series should be applied in sequence to avoid reviewing duplicates. Now I exclude those directorie

[PATCH 1/*] Fix common typos.

2013-07-21 Thread Ondřej Bílka
Hi, This is series of typo fixing patches. They are generated with stylepp https://github.com/neleai/stylepp which makes patch generation very effective. This series should be applied in sequence to avoid reviewing duplicates. Now I exclude those directories that are upstream, see file https://g

Re: [patch, fortran] PR 56937 - temporaries with array indices

2013-07-21 Thread Thomas Koenig
Hi Paul, This is OK for trunk. Could you expand the comment to capture the two cases without dependency. eg. There is no dependency if the vector indices are equal or things are known to be different in a different dimension. Committed to trunk with an updated comment, as you suggested, as re

Re: [Patch, Fortran] PR35862 - add input I/O rounding support - by setting the CPU rounding mode

2013-07-21 Thread Tobias Burnus
Mikael Morin wrote: Le 17/07/2013 11:02, Tobias Burnus a écrit : Build and regtested on x86-64-gnu-linux. OK for the trunk? The fortran bits look good. Thanks for the review Mikel and David! Thanks for the patch Uros. I have now committed the patch (Rev. 201093). - Hopefully, it works on al

Re: [Patch x86/darwin] fix PR51784 'PIC register not correctly preserved...'

2013-07-21 Thread Uros Bizjak
On Sun, Jul 21, 2013 at 9:42 AM, Iain Sandoe wrote: >> > > Sure, I can test that - do you want me to apply it assuming it reg-tests OK > on darwin & linux? > (also I can amend the back ports - since I didn't have time to get to them > yesterday) Yes, please test it on darwin. The build test o

Re: [Patch x86/darwin] fix PR51784 'PIC register not correctly preserved...'

2013-07-21 Thread Iain Sandoe
Hi Uros, On 21 Jul 2013, at 08:34, Uros Bizjak wrote: > Sure, I can test that - do you want me to apply it assuming it reg-tests OK on darwin & linux? (also I can amend the back ports - since I didn't have time to get to them yesterday) thanks Iain

Re: [Patch x86/darwin] fix PR51784 'PIC register not correctly preserved...'

2013-07-21 Thread Uros Bizjak
On Fri, Jul 19, 2013 at 11:00 PM, Jakub Jelinek wrote: > On Fri, Jul 19, 2013 at 04:56:47PM +0200, Uros Bizjak wrote: >> > OK for trunk? >> >> Assuming that Jakub is OK with the patch, it is OK for trunk. > > With the line wrapping fix and Uros' suggested improvement this is ok for > both trunk an