[v3 PATCH] Make the default constructors of tuple and pair conditionally explicit.

2015-10-31 Thread Ville Voutilainen
In the last meeting, while processing LWG 2510, LWG's guidance was to make the default constructors of pair and tuple conditionally explicit. This patch implements a new trait and uses it in pair and tuple. Paolo, Jonathan is traveling and somewhat unlikely to be able to review this for quite

Re: [patch] New backend header reduction

2015-10-31 Thread Andreas Schwab
../../gcc/ggc-common.c: In function 'void init_ggc_heuristics()': ../../gcc/ggc-common.c:822: error: 'GGC_MIN_EXPAND' was not declared in this scope ../../gcc/ggc-common.c:822: error: 'set_default_param_value' was not declared in this scope ../../gcc/ggc-common.c:823: error: 'GGC_MIN_HEAPSIZE'

Re: [PATCH 5/5] remove usage of ADJUST_FIELD_ALIGN in encoding.c

2015-10-31 Thread Andrew Pinski
On Fri, Oct 30, 2015 at 9:11 PM, Bernd Schmidt wrote: > On 10/30/2015 01:47 PM, Richard Biener wrote: >> >> On Fri, Oct 30, 2015 at 1:28 PM, Bernd Schmidt >> wrote: it's not target independent code. Are you suggesting to add a config/

[gomp4, committed] Backport more tree-ssa-structalias.c fixes from trunk

2015-10-31 Thread Tom de Vries
Hi, this patch backports my commits to trunk of today in tree-ssa-structalias.c. Committed to gomp-4_0-branch. Thanks, - Tom 2015-10-31 Tom de Vries backport from trunk: 2015-10-31 Tom de Vries * tree-ssa-structalias.c

Re: [patch] New backend header reduction

2015-10-31 Thread Markus Trippelsdorf
On 2015.10.31 at 07:56 +0100, Andreas Schwab wrote: > ../../gcc/ggc-common.c: In function 'void init_ggc_heuristics()': > ../../gcc/ggc-common.c:822: error: 'GGC_MIN_EXPAND' was not declared in this > scope > ../../gcc/ggc-common.c:822: error: 'set_default_param_value' was not declared > in this

[committed, trivial] Improve readability and structure of create_function_info_for

2015-10-31 Thread Tom de Vries
Hi, this patch improves readability and structure of function create_function_info_for. Bootstrapped and reg-tested on x86_64. Committed to trunk as trivial. Thanks, - Tom Improve readability and structure of create_function_info_for 2015-10-30 Tom de Vries *

[committed, trivial] Don't expect existing varinfo for arguments in intra_create_variable_infos

2015-10-31 Thread Tom de Vries
[ was: Re: [PATCH, 1/6] Simplify constraint handling ] On 31/10/15 09:19, Tom de Vries wrote: On 30/10/15 10:33, Richard Biener wrote: Yes, but as I said we should refactor things to avoid calling > >the intra constraints generation from the IPA path. > >Ah, I see. > >So, like this? OK for

Re: [PATCH, 1/6] Simplify constraint handling

2015-10-31 Thread Tom de Vries
On 30/10/15 10:33, Richard Biener wrote: Yes, but as I said we should refactor things to avoid calling > >the intra constraints generation from the IPA path. > >Ah, I see. > >So, like this? OK for trunk if bootstrap and reg-test succeeds? Yes, like this. But you miss to apply the same to the

[committed, trivial] Use make_copy_constraint in ipa_pta_execute

2015-10-31 Thread Tom de Vries
Hi, this patch gives us shorter code in ipa_pta_execute, by using make_copy_constraint. Bootstrapped and reg-tested on x86_64. Committed to trunk as trivial. Thanks, - Tom Use make_copy_constraint in ipa_pta_execute 2015-10-30 Tom de Vries *

[committed] Tune pointer-plus folding

2015-10-31 Thread Tom de Vries
[ was: Re: [PATCH] Allow more pointer-plus folding ] On 30/10/15 10:24, Richard Biener wrote: I think the checks on TREE_OPERAND (arg0, 1) are bogus though >>and either we should unconditionally sink the conversion or only >>if a conversion on TREE_OPERAND (arg0, 0) vanishes (I prefer the

Re: [patch] New backend header reduction

2015-10-31 Thread Markus Trippelsdorf
On 2015.10.31 at 08:33 +0100, Markus Trippelsdorf wrote: > On 2015.10.31 at 07:56 +0100, Andreas Schwab wrote: > > ../../gcc/ggc-common.c: In function 'void init_ggc_heuristics()': > > ../../gcc/ggc-common.c:822: error: 'GGC_MIN_EXPAND' was not declared in > > this scope > >

Re: [PATCH] New attribute to create target clones

2015-10-31 Thread Dominique d'Humières
Evgeny, On darwin I see the following failures FAIL: g++.dg/ext/mvc1.C -std=c++11 (test for excess errors) UNRESOLVED: g++.dg/ext/mvc1.C -std=c++11 compilation failed to produce executable FAIL: g++.dg/ext/mvc1.C -std=c++14 (test for excess errors) UNRESOLVED: g++.dg/ext/mvc1.C -std=c++14

[C++ PATCH] Remove the implementation of N3994, terse range-for loops.

2015-10-31 Thread Ville Voutilainen
Since N3994 ended up being rejected and was never included in C++17, I want to remove the support for it. It's easy to bring it back if such a facility is resurrected, but for now, let's remove such an extension. Tested on Linux-PPC64. /cp 2015-10-31 Ville Voutilainen

Re: Add VIEW_CONVERT_EXPR to operand_equal_p

2015-10-31 Thread Eric Botcazou
> Lets go with this patch and hopefully stabilize the tree. I don't think the > vector conversions represent an important case. Unfortunately the patch introduces GIMPLE checking failures in Ada so it will need to be completed/improved. But let's postpone it because we have another class of

Re: [PATCH 2/2] rs6000: Rewrite rs6000_reg_live_or_pic_offset_p

2015-10-31 Thread David Edelsohn
On Sat, Oct 31, 2015 at 1:39 PM, Segher Boessenkool wrote: > This function is quite a puzzle; untangle it. No functional change. > > Tested etc.; okay for trunk? > > > Segher > > > 2015-10-31 Segher Boessenkool > > *

Re: [PATCH 1/2] rs6000: Another PIC LRA fix

2015-10-31 Thread David Edelsohn
On Sat, Oct 31, 2015 at 1:39 PM, Segher Boessenkool wrote: > This one for TARGET_TOC && TARGET_MINIMAL_TOC. Without it, r30 is not > saved in the prologue for functions that do not use r30, but the register > is set later in the prologue anyhow. This made all java

Re: Add VIEW_CONVERT_EXPR to operand_equal_p

2015-10-31 Thread Richard Biener
On October 31, 2015 6:17:35 PM GMT+01:00, Eric Botcazou wrote: >> Lets go with this patch and hopefully stabilize the tree. I don't >think the >> vector conversions represent an important case. > >Unfortunately the patch introduces GIMPLE checking failures in Ada so >it

Re: more accurate omp in fortran

2015-10-31 Thread Cesar Philippidis
On 10/30/2015 09:29 PM, Dominique d'Humières wrote: >> diff --git a/gcc/fortran/openmp.c b/gcc/fortran/openmp.c > > Revision r229609 breaks bootstrap: > > ../../work/gcc/fortran/openmp.c: In function 'void > resolve_omp_clauses(gfc_code*, gfc_omp_clauses*, gfc_namespace*, bool)': >

C++ PATCH for Concepts TS multiple auto

2015-10-31 Thread Jason Merrill
The Concepts TS extends 'auto' deduction so that auto, or a constrained-type-specifier, can appear anywhere in the type of a declaration, rather than only as a type-specifier. This was already implemented for function parameters; this patch implements it for variables as well. Use of a

[PATCH 1/2] rs6000: Another PIC LRA fix

2015-10-31 Thread Segher Boessenkool
This one for TARGET_TOC && TARGET_MINIMAL_TOC. Without it, r30 is not saved in the prologue for functions that do not use r30, but the register is set later in the prologue anyhow. This made all java tests fail. Tested on powerpc64-linux, --enable-languages=all,ada,go,obj-c++ and test variants

[PATCH 2/2] rs6000: Rewrite rs6000_reg_live_or_pic_offset_p

2015-10-31 Thread Segher Boessenkool
This function is quite a puzzle; untangle it. No functional change. Tested etc.; okay for trunk? Segher 2015-10-31 Segher Boessenkool * config/rs6000/rs6000.c (rs6000_reg_live_or_pic_offset_p): Rewrite. --- gcc/config/rs6000/rs6000.c | 35

Re: [PATCH 1/2] s/390: Implement "target" attribute.

2015-10-31 Thread Dominik Vogt
To improve readability, I'll split my answers (see below) into several separate messages. > > index 43459c8..4cf0df7 100644 > > --- a/gcc/common/config/s390/s390-common.c > > +++ b/gcc/common/config/s390/s390-common.c > > @@ -79,41 +79,27 @@ s390_option_init_struct (struct gcc_options *opts) > >

Re: [patch] New backend header reduction

2015-10-31 Thread Jeff Law
On 10/31/2015 12:56 AM, Andreas Schwab wrote: ../../gcc/ggc-common.c: In function 'void init_ggc_heuristics()': ../../gcc/ggc-common.c:822: error: 'GGC_MIN_EXPAND' was not declared in this scope ../../gcc/ggc-common.c:822: error: 'set_default_param_value' was not declared in this scope

Re: [PATCH 13/16] Add test-rtl.c to unittests

2015-10-31 Thread Segher Boessenkool
On Thu, Oct 29, 2015 at 10:57:53PM -0600, Jeff Law wrote: > Oh the things we could do here. A parallel of multiple sets where all > but one is unused is a single set, I can't recall if a single set in > parallel with a jump/cond jump is a single set or not. It is not, it is two SETs (one of

Re: [wwwdocs] GCC 6 Release Notes for RTEMS

2015-10-31 Thread Gerald Pfeifer
Hi Sebastian, what do you think about the follow-up patch below, on top of your original patch? Gerald Index: gcc-6/changes.html === RCS file: /cvs/gcc/wwwdocs/htdocs/gcc-6/changes.html,v retrieving revision 1.38 diff -u -r1.38

[patch] gcc6 FreeBSD rs6000 PIE handling

2015-10-31 Thread Andreas Tobler
Hi, this is the part for gcc trunk. As mentioned in the previous mail (same subject for gcc5) I forgot to adapt the PIE bits for FreeBSD powerpc64. The patch below lets me bootstrap a current gcc with itself. I'll commit this part if there are no objections. Thanks, Andreas 2015-10-31

Re: Try to update dominance info in tree-call-cdce.c

2015-10-31 Thread Steven Bosscher
On Fri, Oct 30, 2015 at 2:11 PM, Richard Sandiford wrote: > Is the split_block change really so bad? IMHO: Yes. split_block just splits some basic block B into two blocks B1/B2 somewhere in the middle of B. The dominance relations between B1 and B2 are obvious and

[patch] gcc5 FreeBSD rs6000 PIE handling

2015-10-31 Thread Andreas Tobler
Hi, I forgot to adapt the pie bits for powerpc64 FreeBSD back in May when I committed the pie support for FreeBSD. Without the below patch I'm not able to bootstrap a current gcc on FreeBSD powerpc64. The patch is against gcc-5, the patch for trunk will follow. If there are no objections

gotools patch committed: Update for Go 1.5.1 library

2015-10-31 Thread Ian Lance Taylor
I forgot to commit this patch to update gotools to the Go 1.5.1 library. Already tested, now committed. Ian 2015-10-31 Ian Lance Taylor * Makefile.am (go_cmd_go_files): Update to Go 1.5.1 library by adding alldocs.go, doc.go, note.go. * Makefile.in: Rebuild. Index:

Re: [PATCH] Fix declaration of pthread-structs in s-osinte-rtems.ads

2015-10-31 Thread Arnaud Charlet
> > This patch changes the Ada-declaration of the pthread-related structs > > such as pthread_attr_t from a field-equivalent declaration to just > > reserving the right amount of memory. > > It is only rtems related and essentially copies the way how the types are > > defined in

libgo patch committed: Update to Go 1.5.1

2015-10-31 Thread Ian Lance Taylor
This patch updates libgo from the Go 1.5 release to the Go 1.5.1 release. It's fairly small. Bootstrapped and ran Go testsuite on x86_64-pc-linux-gnu. Committed to mainline. Ian Index: gcc/go/gofrontend/MERGE === ---

Re: [PATCH] Fix declaration of pthread-structs in s-osinte-rtems.ads

2015-10-31 Thread Jan Sommer
Am Saturday 31 October 2015, 16:47:35 schrieb Jan Sommer: > Hi, > > This patch changes the Ada-declaration of the pthread-related structs such as > pthread_attr_t from a field-equivalent declaration to just reserving the > right amount of memory. > It is only rtems related and essentially

[PATCH] Fix declaration of pthread-structs in s-osinte-rtems.ads

2015-10-31 Thread Jan Sommer
Hi, This patch changes the Ada-declaration of the pthread-related structs such as pthread_attr_t from a field-equivalent declaration to just reserving the right amount of memory. It is only rtems related and essentially copies the way how the types are defined in s-osinte-linux.ads. It makes

Re: [C++ PATCH] Remove the implementation of N3994, terse range-for loops.

2015-10-31 Thread Jason Merrill
OK. Jason

Re: [PATCH 6/6] Make SRA replace constant-pool loads

2015-10-31 Thread Bernhard Reutner-Fischer
On October 29, 2015 8:18:22 PM GMT+01:00, Alan Lawrence wrote: >+ >+static tree >+subst_constant_pool_initial (tree expr, tree var) >+{ >+ if (TREE_CODE (expr) == VAR_DECL) Just a nit, but i thought we had VAR_DECL_P or VAR_P for the TREE_CODE (NODE) == VAR_DECL

libgo patch committed: When non-split-stack, allocate 64-bit stack using mmap

2015-10-31 Thread Ian Lance Taylor
When not using split stacks, libgo allocate large stacks for each goroutine. On a 64-bit system, libgo allocates a maximum of 128G for the Go heap, and allocates 4M for each stack. When the stacks are allocated from the Go heap, the result is that a program can only create 32K goroutines, which