[RS6000] rs6000_output_mi_thunk tidy

2019-07-26 Thread Alan Modra
Since svn r123193 (git 327202e27a) the comment about scratch regs was no longer correct, and I think gen_sibcall could have been used even then. Bootstrapped and regression tested powerpc64le-linux. OK for mainline? * gcc/config/rs6000/rs6000-call.c (rs6000_output_mi_thunk): Use

[RS6000] PR91135, __linux__ not defined with -mcall-aixdesc on 9.x and ppc64

2019-07-26 Thread Alan Modra
This patch makes the obvious fix for PR91135, and deletes extraneous copies of GNU_USER_TARGET_D_OS_VERSIONS that appear in rs6000/linux.h and rs6000/linux64.h. Since all configurations using either of these files also inclue linux.h there is no need to duplicate the macro. Bootstrapped and

[RS6000] Make assembler command line cpu match default for gcc

2019-07-26 Thread Alan Modra
When gcc is configured using --with-cpu=, the specified cpu effectively becomes a default -mcpu= passed to gcc. This then affects the cpu passed to gas via ASM_CPU_SPEC. If gcc is not configured using --with-cpu then the cpu passed to gas is that given by ASM_DEFAULT_SPEC, which currently does

Re: [PATCH, og9] Port OpenACC profiling interface to OG9

2019-07-26 Thread Kwok Cheung Yeung
On 24/07/2019 11:45 am, Thomas Schwinge wrote: +2017-02-28 Thomas Schwinge + + [...] + * oacc-parallel.c (GOACC_parallel_keyed_internal): Set device_api for + profiling. --- a/libgomp/oacc-parallel.c +++ b/libgomp/oacc-parallel.c @@ -275,6 +275,8 @@

Re: [Darwin, testsuite] Handle Darwin's size command.

2019-07-26 Thread Mike Stump
On Jul 26, 2019, at 7:52 AM, Iain Sandoe wrote: > > This one has been in my patch stack for a long time… > > Darwin's "size" command has a different header line, reflecting the Mach-O > section naming conventions. This causes tests using the command to fail > because scanasm.exp expects and

[Darwin, testsuite] Handle Darwin's size command.

2019-07-26 Thread Iain Sandoe
This one has been in my patch stack for a long time… Darwin's "size" command has a different header line, reflecting the Mach-O section naming conventions. This causes tests using the command to fail because scanasm.exp expects and checks specific layout of the header line. Tested on i686,

Re: [range-ops] patch 01/04: types for VR_UNDEFINED and VR_VARYING

2019-07-26 Thread Andrew MacLeod
On 7/25/19 11:37 PM, Jeff Law wrote: On 7/24/19 12:33 PM, Richard Biener wrote: On July 24, 2019 8:18:57 PM GMT+02:00, Jeff Law wrote: On 7/24/19 11:00 AM, Richard Biener wrote: [ Big snip, ignore missing reply attributions... ] it. But I'd claim that if callers are required not to change

Re: [PATCH, rs6000] Fix PR91050 by adding a DRIVER_SELF_SPECS spec

2019-07-26 Thread Iain Sandoe
Hi Peter, The patch needs one small amendment to succeed in bootstrap. I applied the amended to i686, x86_64 and powerpc Darwin with no apparent new problems. From the Darwin perspective, the patch is OK with the amendment. (there’s also a note in the text, but that’s just an observation)

Re: [PATCH V3, rs6000] Support vrotr3 for int vector types

2019-07-26 Thread Segher Boessenkool
On Fri, Jul 26, 2019 at 11:20:27AM +0800, Kewen.Lin wrote: > on 2019/7/25 下午9:49, Segher Boessenkool wrote: > > "vrlv2di_and" is an a bit unhappy name, we have a "vrlv" intruction. > > Just something like "rotatev2di_something", maybe? > > > > Do we have something similar for non-rotate vector

Re: [PATCH] Relocate std::endian from to

2019-07-26 Thread Jonathan Wakely
On 26/07/19 14:32 +0100, Jonathan Wakely wrote: This change to an early C++2a feature was just approved (P1612R1). * include/std/bit (endian): Move definition here as per P1612R1. * include/std/type_traits (endian): Remove definition from here. *

[PATCH] Relocate std::endian from to

2019-07-26 Thread Jonathan Wakely
This change to an early C++2a feature was just approved (P1612R1). * include/std/bit (endian): Move definition here as per P1612R1. * include/std/type_traits (endian): Remove definition from here. * testsuite/20_util/endian/1.cc: Rename to ... *

[patch] Extend GIMPLE store merging to throwing stores

2019-07-26 Thread Eric Botcazou
Hi, one of the effects of -fnon-call-exceptions is that the memory accesses are considered trapping by default, i.e. unless you can prove otherwise. If, in addition to this, the code is covered by an exception handler, such memory accesses are the sources of an EH edge, which means that they

[PATCH] [MIPS] Add missing const qualifier in MSA ld intrinsic documentation

2019-07-26 Thread Mihailo Stojanovic
From: Mihailo Stojanovic The documentation is not reflecting the fact that the first argument of MSA ld intrinsics is a const void pointer. gcc/ * doc/extend.texi: Add const qualifier to ld intrinsics. --- gcc/doc/extend.texi | 8 1 file changed, 4 insertions(+), 4 deletions(-)