[PATCH] gcc: rename floatformat_ia64_quad_{big, little} to floatformat_ieee_quad_{big, little}

2022-03-13 Thread Tiezhu Yang
I submitted a GDB patch [1] to rename floatformats_ia64_quad to floatformats_ieee_quad to reflect the reality, and then we can clean up the related code. As GDB Global Maintainer Tom Tromey said [2]: These files are maintained in gcc and then imported into the binutils-gdb repository, so any

Re: [PATCH v7] c++: Add diagnostic when operator= is used as truth cond [PR25689]

2022-03-13 Thread Zhao Wei Liew via Gcc-patches
On Sat, 12 Mar 2022 at 06:15, Jason Merrill wrote: > It looks good, but unfortunately regresses some other warning tests, > such as Wnonnull5.C. Please remember to run the regression tests before > sending a patch (https://gcc.gnu.org/contribute.html#testing). > > This seems to be a complicated

[PATCH 2/2] c++tools: Work around a BSD bug in getaddrinfo().

2022-03-13 Thread Iain Sandoe via Gcc-patches
Some versions of the BSD getaddrinfo() call do not work with the specific input of "0" for the servname entry (a segv results). Since we are making the call with a dummy port number, the value is actually not important, other than it should be in range. Work around the BSD bug by using "1"

[PATCH 1/2] libcody: Do not use a dummy port number in getaddrinfo().

2022-03-13 Thread Iain Sandoe via Gcc-patches
The getaddrinfo() call requires either a non-null name for the server or a port service / number. In the code that opens a connection we have been calling this with a dummy port number of "0". Unfortunately this triggers a crashing bug in some BSD versions (and OSes importing that code). In

[PATCH] gcc: emit DW_AT_name for DW_TAG_GNU_formal_parameter_pack [PR70536]

2022-03-13 Thread Ed Catmur
Per http://wiki.dwarfstd.org/index.php?title=C%2B%2B0x:_Variadic_templates DW_TAG_GNU_formal_parameter_pack should have a DW_AT_name: 17$: DW_TAG_formal_parameter_pack DW_AT_name("args") 18$: DW_TAG_formal_parameter ! no DW_AT_name attribute

Re: [x86 PATCH] Fix libitm.c/memset-1.c test fails with new peephole2s.

2022-03-13 Thread Uros Bizjak via Gcc-patches
On Sat, Mar 12, 2022 at 7:50 PM Roger Sayle wrote: > > > My sincere apologies for the breakage, but alas handling SImode in the > recently added "xorl;movb -> movzbl" peephole2 turns out to be slightly > more complicated that just using SWI48 as a mode iterator. I'd failed > to check the machine

Re: [PATCH] ifcvt: Punt if not onlyjump_p for find_if_case_{1,2} [PR104814]

2022-03-13 Thread Jakub Jelinek via Gcc-patches
On Sun, Mar 13, 2022 at 02:03:33PM +0100, Eric Botcazou wrote: > > Bootstrapped/regtested on {x86_64,i686,powerpc64le,aarch64,s390x}-linux, > > ok for trunk? > > > > 2022-03-13 Jakub Jelinek > > > > PR rtl-optimization/104814 > > * ifcvt.cc (find_if_case_1, find_if_case_2): Punt if

Re: [PATCH] i386: Fix up _mm_loadu_si{16,32} [PR99754]

2022-03-13 Thread Hongtao Liu via Gcc-patches
On Sun, Mar 13, 2022 at 3:28 AM Jakub Jelinek wrote: > > Hi! > > These intrinsics are supposed to do an unaligned may_alias load > of a 16-bit or 32-bit value and store it as the first element of > a 128-bit integer vector, with all other elements cleared. > > The current _mm_storeu_*

Re: [PATCH] ifcvt: Punt if not onlyjump_p for find_if_case_{1, 2} [PR104814]

2022-03-13 Thread Eric Botcazou via Gcc-patches
> Bootstrapped/regtested on {x86_64,i686,powerpc64le,aarch64,s390x}-linux, > ok for trunk? > > 2022-03-13 Jakub Jelinek > > PR rtl-optimization/104814 > * ifcvt.cc (find_if_case_1, find_if_case_2): Punt if test_bb > doesn't end with onlyjump_p. > > *

[PATCH] ifcvt: Punt if not onlyjump_p for find_if_case_{1,2} [PR104814]

2022-03-13 Thread Jakub Jelinek via Gcc-patches
Hi! find_if_case_{1,2} implicitly assumes conditional jumps and rewrites them, so if they have extra side-effects or are say asm goto, things don't work well, either the side-effects are lost or we could ICE. In particular, the testcase below on s390x has there a doloop instruction that

[committed] texi + c-target.def: Fix typos

2022-03-13 Thread Tobias Burnus
Fixed couple of documentation typos; namely, misspelled words and duplicated words. Committed as r12-7635. Tobias - Siemens Electronic Design Automation GmbH; Anschrift: Arnulfstraße 201, 80634 München; Gesellschaft mit beschränkter Haftung; Geschäftsführer: Thomas Heurung,