On Wed, Mar 29, 2023 at 7:22 PM Andrew MacLeod wrote:
>
> The patch, or a slight variation (attached), in the PR allows us to
> generate better ranges be recomputing longer instruction sequences on
> outgoing edges.
>
> This in fact also fixes
> XPASS: gcc.dg/Walloca-13.c (test for bogus messages
On Thu, Mar 30, 2023 at 8:17 AM Uros Bizjak wrote:
>
> On Thu, Mar 30, 2023 at 3:47 AM liuhongt wrote:
> >
> > There's some typo for the standard pattern name for unsigned_{float,fix},
> > it should be floatunsmn2/fixuns_truncmn2, not ufloatmn2/ufix_truncmn2
> > in current trunk, the patch fix th
On Thu, Mar 30, 2023 at 3:47 AM liuhongt wrote:
>
> There's some typo for the standard pattern name for unsigned_{float,fix},
> it should be floatunsmn2/fixuns_truncmn2, not ufloatmn2/ufix_truncmn2
> in current trunk, the patch fix the typo.
>
> Also vcvttps2udq is available under AVX512VL, so it
Thanks Jiawei, committed to trunk!
On Wed, Mar 29, 2023 at 12:55 AM Jiawei wrote:
>
> Z*inx is conflict with float extensions, add incompatible check when
> z*inx and f extension both enabled.
>
> Since all float extension imply f extension and all z*inx extension
> imply zfinx extension, so we j
The problem here is we were outputing long_long instead of
"long long". This was just an oversight and a missing check.
Committed as obvious after a bootstrap/test on x86_64-linux-gnu.
gcc/fortran/ChangeLog:
* dump-parse-tree.cc (get_c_type_name): Fix "long_long"
type name to be
On 3/23/23 17:18, Patrick Palka wrote:
Here we're issuing a duplicate diagnostic for the use of the deleted
foo, first from the CALL_EXPR case of tsubst_copy_and_build (which
doesn't exit early upon failure), and again from from build_over_call
when rebuilding the substituted CALL_EXPR.
We can f
On 3/29/23 16:57, Jakub Jelinek wrote:
On Wed, Mar 29, 2023 at 04:35:15PM -0400, Jason Merrill wrote:
On the following testcase we emit notes in
maybe_inform_about_fndecl_for_bogus_argument_init
despite no warning/error being printed before it.
This is for the extended floating point type conver
There's some typo for the standard pattern name for unsigned_{float,fix},
it should be floatunsmn2/fixuns_truncmn2, not ufloatmn2/ufix_truncmn2
in current trunk, the patch fix the typo.
Also vcvttps2udq is available under AVX512VL, so it can be generated
directly instead of being emulated via vcvt
From: Juzhe-Zhong
gcc/ChangeLog:
* config/riscv/riscv-vsetvl.cc (pass_vsetvl::cleanup_insns): Adapt PASS.
* config/riscv/vector-iterators.md: New unspec.
* config/riscv/vector.md: Optimize fault only first load pattern.
gcc/testsuite/ChangeLog:
* gcc.target/risc
On 30/03/23 00:39 +0100, Jonathan Wakely wrote:
Tested powerpc64le-linux. Pushed to trunk.
-- >8 --
We need to strip cv-qualifiers from the result of the callable passed to
std::optional::transform.
For std::expected::transform and std::expected::transform_error I
noticed we were stripping cv-
Tested powerpc64le-linux. Pushed to trunk.
-- >8 --
Change ip::basic_endpoint to work in constant expressions, but only for
C++20 and later (due to the use of a union, which cannot change active
member in constexpr evaluation until C++20).
During constant evaluation we cannot inspect the common
Tested powerpc64le-linux. Pushed to trunk.
-- >8 --
LWG 3843 adds some type requirements to std::expected::value to ensure
that it can correctly copy the error value if it needs to throw an
exception. We don't need to do anything to enforce that, because it will
already be ill-formed if the type
Tested powerpc64le-linux. Pushed to trunk.
-- >8 --
We need to strip cv-qualifiers from the result of the callable passed to
std::optional::transform.
For std::expected::transform and std::expected::transform_error I
noticed we were stripping cv-qualifiers but were also incorrectly
stripping ref
Tested powerpc64le-linux. Pushed to trunk.
-- >8 --
The standard does not allow std::optional, std::optional,
std::optional etc. and although we do give errors, they come from
down inside the internals of std::optional. We could improve the static
assertions at the top of the class so that users
Stepping through a gdb session inspecting costs that cause
gcc.dg/tree-ssa/slsr-13.c to fail, exposed that before this
patch, cris_rtx_costs told that a shift of 1 of a register
costs 5, while adding two registers costs 4.
Making the cost of a quick-immediate constant equal to using
a register (de
On Wed, Mar 29, 2023 at 3:08 PM Gerald Pfeifer wrote:
>
> Business as usual - 301 Moved Permanently.
Just FYI, dwarfstd is now hosted by sourceware too. So I doubt these
URLs will change after this.
Thanks,
Andrew
>
> Gerald
> ---
> htdocs/gcc-4.7/changes.html | 8
> 1 file changed, 4
Hello,
On Wed, Mar 08 2023, Jason Merrill via Gcc-patches wrote:
> On 3/8/23 11:15, Jason Merrill wrote:
>> On 3/8/23 10:53, Jan Hubicka wrote:
[...]
>>> We have n->reset () for that which is used in similar situation when
>>> frontends overwrites extern inline function by its different offline
>>
Business as usual - 301 Moved Permanently.
Gerald
---
htdocs/gcc-4.7/changes.html | 8
1 file changed, 4 insertions(+), 4 deletions(-)
diff --git a/htdocs/gcc-4.7/changes.html b/htdocs/gcc-4.7/changes.html
index f98f108c..91159f1f 100644
--- a/htdocs/gcc-4.7/changes.html
+++ b/htdocs/gc
On 3/27/23 09:30, Patrick Palka wrote:
On Thu, 23 Mar 2023, Patrick Palka wrote:
r13-995-g733a792a2b2e16 worked around the problem of FUNCTION_DECL
template arguments not always getting marked as odr-used by redundantly
calling mark_used on the substituted ADDR_EXPR callee of a CALL_EXPR.
This
On Wed, Mar 29, 2023 at 04:35:15PM -0400, Jason Merrill wrote:
> > On the following testcase we emit notes in
> > maybe_inform_about_fndecl_for_bogus_argument_init
> > despite no warning/error being printed before it.
> > This is for the extended floating point type conversions where pedwarn
> > is
On 3/25/23 06:08, Jakub Jelinek wrote:
Hi!
On the following testcase we emit notes in
maybe_inform_about_fndecl_for_bogus_argument_init
despite no warning/error being printed before it.
This is for the extended floating point type conversions where pedwarn
is used, and complained is used there f
On 3/17/23 11:26, Patrick Palka wrote:
Here we're crashing during satisfaction for the NTTP 'C auto' from
do_auto_deduction ultimately because convert_template_argument / unify
don't pass all outer template arguments to do_auto_deduction, and during
satisfaction we need to know all arguments. Wh
Hi!
This changed needs more attention I'm afraid:
On 2023-02-23T15:18:04+0100, Jakub Jelinek via Gcc-patches
wrote:
> On Wed, Feb 22, 2023 at 02:33:42PM -0300, Alexandre Oliva via Gcc-patches
> wrote:
>> When a multi-source module is found to be unsupported, we fail
>> module_cmi_p and subsequ
On 3/26/23 12:54, Iain Sandoe wrote:
Tested on x86_64-darwin21, x86-64-linux-gnu
OK for trunk?
Iain
When we need to 'promote' a value (i.e. store it in the coroutine frame) it
is given a frame entry name. This was based on the DECL_UID for slot vars.
However, when LTO is used, the names from mu
I've backported the following patches to the releases/gcc-12 branch
(shown in reverse chronological order):
r12-9367-g7903e0bca00384:
analyzer: fix ICE on certain longjmp calls [PR109094]
Cherrypicked from r13-6749-g430d7d88c1a123.
r12-9366-g833d822ff0e834:
analyzer: fix uninit false +ves
On Wed, Mar 29, 2023 at 9:21 AM liuhongt wrote:
>
> Bootstrapped and regtested on x86_64-pc-linux-gnu{-m32,}
> Ok for GCC14 stage-1(or maybe trunk)?
>
> gcc/ChangeLog:
>
> * config/i386/i386-expand.cc (expand_vec_perm_blend): Generate
> vpblendd instead of vpblendw for V4SI under a
I merged trunk revision aa8f4242efc99f24de73c59d53996f28db28c13f to
the gccgo branch.
Ian
On 3/28/23 13:37, Patrick Palka wrote:
Now that we resolve non-dependent variable template-ids ahead of time,
cp_finish_decl needs to handle a new invalid situation: we can end up
trying to instantiate a variable template with deduced return type
before we fully parsed (and attached) its initiali
On 3/29/23 07:36, Benjamin Priour wrote:
Hi, below is my first patch ever. I ran the testsuites against trunk
20230322, everything seems OK to me, but as it is my first submission
I'd like to be sure of it.
Thanks a lot for the review !
Thanks!
Please see https://gcc.gnu.org/contribute.html#
The patch, or a slight variation (attached), in the PR allows us to
generate better ranges be recomputing longer instruction sequences on
outgoing edges.
This in fact also fixes
XPASS: gcc.dg/Walloca-13.c (test for bogus messages, line 11)
[local count: 1073741824]:
_1 = p_5(D) - q_6(D);
On Fri, Nov 13, 2020 at 11:53:43AM -0700, Jeff Law via Gcc-patches wrote:
>
> On 5/1/20 6:06 PM, Seija Kijin via Gcc-patches wrote:
> > The original code in libiberty says "FIXME" and then says it has not been
> > validated to be ANSI compliant. However, this patch changes the function to
> > matc
So as mentioned in the PR the underlying issue here is combine changes
the form of an existing insn, but fails to force re-recognition. As a
result other parts of the compiler blow up.
/* Temporarily replace the set's source with the
contents of the RE
From: yulong
This patch fixes the problem of the contracts-tmpl-spec2.c running failure.
When run the dejagnu test, I find that the output is inconsistent with that
verified
in the testcase. So I try to modify it, and then it can be passed.
gcc/testsuite/ChangeLog:
* g++.dg/contracts/
On 3/29/23 15:05, Richard Biener wrote:
> I wonder if we can simply alias --enable-link-mutex to
> --enable-link-serialization though.
Sure, we can. Do you want it for gcc-13 as well?
Cheers,
Martin
On Wed, Mar 29, 2023 at 3:01 PM Jakub Jelinek via Gcc-patches
wrote:
>
> On Wed, Mar 29, 2023 at 02:55:01PM +0200, Martin Liška wrote:
> > Ready to be installed?
> > Thanks,
> > Martin
> >
> > PR bootstrap/109310
> >
> > gcc/ChangeLog:
> >
> > * configure.ac: Emit a warning for depreca
On 3/29/23 15:02, Andreas Schwab wrote:
> On Mär 29 2023, Martin Liška wrote:
>
>> diff --git a/gcc/configure.ac b/gcc/configure.ac
>> index 120151c474a..13c1a85851c 100644
>> --- a/gcc/configure.ac
>> +++ b/gcc/configure.ac
>> @@ -7013,6 +7013,7 @@ AC_MSG_RESULT($do_link_mutex)
>>
>> if test "
On Mär 29 2023, Martin Liška wrote:
> diff --git a/gcc/configure.ac b/gcc/configure.ac
> index 120151c474a..13c1a85851c 100644
> --- a/gcc/configure.ac
> +++ b/gcc/configure.ac
> @@ -7013,6 +7013,7 @@ AC_MSG_RESULT($do_link_mutex)
>
> if test "$do_link_mutex" = "yes"; then
> DO_LINK_MUTEX=t
On Wed, Mar 29, 2023 at 02:55:01PM +0200, Martin Liška wrote:
> Ready to be installed?
> Thanks,
> Martin
>
> PR bootstrap/109310
>
> gcc/ChangeLog:
>
> * configure.ac: Emit a warning for deprecated option
> --enable-link-mutex.
> * configure: Regenerate.
LGTM.
> diff -
Ready to be installed?
Thanks,
Martin
PR bootstrap/109310
gcc/ChangeLog:
* configure.ac: Emit a warning for deprecated option
--enable-link-mutex.
* configure: Regenerate.
---
gcc/configure| 1 +
gcc/configure.ac | 1 +
2 files changed, 2 insertions(+)
diff
> -Original Message-
> From: Stam Markianos-Wright
> Sent: Wednesday, March 29, 2023 11:50 AM
> To: gcc-patches@gcc.gnu.org
> Cc: Kyrylo Tkachov
> Subject: arm: Fix MVE vcreate definition
>
> Hi all,
>
> I just found a bug that goes back to the initial merge of
> the MVE backend: The
The following tells pointer-query to prefer a zero size when we
are querying for the size range for a write into an object we've
determined is of zero size. That avoids diagnostics about really
varying size arguments that just get a meaningful range for example
because they are multiplied by an el
When forwprop discovers unreachable code or makes decisions based
on unreachable edges make sure to cleanup the CFG since otherwise
SSA form can become invalid.
Bootstrapped and tested on x86_64-unknown-linux-gnu, pushed.
PR tree-optimization/109331
* tree-ssa-forwprop.cc (pass_fo
Hi, below is my first patch ever. I ran the testsuites against trunk
20230322, everything seems OK to me, but as it is my first submission I'd
like to be sure of it.
Thanks a lot for the review !
diff --git a/gcc/cp/class.cc b/gcc/cp/class.cc
index 68b62086340..147a7458488 100644
--- a/gcc/cp/clas
Hi all,
I just found a bug that goes back to the initial merge of
the MVE backend: The vcreate intrinsic has had it's vector
lanes mixed up, compared to what was intended (as per
the ACLE) definition. This is also a discrepancy with clang:
https://godbolt.org/z/4n93e5aqj
This patches simply swit
Cool. Thank you all for this, have a nice day!
Pan
From: juzhe.zh...@rivai.ai
Sent: Wednesday, March 29, 2023 5:35 PM
To: rguenther ; Li, Pan2
Cc: gcc-patches ; Kito.cheng ;
Wang, Yanzhang
Subject: Re: Re: [PATCH v2] RISC-V: Bugfix for RVV vbool*_t vn_reference_equal.
Thanks Richard && Pan.
On 3/28/23 10:50, Aldy Hernandez wrote:
On 3/28/23 09:54, Jakub Jelinek wrote:
Hi!
On Wed, Mar 22, 2023 at 07:32:44AM +0100, Aldy Hernandez wrote:
* value-range.cc (frange::set): Add nan_state argument.
* value-range.h (class nan_state): New.
(frange::get_nan_state): New.
Th
Thanks Richard && Pan.
Pan has passed the bootstrap and I will merge this patch when GCC 14 is open (I
have write access now).
juzhe.zh...@rivai.ai
From: Richard Biener
Date: 2023-03-29 17:24
To: pan2.li
CC: gcc-patches; juzhe.zhong; kito.cheng; yanzhang.wang
Subject: Re: [PATCH v2] RISC-V:
On Wed, 29 Mar 2023, pan2...@intel.com wrote:
> From: Pan Li
>
> In most architecture the precision_size of vbool*_t types are caculated
> like as the multiple of the type size. For example:
> precision_size = type_size * 8 (aka, bit count per bytes).
>
> Unfortunately, some architecture like
Thank you Biener for the professional suggestion. That make it more clean and
simple, and update the PATCH v2 for this already.
Pan
-Original Message-
From: Richard Biener
Sent: Wednesday, March 29, 2023 4:10 PM
To: Li, Pan2
Cc: gcc-patches@gcc.gnu.org; juzhe.zh...@rivai.ai; kito.ch..
From: Pan Li
In most architecture the precision_size of vbool*_t types are caculated
like as the multiple of the type size. For example:
precision_size = type_size * 8 (aka, bit count per bytes).
Unfortunately, some architecture like RISC-V will adjust the precision_size
for the vbool*_t in ord
Hi Manfred,
Indeed I do :-) Thanks for the spot. I have decided that it will be less
messy if I roll all the testcases into one or, perhaps two =>
associate_xx.f90
Forgetting the space before the final brace seems to be rife!
Cheers
Paul
On Wed, 29 Mar 2023 at 09:24, Manfred Schwarb wrote:
On Wed, Mar 29, 2023 at 10:35 AM 陈逸轩 wrote:
>
> Thanks for your suggestion!But I met the issue that if I declare a int type
> variable,this variable can't be converted to vector type. Could you teach me
> more detail?
I don't understand what you mean. I have pushed a fix.
Richard.
> Best reg
The g++.dg/pr94920.C testcase looks for a specific number of
ABS_EXPRs but the vector example is prone to vector lowering so
the following instead of scanning the optimized dump scans the
forwprop1 dump which is before vector lowering and the point the
transforms should have happened.
Tested on ri
Thanks for your suggestion!But I met the issue that if I declare a int type
variable,this variable can't be converted to vector type. Could you teach me
more detail?
Best regards!
Yixuan Chen
"Richard Biener" wrote:
> On Mon, Mar 27, 2023 at 12:37 PM wrote:
> >
>
There's interfering between the to_removed queue and other mechanisms
removing stmts, in this case remove_prop_source_from_use. The following
makes the to_remove queue draining more permissive.
Bootstrapped and tested on x86_64-unknown-linux-gnu, pushed.
PR tree-optimization/109327
Am 28.03.23 um 23:04 schrieb Paul Richard Thomas via Fortran:
> Hi All,
>
> I have made a start on ASSOCIATE issues. Some of the low(-ish) hanging
> fruit are already fixed but I have yet to check that they a really fixed
> and to close them:
> pr102106, pr102111, pr104430, pr106048, pr85510, pr874
On Linux/x86_64,
776a5bb5894315ab144dc74222fc580fde8fdd87 is the first bad commit
commit 776a5bb5894315ab144dc74222fc580fde8fdd87
Author: Richard Biener
Date: Wed Mar 22 10:05:19 2023 +0100
rtl-optimization/109237 - speedup bb_is_just_return
caused
FAIL: gcc.dg/guality/pr54200.c -Og -DP
Hi Haochen,
on 2023/3/28 15:45, HAO CHEN GUI wrote:
> Hi,
> This patch removes byte reverse operation before vector integer sign
> extension on big endian. These built-ins require to sign extend the element
> of the input vector that would fall in the least significant portion of the
> result el
On Wed, Mar 29, 2023 at 9:55 AM Pan Li via Gcc-patches
wrote:
>
> From: Pan Li
>
> In most architecture the precision_size of vbool*_t types are caculated
> like as the multiple of the type size. For example:
> precision_size = type_size * 8 (aka, bit count per bytes).
>
> Unfortunately, some ar
From: Pan Li
In most architecture the precision_size of vbool*_t types are caculated
like as the multiple of the type size. For example:
precision_size = type_size * 8 (aka, bit count per bytes).
Unfortunately, some architecture like RISC-V will adjust the precision_size
for the vbool*_t in ord
Bootstrapped and regtested on x86_64-pc-linux-gnu{-m32,}
Ok for GCC14 stage-1(or maybe trunk)?
gcc/ChangeLog:
* config/i386/i386-expand.cc (expand_vec_perm_blend): Generate
vpblendd instead of vpblendw for V4SI under avx2.
gcc/testsuite/ChangeLog:
* gcc.target/i386/pr888
Hi,
By addressing Alexander's comments, against v1 this
patch v2 mainly:
- Rename no_real_insns_p to no_real_nondebug_insns_p;
- Introduce enum rgn_bb_deps_free_action for three
kinds of actions to free deps;
- Change function free_deps_for_bb_no_real_insns_p to
resolve_forw_deps wh
62 matches
Mail list logo