bircoph     15/05/25 00:11:52

  Modified:             metadata.xml ChangeLog
  Added:                clsync-0.4.1.ebuild
  Log:
  Version bump.
  
  Signed-off-by: Andrew Savchenko <birc...@gentoo.org>
  (Portage version: 2.2.20/cvs/Linux i686, signed Manifest commit with key 
565953B95372756C)

Revision  Changes    Path
1.3                  app-admin/clsync/metadata.xml

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/app-admin/clsync/metadata.xml?rev=1.3&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/app-admin/clsync/metadata.xml?rev=1.3&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/app-admin/clsync/metadata.xml?r1=1.2&r2=1.3

Index: metadata.xml
===================================================================
RCS file: /var/cvsroot/gentoo-x86/app-admin/clsync/metadata.xml,v
retrieving revision 1.2
retrieving revision 1.3
diff -u -r1.2 -r1.3
--- metadata.xml        28 Feb 2015 21:38:00 -0000      1.2
+++ metadata.xml        25 May 2015 00:11:52 -0000      1.3
@@ -18,9 +18,11 @@
        <flag name="cluster">Enable clustering support (allows master-master 
clsync on multiple hosts). Not fully implemented yet.</flag>
        <flag name="control-socket">Enable AF_UNIX control socket 
support.</flag>
        <flag name="cgroups">Use cgroups to limit /dev access.</flag>
+       <flag name="extra-debug">Enable extra debugging. This will hurt 
performance badly. Be ready for tons of output.</flag>
        <flag name="extra-hardened">Enable extra security checks. This will 
hurt performance.</flag>
        <flag name="gio">Enable GIO for FS monitoring (glib based alternative 
to inotify interface, not recommended; if both are compiled, may be selected at 
runtime).</flag>
        <flag name="highload-locks">Allows to use spinlocks for short delays 
instead of mutexes, but only on SMP systems.</flag>
        <flag name="namespaces">Enable namespaces isolation.</flag>
+       <flag name="seccomp">Enable seccomp for system call filtering.</flag>
 </use>
 </pkgmetadata>



1.5                  app-admin/clsync/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/app-admin/clsync/ChangeLog?rev=1.5&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/app-admin/clsync/ChangeLog?rev=1.5&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/app-admin/clsync/ChangeLog?r1=1.4&r2=1.5

Index: ChangeLog
===================================================================
RCS file: /var/cvsroot/gentoo-x86/app-admin/clsync/ChangeLog,v
retrieving revision 1.4
retrieving revision 1.5
diff -u -r1.4 -r1.5
--- ChangeLog   28 Feb 2015 21:38:00 -0000      1.4
+++ ChangeLog   25 May 2015 00:11:52 -0000      1.5
@@ -1,6 +1,12 @@
 # ChangeLog for app-admin/clsync
 # Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/clsync/ChangeLog,v 1.4 2015/02/28 
21:38:00 bircoph Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/clsync/ChangeLog,v 1.5 2015/05/25 
00:11:52 bircoph Exp $
+
+*clsync-0.4.1 (25 May 2015)
+
+  25 May 2015; Andrew Savchenko <birc...@gentoo.org> +clsync-0.4.1.ebuild,
+  metadata.xml:
+  Version bump. Apply upstream fixes. Add extra debugging support.
 
   28 Feb 2015; Andrew Savchenko <birc...@gentoo.org> metadata.xml:
   seccomp USE flag is now global, removing from metadata



1.1                  app-admin/clsync/clsync-0.4.1.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/app-admin/clsync/clsync-0.4.1.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/app-admin/clsync/clsync-0.4.1.ebuild?rev=1.1&content-type=text/plain

Index: clsync-0.4.1.ebuild
===================================================================
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/app-admin/clsync/clsync-0.4.1.ebuild,v 1.1 
2015/05/25 00:11:52 bircoph Exp $

EAPI=5

if [[ ${PV} == "9999" ]] ; then
        inherit git-r3
        EGIT_REPO_URI="https://github.com/xaionaro/${PN}.git";
else
        PVER="20150524-v2"
        SRC_URI="
                https://github.com/xaionaro/${PN}/archive/v${PV}.tar.gz -> 
${P}.tar.gz
                http://dev.gentoo.org/~bircoph/patches/${P}-${PVER}.patch.xz
        "
        KEYWORDS="~amd64 ~x86"
fi

inherit autotools eutils linux-info

DESCRIPTION="Live sync tool based on inotify, written in GNU C"
HOMEPAGE="https://github.com/xaionaro/clsync http://ut.mephi.ru/oss/clsync";
LICENSE="GPL-3+"
SLOT="0"
IUSE="+caps cluster control-socket cgroups debug extra-debug
extra-hardened gio hardened +highload-locks +inotify mhash
namespaces seccomp"

REQUIRED_USE="
        || ( gio inotify )
        extra-debug? ( debug )
        extra-hardened? ( hardened )
        mhash? ( cluster )
        seccomp? ( caps )
"
RDEPEND="
        dev-libs/glib:2
        cgroups? ( dev-libs/libcgroup )
        mhash? ( app-crypt/mhash )
"
DEPEND="${CDEPEND}
        virtual/pkgconfig
"
RDEPEND="${CDEPEND}
        ~app-doc/clsync-docs-${PV}
"

pkg_pretend() {
        use namespaces && CONFIG_CHECK="~NAMESPACES ~UTS_NS ~IPC_NS ~USER_NS 
~PID_NS ~NET_NS"
        use seccomp && CONFIG_CHECK+=" ~SECCOMP"
        check_extra_config
}

src_prepare() {
        # upstream fixes for 0.4.1
        epatch "${WORKDIR}/${P}-${PVER}.patch"
        eautoreconf
}

src_configure() {
        local harden_level=0
        use hardened && harden_level=1
        use extra-hardened && harden_level=2

        local debug_level=0
        use debug && debug_level=1
        use extra-debug && debug_level=2

        econf \
                --docdir="${EPREFIX}/usr/share/doc/${PF}" \
                --disable-socket-library \
                --enable-clsync \
                --enable-debug=${debug_level} \
                --enable-paranoid=${harden_level} \
                --without-bsm \
                --without-kqueue \
                $(use_enable caps capabilities) \
                $(use_enable cluster) \
                $(use_enable control-socket socket) \
                $(use_enable highload-locks) \
                $(use_enable namespaces unshare) \
                $(use_enable seccomp) \
                $(use_with cgroups libcgroup) \
                $(use_with gio gio lib) \
                $(use_with inotify inotify native) \
                $(use_with mhash)
}

src_install() {
        emake DESTDIR="${D}" install

        # docs go into clsync-docs
        rm -rf "${ED}/usr/share/doc" || die

        newinitd "${FILESDIR}/${PN}.initd" "${PN}"
        newconfd "${FILESDIR}/${PN}.confd" "${PN}"

        # filter rules and sync scripts are supposed to be here
        keepdir "${EPREFIX}/etc/${PN}"
        insinto "/etc/${PN}"
        newins "${FILESDIR}/${PN}.conf" "${PN}.conf"
}

pkg_postinst() {
        einfo "${PN} is just a convenient way to run synchronization tools on 
live data,"
        einfo "it doesn't copy data itself, so you need to install software to 
do actual"
        einfo "data transfer. Usually net-misc/rsync is a good choise, but 
${PN} is"
        einfo "is flexible enough to use any user tool, see manual page for 
details."
        einfo
        einfo "${PN} init script can be multiplexed, to use symlink init script 
to"
        einfo "othername and use conf.d/othername to configure it."
        einfo
        einfo "If you're interested in improved security, enable"
        einfo "USE=\"caps cgroups hardened namespaces seccomp\""
}




Reply via email to