floppym     14/03/16 18:16:41

  Modified:             python-updater-9999.ebuild ChangeLog
  Added:                python-updater-0.12.ebuild
  Log:
  Version bump. Incorporate prefix support. Source /lib/gentoo/functions.sh, 
bug 504130.
  
  (Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 
0BBEEA1FEA4843A4)

Revision  Changes    Path
1.12                 app-admin/python-updater/python-updater-9999.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/app-admin/python-updater/python-updater-9999.ebuild?rev=1.12&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/app-admin/python-updater/python-updater-9999.ebuild?rev=1.12&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/app-admin/python-updater/python-updater-9999.ebuild?r1=1.11&r2=1.12

Index: python-updater-9999.ebuild
===================================================================
RCS file: 
/var/cvsroot/gentoo-x86/app-admin/python-updater/python-updater-9999.ebuild,v
retrieving revision 1.11
retrieving revision 1.12
diff -u -r1.11 -r1.12
--- python-updater-9999.ebuild  20 Jan 2014 02:49:18 -0000      1.11
+++ python-updater-9999.ebuild  16 Mar 2014 18:16:41 -0000      1.12
@@ -1,17 +1,16 @@
 # Copyright 1999-2014 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: 
/var/cvsroot/gentoo-x86/app-admin/python-updater/python-updater-9999.ebuild,v 
1.11 2014/01/20 02:49:18 floppym Exp $
+# $Header: 
/var/cvsroot/gentoo-x86/app-admin/python-updater/python-updater-9999.ebuild,v 
1.12 2014/03/16 18:16:41 floppym Exp $
 
 EAPI=5
 
 if [[ "${PV}" == "9999" ]]; then
-       inherit git-2
+       inherit git-r3
 fi
 
 DESCRIPTION="Script used to reinstall Python packages after changing of active 
Python versions"
 HOMEPAGE="http://www.gentoo.org/proj/en/Python/";
 if [[ "${PV}" == "9999" ]]; then
-       SRC_URI=""
        EGIT_REPO_URI="git://git.overlays.gentoo.org/proj/python-updater.git"
 else
        SRC_URI="http://dev.gentoo.org/~floppym/dist/${P}.tar.bz2";
@@ -22,17 +21,18 @@
 SLOT="0"
 IUSE=""
 
-DEPEND="$([[ "${PV}" == "9999" ]] && echo "sys-apps/help2man")"
-RDEPEND="|| ( >=sys-apps/portage-2.1.6 >=sys-apps/paludis-0.56.0 )"
+if [[ ${PV} == 9999 ]]; then
+       DEPEND="
+               sys-apps/gentoo-functions
+               sys-apps/help2man
+       "
+fi
+RDEPEND="
+       sys-apps/gentoo-functions
+       || ( >=sys-apps/portage-2.1.6 >=sys-apps/paludis-0.56.0 
sys-apps/pkgcore )
+"
 
 src_compile() {
-       if [[ "${PV}" == "9999" ]]; then
-               emake ${PN}.1 || die "Generation of man page failed"
-       fi
-}
-
-src_install() {
-       dosbin ${PN}
-       doman ${PN}.1
-       dodoc AUTHORS
+       [[ ${PV} == 9999 ]] && emake python-updater
+       default
 }



1.94                 app-admin/python-updater/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/app-admin/python-updater/ChangeLog?rev=1.94&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/app-admin/python-updater/ChangeLog?rev=1.94&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/app-admin/python-updater/ChangeLog?r1=1.93&r2=1.94

Index: ChangeLog
===================================================================
RCS file: /var/cvsroot/gentoo-x86/app-admin/python-updater/ChangeLog,v
retrieving revision 1.93
retrieving revision 1.94
diff -u -r1.93 -r1.94
--- ChangeLog   20 Jan 2014 02:49:18 -0000      1.93
+++ ChangeLog   16 Mar 2014 18:16:41 -0000      1.94
@@ -1,6 +1,13 @@
 # ChangeLog for app-admin/python-updater
 # Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/python-updater/ChangeLog,v 1.93 
2014/01/20 02:49:18 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/python-updater/ChangeLog,v 1.94 
2014/03/16 18:16:41 floppym Exp $
+
+*python-updater-0.12 (16 Mar 2014)
+
+  16 Mar 2014; Mike Gilbert <flop...@gentoo.org> +python-updater-0.12.ebuild,
+  python-updater-9999.ebuild:
+  Version bump. Incorporate prefix support. Source /lib/gentoo/functions.sh, 
bug
+  504130.
 
   20 Jan 2014; Mike Gilbert <flop...@gentoo.org> python-updater-0.11.ebuild,
   python-updater-9999.ebuild:



1.1                  app-admin/python-updater/python-updater-0.12.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/app-admin/python-updater/python-updater-0.12.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/app-admin/python-updater/python-updater-0.12.ebuild?rev=1.1&content-type=text/plain

Index: python-updater-0.12.ebuild
===================================================================
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: 
/var/cvsroot/gentoo-x86/app-admin/python-updater/python-updater-0.12.ebuild,v 
1.1 2014/03/16 18:16:41 floppym Exp $

EAPI=5

if [[ "${PV}" == "9999" ]]; then
        inherit git-r3
fi

DESCRIPTION="Script used to reinstall Python packages after changing of active 
Python versions"
HOMEPAGE="http://www.gentoo.org/proj/en/Python/";
if [[ "${PV}" == "9999" ]]; then
        EGIT_REPO_URI="git://git.overlays.gentoo.org/proj/python-updater.git"
else
        SRC_URI="http://dev.gentoo.org/~floppym/dist/${P}.tar.bz2";
        KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 
~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd"
fi

LICENSE="GPL-2"
SLOT="0"
IUSE=""

if [[ ${PV} == 9999 ]]; then
        DEPEND="
                sys-apps/gentoo-functions
                sys-apps/help2man
        "
fi
RDEPEND="
        sys-apps/gentoo-functions
        || ( >=sys-apps/portage-2.1.6 >=sys-apps/paludis-0.56.0 
sys-apps/pkgcore )
"

src_compile() {
        [[ ${PV} == 9999 ]] && emake python-updater
        default
}




Reply via email to