mgorny      14/06/17 15:22:36

  Modified:             ChangeLog
  Added:                zpaq-extras-3.ebuild
  Log:
  Add lazy2 & update bmp filter. Switch to new-style /usr/lib libexecdir.
  
  (Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 
EFB4464E!)

Revision  Changes    Path
1.8                  app-arch/zpaq-extras/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/app-arch/zpaq-extras/ChangeLog?rev=1.8&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/app-arch/zpaq-extras/ChangeLog?rev=1.8&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/app-arch/zpaq-extras/ChangeLog?r1=1.7&r2=1.8

Index: ChangeLog
===================================================================
RCS file: /var/cvsroot/gentoo-x86/app-arch/zpaq-extras/ChangeLog,v
retrieving revision 1.7
retrieving revision 1.8
diff -u -r1.7 -r1.8
--- ChangeLog   19 Feb 2014 16:57:54 -0000      1.7
+++ ChangeLog   17 Jun 2014 15:22:36 -0000      1.8
@@ -1,6 +1,11 @@
 # ChangeLog for app-arch/zpaq-extras
 # Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/zpaq-extras/ChangeLog,v 1.7 
2014/02/19 16:57:54 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/zpaq-extras/ChangeLog,v 1.8 
2014/06/17 15:22:36 mgorny Exp $
+
+*zpaq-extras-3 (17 Jun 2014)
+
+  17 Jun 2014; Michał Górny <mgo...@gentoo.org> +zpaq-extras-3.ebuild:
+  Add lazy2 & update bmp filter. Switch to new-style /usr/lib libexecdir.
 
   19 Feb 2014; Michał Górny <mgo...@gentoo.org> -zpaq-extras-1.ebuild:
   Drop old.



1.1                  app-arch/zpaq-extras/zpaq-extras-3.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/app-arch/zpaq-extras/zpaq-extras-3.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/app-arch/zpaq-extras/zpaq-extras-3.ebuild?rev=1.1&content-type=text/plain

Index: zpaq-extras-3.ebuild
===================================================================
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/app-arch/zpaq-extras/zpaq-extras-3.ebuild,v 
1.1 2014/06/17 15:22:36 mgorny Exp $

EAPI=5
inherit toolchain-funcs

DESCRIPTION="A set of additional compression profiles for app-arch/zpaq"
HOMEPAGE="http://mattmahoney.net/dc/zpaq.html";
SRC_URI="http://mattmahoney.net/dc/bwt_j3.zip
        http://mattmahoney.net/dc/bwt_slowmode1.zip
        http://mattmahoney.net/dc/exe_j1.zip
        http://mattmahoney.net/dc/jpg_test2.zip
        http://mattmahoney.net/dc/min.zip
        http://mattmahoney.net/dc/fast.cfg -> zpaq-fast.cfg
        http://mattmahoney.net/dc/mid.cfg -> zpaq-mid.cfg
        http://mattmahoney.net/dc/max.cfg -> zpaq-max.cfg
        http://mattmahoney.net/dc/bmp_j4c.zip
        http://mattmahoney.net/dc/lz1.zip
        http://mattmahoney.net/dc/lazy100.zip
        http://mattmahoney.net/dc/lazy210.zip";

LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64"
IUSE=""

DEPEND="app-arch/unzip"
RDEPEND=">=app-arch/zpaq-6.19"

S=${WORKDIR}

src_unpack() {
        local x
        for x in ${A}; do
                if [[ ${x} == *.cfg ]]; then
                        cp "${DISTDIR}"/${x} ${x#zpaq-} || die
                fi
        done

        default
}

src_configure() {
        sed \
                -e "/^pcomp zpaq/s:-m:-m${EPREFIX}/usr/share/zpaq/:" \
                -e "s:^pcomp zpaq:pcomp ${EPREFIX}/usr/bin/zpaq:" \
                -e "s:^pcomp \([^/]\):pcomp ${EPREFIX}/usr/lib/zpaq/\1:" \
                -i *.cfg || die

        local sources=( *.cpp )
        # (the following assignment flattens the array)
        progs=${sources[@]%.cpp}
}

src_compile() {
        tc-export CXX
        emake ${progs} || die
}

src_install() {
        exeinto /usr/lib/zpaq
        doexe ${progs} || die

        insinto /usr/share/zpaq
        doins *.cfg || die
}




Reply via email to