tomka       14/10/25 12:41:42

  Modified:             ChangeLog
  Added:                anki-2.0.31.ebuild
  Removed:              anki-2.0.24.ebuild anki-2.0.29.ebuild
  Log:
  bump to 2.0.31
  
  (Portage version: 2.2.8-r2/cvs/Linux x86_64, signed Manifest commit with key 
565C32BC)

Revision  Changes    Path
1.86                 app-misc/anki/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/app-misc/anki/ChangeLog?rev=1.86&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/app-misc/anki/ChangeLog?rev=1.86&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/app-misc/anki/ChangeLog?r1=1.85&r2=1.86

Index: ChangeLog
===================================================================
RCS file: /var/cvsroot/gentoo-x86/app-misc/anki/ChangeLog,v
retrieving revision 1.85
retrieving revision 1.86
diff -u -r1.85 -r1.86
--- ChangeLog   9 Oct 2014 15:19:15 -0000       1.85
+++ ChangeLog   25 Oct 2014 12:41:42 -0000      1.86
@@ -1,6 +1,12 @@
 # ChangeLog for app-misc/anki
 # Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/anki/ChangeLog,v 1.85 2014/10/09 
15:19:15 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/anki/ChangeLog,v 1.86 2014/10/25 
12:41:42 tomka Exp $
+
+*anki-2.0.31 (25 Oct 2014)
+
+  25 Oct 2014; Thomas Kahle <to...@gentoo.org> +anki-2.0.31.ebuild,
+  -anki-2.0.24.ebuild, -anki-2.0.29.ebuild:
+  bump to 2.0.31
 
   09 Oct 2014; Agostino Sarubbo <a...@gentoo.org> anki-2.0.28.ebuild:
   Stable for amd64, wrt bug #518844



1.1                  app-misc/anki/anki-2.0.31.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/app-misc/anki/anki-2.0.31.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/app-misc/anki/anki-2.0.31.ebuild?rev=1.1&content-type=text/plain

Index: anki-2.0.31.ebuild
===================================================================
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/app-misc/anki/anki-2.0.31.ebuild,v 1.1 
2014/10/25 12:41:42 tomka Exp $

EAPI=5

PYTHON_COMPAT=( python2_6 python2_7 )
PYTHON_REQ_USE="sqlite"

inherit eutils python-single-r1

DESCRIPTION="A spaced-repetition memory training program (flash cards)"
HOMEPAGE="http://ichi2.net/anki/";
SRC_URI="http://ankisrs.net/download/mirror/${P}.tgz";

LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="latex +recording +sound"

RDEPEND="${PYTHON_DEPS}
         dev-python/PyQt4[X,svg,webkit]
         >=dev-python/httplib2-0.7.4
         dev-python/beautifulsoup:python-2
         dev-python/send2trash
         recording? ( media-sound/lame
                                  >=dev-python/pyaudio-0.2.4 )
         sound? ( media-video/mplayer )
         latex? ( app-text/texlive
                          app-text/dvipng )"
DEPEND=""

pkg_setup(){
        python-single-r1_pkg_setup
}

src_prepare() {
        rm -r thirdparty || die
        sed -i -e "s/updates=True/updates=False/" \
                aqt/profiles.py || die
}

# Nothing to configure or compile
src_configure() {
        true;
}

src_compile() {
        true;
}

src_install() {
        doicon ${PN}.png
        domenu ${PN}.desktop
        doman ${PN}.1

        dodoc README README.development
        python_domodule aqt anki
        python_doscript anki/anki
}

pkg_preinst() {
        if has_version "<app-misc/anki-2" ; then
                elog "Anki 2 is a rewrite of Anki with many new features and"
                elog "a new database format.  On the first run your decks are"
                elog "converted to the new format and a backup of your Anki-1"
                elog "decks is created.  Please read the following:"
                elog "http://ankisrs.net/anki2.html";
        fi
}




Reply via email to