eva         14/12/21 12:18:54

  Modified:             ChangeLog
  Added:                glibmm-2.42.0.ebuild
  Removed:              glibmm-2.38.1.ebuild glibmm-2.38.2.ebuild
  Log:
  Version bump for Gnome 3.14. Clean up old revisions.
  
  (Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key 
C6085806)

Revision  Changes    Path
1.229                dev-cpp/glibmm/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-cpp/glibmm/ChangeLog?rev=1.229&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-cpp/glibmm/ChangeLog?rev=1.229&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-cpp/glibmm/ChangeLog?r1=1.228&r2=1.229

Index: ChangeLog
===================================================================
RCS file: /var/cvsroot/gentoo-x86/dev-cpp/glibmm/ChangeLog,v
retrieving revision 1.228
retrieving revision 1.229
diff -u -r1.228 -r1.229
--- ChangeLog   11 Oct 2014 11:35:57 -0000      1.228
+++ ChangeLog   21 Dec 2014 12:18:54 -0000      1.229
@@ -1,6 +1,12 @@
 # ChangeLog for dev-cpp/glibmm
 # Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/glibmm/ChangeLog,v 1.228 2014/10/11 
11:35:57 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/glibmm/ChangeLog,v 1.229 2014/12/21 
12:18:54 eva Exp $
+
+*glibmm-2.42.0 (21 Dec 2014)
+
+  21 Dec 2014; Gilles Dartiguelongue <e...@gentoo.org> -glibmm-2.38.1.ebuild,
+  -glibmm-2.38.2.ebuild, +glibmm-2.42.0.ebuild:
+  Version bump for Gnome 3.14. Clean up old revisions.
 
   11 Oct 2014; Markus Meier <mae...@gentoo.org> glibmm-2.40.0.ebuild:
   arm stable, bug #512012



1.1                  dev-cpp/glibmm/glibmm-2.42.0.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-cpp/glibmm/glibmm-2.42.0.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-cpp/glibmm/glibmm-2.42.0.ebuild?rev=1.1&content-type=text/plain

Index: glibmm-2.42.0.ebuild
===================================================================
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/dev-cpp/glibmm/glibmm-2.42.0.ebuild,v 1.1 
2014/12/21 12:18:54 eva Exp $

EAPI="5"
GCONF_DEBUG="no"

inherit gnome2

DESCRIPTION="C++ interface for glib2"
HOMEPAGE="http://www.gtkmm.org";

LICENSE="LGPL-2.1+ GPL-2+" # GPL-2+ applies only to the build system
SLOT="2"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 
~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris 
~x86-solaris"
IUSE="doc debug examples test"

RDEPEND="
        >=dev-libs/libsigc++-2.2.10:2
        >=dev-libs/glib-2.42:2
"
DEPEND="${RDEPEND}
        virtual/pkgconfig
        doc? ( app-doc/doxygen )
"
# dev-cpp/mm-common needed for eautoreconf

src_prepare() {
        if ! use test; then
                # don't waste time building tests
                sed 's/^\(SUBDIRS =.*\)tests\(.*\)$/\1\2/' \
                        -i Makefile.am Makefile.in || die "sed 1 failed"
        fi

        if ! use examples; then
                # don't waste time building examples
                sed 's/^\(SUBDIRS =.*\)examples\(.*\)$/\1\2/' \
                        -i Makefile.am Makefile.in || die "sed 2 failed"
        fi

        # Test fails with IPv6 but not v4, upstream bug #720073
        sed -e 's:giomm_tls_client/test::' \
                -i tests/Makefile.{am,in} || die

        gnome2_src_prepare
}

src_configure() {
        gnome2_src_configure \
                $(use_enable debug debug-refcounting) \
                $(use_enable doc documentation) \
                --enable-deprecated-api
}

src_test() {
        cd "${S}/tests/"
        default

        for i in */test; do
                ${i} || die "Running tests failed at ${i}"
        done
}

src_install() {
        gnome2_src_install

        if ! use doc && ! use examples; then
                rm -fr "${ED}usr/share/doc/glibmm*"
        fi

        if use examples; then
                find examples -type d -name '.deps' -exec rm -rf {} \; 
2>/dev/null
                dodoc -r examples
        fi
}




Reply via email to