jauhien     14/05/09 22:06:24

  Added:                metadata.xml soci-3.2.2.ebuild ChangeLog
  Log:
  Import from sunrise, closing bug #156506
  
  (Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 
0xB2EFA1D4)

Revision  Changes    Path
1.1                  dev-db/soci/metadata.xml

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-db/soci/metadata.xml?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-db/soci/metadata.xml?rev=1.1&content-type=text/plain

Index: metadata.xml
===================================================================
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd";>
<pkgmetadata>
        <maintainer>
                <email>jauh...@gentoo.org</email>
                <name>Jauhien Piatlicki</name>
        </maintainer>
        <use>
                <flag name="boost">Enable boost support</flag>
                <flag name="empty">Build the sample backend called Empty</flag>
        </use>
</pkgmetadata>



1.1                  dev-db/soci/soci-3.2.2.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-db/soci/soci-3.2.2.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-db/soci/soci-3.2.2.ebuild?rev=1.1&content-type=text/plain

Index: soci-3.2.2.ebuild
===================================================================
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/dev-db/soci/soci-3.2.2.ebuild,v 1.1 
2014/05/09 22:06:24 jauhien Exp $

EAPI=5

inherit cmake-utils

KEYWORDS="~amd64 ~x86"

DESCRIPTION="A db access library for C++ that makes the illusion of embedding 
SQL queries in the regular C++ code"
HOMEPAGE="http://soci.sourceforge.net/";
SRC_URI="mirror://sourceforge/${PN}/${P}.zip"
LICENSE="Boost-1.0"
SLOT="0"
IUSE="boost doc +empty firebird mysql odbc oracle postgres sqlite"

DEPEND="boost? ( dev-libs/boost )
        firebird? ( dev-db/firebird )
        mysql? ( virtual/mysql )
        odbc? ( dev-db/unixODBC )
        oracle? ( dev-db/oracle-instantclient-basic )
        postgres? ( dev-db/postgresql-base )
        sqlite? ( dev-db/sqlite:3 )
"
RDEPEND=${DEPEND}

src_configure() {
        local mycmakeargs="$(cmake-utils_use_with boost )
                $(cmake-utils_use empty SOCI_EMPTY)
                $(cmake-utils_use_with firebird FIREBIRD)
                $(cmake-utils_use_with mysql MYSQL)
                $(cmake-utils_use_with odbc ODBC)
                $(cmake-utils_use_with oracle ORACLE)
                $(cmake-utils_use_with postgres POSTGRESQL)
                $(cmake-utils_use_with sqlite SQLITE3)
                -DWITH_DB2=OFF" #use MYCMAKEARGS if you want enable IBM DB2 
support
        cmake-utils_src_configure
}

src_install() {
        cmake-utils_src_install
        dodoc AUTHORS CHANGES
        if use doc; then
                dohtml -r doc/*
        fi
}



1.1                  dev-db/soci/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-db/soci/ChangeLog?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-db/soci/ChangeLog?rev=1.1&content-type=text/plain

Index: ChangeLog
===================================================================
# ChangeLog for dev-db/soci
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
# $Header: /var/cvsroot/gentoo-x86/dev-db/soci/ChangeLog,v 1.1 2014/05/09 
22:06:24 jauhien Exp $

*soci-3.2.2 (09 May 2014)

  09 May 2014; Jauhien Piatlicki <jauh...@gentoo.org> +metadata.xml,
  +soci-3.2.2.ebuild:
  Import from sunrise, closing bug #156506




Reply via email to