hwoarang    14/05/04 11:20:56

  Modified:             metadata.xml ChangeLog
  Added:                libftd2xx-1.1.12.ebuild
  Log:
  Version bump. Bug #498560 thanks to Brendan Horan <bren...@horan.hk> who will 
proxy-maintain the package
  
  (Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 
09BF4F54C2BA7F3C!)

Revision  Changes    Path
1.4                  dev-embedded/libftd2xx/metadata.xml

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-embedded/libftd2xx/metadata.xml?rev=1.4&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-embedded/libftd2xx/metadata.xml?rev=1.4&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-embedded/libftd2xx/metadata.xml?r1=1.3&r2=1.4

Index: metadata.xml
===================================================================
RCS file: /var/cvsroot/gentoo-x86/dev-embedded/libftd2xx/metadata.xml,v
retrieving revision 1.3
retrieving revision 1.4
diff -u -r1.3 -r1.4
--- metadata.xml        23 Sep 2011 22:11:12 -0000      1.3
+++ metadata.xml        4 May 2014 11:20:55 -0000       1.4
@@ -1,8 +1,10 @@
 <?xml version="1.0" encoding="UTF-8"?>
 <!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd";>
 <pkgmetadata>
+<herd>proxy-maintainer</herd>
 <maintainer>
-  <email>maintainer-nee...@gentoo.org</email>
+       <email>bren...@horan.hk</email>
+       <name>Brendan Horan</name>
+       <description>Proxy maintainer. Assign bugs to him</description>
 </maintainer>
-<!-- <longdescription>Long description of the package</longdescription> -->
 </pkgmetadata>



1.11                 dev-embedded/libftd2xx/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-embedded/libftd2xx/ChangeLog?rev=1.11&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-embedded/libftd2xx/ChangeLog?rev=1.11&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-embedded/libftd2xx/ChangeLog?r1=1.10&r2=1.11

Index: ChangeLog
===================================================================
RCS file: /var/cvsroot/gentoo-x86/dev-embedded/libftd2xx/ChangeLog,v
retrieving revision 1.10
retrieving revision 1.11
diff -u -r1.10 -r1.11
--- ChangeLog   12 Apr 2013 22:53:34 -0000      1.10
+++ ChangeLog   4 May 2014 11:20:55 -0000       1.11
@@ -1,6 +1,13 @@
 # ChangeLog for dev-embedded/libftd2xx
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-embedded/libftd2xx/ChangeLog,v 1.10 
2013/04/12 22:53:34 ulm Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-embedded/libftd2xx/ChangeLog,v 1.11 
2014/05/04 11:20:55 hwoarang Exp $
+
+*libftd2xx-1.1.12 (04 May 2014)
+
+  04 May 2014; Markos Chandras <hwoar...@gentoo.org> +libftd2xx-1.1.12.ebuild,
+  metadata.xml:
+  Version bump. Bug #498560 thanks to Brendan Horan <bren...@horan.hk> who will
+  proxy-maintain the package
 
   12 Apr 2013; Ulrich Müller <u...@gentoo.org> libftd2xx-0.4.16-r1.ebuild:
   Fix LICENSE, bug 463996.



1.1                  dev-embedded/libftd2xx/libftd2xx-1.1.12.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-embedded/libftd2xx/libftd2xx-1.1.12.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-embedded/libftd2xx/libftd2xx-1.1.12.ebuild?rev=1.1&content-type=text/plain

Index: libftd2xx-1.1.12.ebuild
===================================================================
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: 
/var/cvsroot/gentoo-x86/dev-embedded/libftd2xx/libftd2xx-1.1.12.ebuild,v 1.1 
2014/05/04 11:20:55 hwoarang Exp $

EAPI=5
inherit multilib

MY_P="${PN}${PV}"

DESCRIPTION="Library that allows a direct access to a USB device"
HOMEPAGE="http://www.ftdichip.com/Drivers/D2XX.htm";
SRC_URI="http://www.ftdichip.com/Drivers/D2XX/Linux/${MY_P}.tar.gz";

LICENSE="FTDI LGPL-2.1+"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="examples"

QA_PREBUILT="*"

S=${WORKDIR}

src_install() {

        use amd64 && cd "${S}"/release/build/x86_64
        use x86 && cd "${S}"/release/build/i386

        into /opt
        dolib.so ${PN}.so.${PV}
        dosym ${PN}.so.${PV} /opt/$(get_libdir)/${PN}.so.${PV:0:1}
        dosym ${PN}.so.${PV:0:1} /opt/$(get_libdir)/${PN}.so
        insinto /usr/include
        doins "${S}"/release/ftd2xx.h "${S}"/release/WinTypes.h

        dodir /etc/env.d
        echo "LDPATH=\"/opt/$(get_libdir)\"" > ${D}/etc/env.d/50libftd2xx || die
        if use examples ; then
                find sample lib_table '(' -name '*.so' -o -name '*.[oa]' ')' 
-exec rm -f {} +
                insinto /usr/share/doc/${PF}
                doins -r sample
                insinto /usr/share/doc/${PF}/sample
                doins -r lib_table
        fi

        dodoc "${S}"/release/ReadMe.txt
}




Reply via email to