hasufell    14/10/10 20:17:05

  Modified:             ChangeLog metadata.xml
  Added:                openscenegraph-3.2.1.ebuild
  Log:
  version bump wrt #520442, patch and ebuild from Émeric Maschino
  
  (Portage version: 2.2.14_rc1/cvs/Linux x86_64, signed Manifest commit with 
key BDEED020)

Revision  Changes    Path
1.58                 dev-games/openscenegraph/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-games/openscenegraph/ChangeLog?rev=1.58&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-games/openscenegraph/ChangeLog?rev=1.58&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-games/openscenegraph/ChangeLog?r1=1.57&r2=1.58

Index: ChangeLog
===================================================================
RCS file: /var/cvsroot/gentoo-x86/dev-games/openscenegraph/ChangeLog,v
retrieving revision 1.57
retrieving revision 1.58
diff -u -r1.57 -r1.58
--- ChangeLog   20 Aug 2014 23:47:19 -0000      1.57
+++ ChangeLog   10 Oct 2014 20:17:05 -0000      1.58
@@ -1,6 +1,12 @@
 # ChangeLog for dev-games/openscenegraph
 # Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-games/openscenegraph/ChangeLog,v 1.57 
2014/08/20 23:47:19 reavertm Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-games/openscenegraph/ChangeLog,v 1.58 
2014/10/10 20:17:05 hasufell Exp $
+
+*openscenegraph-3.2.1 (10 Oct 2014)
+
+  10 Oct 2014; Julian Ospald <hasuf...@gentoo.org>
+  +openscenegraph-3.2.1.ebuild, +files/openscenegraph-3.2.1-cmake.patch:
+  version bump wrt #520442, patch and ebuild from Émeric Maschino
 
   20 Aug 2014; Maciej Mrozowski <reave...@gentoo.org> metadata.xml,
   openscenegraph-3.0.1-r1.ebuild:



1.10                 dev-games/openscenegraph/metadata.xml

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-games/openscenegraph/metadata.xml?rev=1.10&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-games/openscenegraph/metadata.xml?rev=1.10&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-games/openscenegraph/metadata.xml?r1=1.9&r2=1.10

Index: metadata.xml
===================================================================
RCS file: /var/cvsroot/gentoo-x86/dev-games/openscenegraph/metadata.xml,v
retrieving revision 1.9
retrieving revision 1.10
diff -u -r1.9 -r1.10
--- metadata.xml        20 Aug 2014 23:47:19 -0000      1.9
+++ metadata.xml        10 Oct 2014 20:17:05 -0000      1.10
@@ -10,6 +10,7 @@
 The OpenSceneGraph is an open source high performance 3D graphics toolkit, 
used by application developers in fields such as visual simulation, games, 
virtual reality, scientific visualization and modelling. Written entirely in 
Standard C++ and OpenGL it runs on all Windows platforms, OSX, GNU/Linux, IRIX, 
Solaris, HP-Ux, AIX and FreeBSD operating systems. The OpenSceneGraph is now 
well established as the world leading scene graph technology, used widely in 
the vis-sim, space, scientific, oil-gas, games and virtual reality industries.
 </longdescription>
   <use>
+    <flag name="asio">Enable support for <pkg>dev-cpp/asio</pkg> library</flag>
     <flag name="fox">Build examples using <pkg>x11-libs/fox</pkg> 
library</flag>
     <flag name="gdal">Enable support for <pkg>sci-libs/gdal</pkg> 
library</flag>
     <flag name="openinventor">Build OpenInventor plugin</flag>



1.1                  dev-games/openscenegraph/openscenegraph-3.2.1.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-games/openscenegraph/openscenegraph-3.2.1.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-games/openscenegraph/openscenegraph-3.2.1.ebuild?rev=1.1&content-type=text/plain

Index: openscenegraph-3.2.1.ebuild
===================================================================
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: 
/var/cvsroot/gentoo-x86/dev-games/openscenegraph/openscenegraph-3.2.1.ebuild,v 
1.1 2014/10/10 20:17:05 hasufell Exp $

EAPI=5

inherit eutils cmake-utils flag-o-matic wxwidgets

MY_PN="OpenSceneGraph"
MY_P=${MY_PN}-${PV}

DESCRIPTION="Open source high performance 3D graphics toolkit"
HOMEPAGE="http://www.openscenegraph.org/projects/osg/";
SRC_URI="http://www.openscenegraph.org/downloads/developer_releases/${MY_P}.zip";

LICENSE="wxWinLL-3 LGPL-2.1"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
IUSE="asio curl debug doc examples ffmpeg fltk fox gdal gif glut gtk jpeg jpeg2k
openexr openinventor osgapps pdf png qt4 sdl svg tiff truetype vnc wxwidgets
xine xrandr zlib"

# TODO: COLLADA, FBX, GTA, ITK, OpenVRML, Performer, DCMTK
RDEPEND="
        x11-libs/libSM
        x11-libs/libXext
        virtual/glu
        virtual/opengl
        asio? ( dev-cpp/asio )
        curl? ( net-misc/curl )
        examples? (
                fltk? ( x11-libs/fltk:1[opengl] )
                fox? ( x11-libs/fox:1.6[opengl] )
                glut? ( media-libs/freeglut )
                gtk? ( x11-libs/gtkglext )
                qt4? (
                        dev-qt/qtcore:4
                        dev-qt/qtgui:4
                        dev-qt/qtopengl:4
                )
                sdl? ( media-libs/libsdl )
                wxwidgets? ( x11-libs/wxGTK[opengl,X] )
        )
        ffmpeg? ( virtual/ffmpeg )
        gdal? ( sci-libs/gdal )
        gif? ( media-libs/giflib )
        jpeg? ( virtual/jpeg )
        jpeg2k? ( media-libs/jasper )
        openexr? (
                media-libs/ilmbase
                media-libs/openexr
        )
        openinventor? ( media-libs/coin )
        pdf? ( app-text/poppler[cairo] )
        png? ( media-libs/libpng:0 )
        svg? (
                gnome-base/librsvg
                x11-libs/cairo
        )
        tiff? ( media-libs/tiff:0 )
        truetype? ( media-libs/freetype:2 )
        vnc? ( net-libs/libvncserver )
        xine? ( media-libs/xine-lib )
        xrandr? ( x11-libs/libXrandr )
        zlib? ( sys-libs/zlib )
"
DEPEND="${RDEPEND}
        app-arch/unzip
        virtual/pkgconfig
        x11-proto/xextproto
        doc? ( app-doc/doxygen )
        xrandr? ( x11-proto/randrproto )
"

S=${WORKDIR}/${MY_P}

DOCS=(AUTHORS.txt ChangeLog NEWS.txt)

PATCHES=(
        "${FILESDIR}"/${PN}-3.2.1-cmake.patch
)

src_configure() {
        if use examples && use wxwidgets; then
                WX_GTK_VER="2.8"
                need-wxwidgets unicode
        fi

        # Needed by FFmpeg
        append-cppflags -D__STDC_CONSTANT_MACROS

        mycmakeargs=(
                -DDYNAMIC_OPENSCENEGRAPH=ON
                -DWITH_ITK=OFF
                -DGENTOO_DOCDIR="/usr/share/doc/${PF}"
                $(cmake-utils_use_with asio)
                $(cmake-utils_use_with curl)
                $(cmake-utils_use_build doc DOCUMENTATION)
                $(cmake-utils_use_build osgapps OSG_APPLICATIONS)
                $(cmake-utils_use_build examples OSG_EXAMPLES)
                $(cmake-utils_use_with ffmpeg FFmpeg)
                $(cmake-utils_use_with fltk)
                $(cmake-utils_use_with fox)
                $(cmake-utils_use_with gdal)
                $(cmake-utils_use_with gif GIFLIB)
                $(cmake-utils_use_with glut)
                $(cmake-utils_use_with gtk GtkGl)
                $(cmake-utils_use_with jpeg)
                $(cmake-utils_use_with jpeg2k Jasper)
                $(cmake-utils_use_with openexr OpenEXR)
                $(cmake-utils_use_with openinventor Inventor)
                $(cmake-utils_use_with pdf Poppler-glib)
                $(cmake-utils_use_with png)
                $(cmake-utils_use_with qt4)
                $(cmake-utils_use_with sdl)
                $(cmake-utils_use_with svg rsvg)
                $(cmake-utils_use_with tiff)
                $(cmake-utils_use_with truetype Freetype)
                $(cmake-utils_use_with vnc LibVNCServer)
                $(cmake-utils_use_with wxwidgets wxWidgets)
                $(cmake-utils_use_with xine)
                $(cmake-utils_use xrandr OSGVIEWER_USE_XRANDR)
                $(cmake-utils_use_with zlib)
        )
        cmake-utils_src_configure
}

src_compile() {
        cmake-utils_src_compile
        use doc && cmake-utils_src_compile doc_openscenegraph doc_openthreads
}




Reply via email to