jer         15/01/13 07:31:30

  Modified:             ChangeLog
  Added:                geoip-1.6.4.ebuild
  Log:
  Version bump.
  
  (Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key 
A792A613)

Revision  Changes    Path
1.243                dev-libs/geoip/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-libs/geoip/ChangeLog?rev=1.243&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-libs/geoip/ChangeLog?rev=1.243&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-libs/geoip/ChangeLog?r1=1.242&r2=1.243

Index: ChangeLog
===================================================================
RCS file: /var/cvsroot/gentoo-x86/dev-libs/geoip/ChangeLog,v
retrieving revision 1.242
retrieving revision 1.243
diff -u -r1.242 -r1.243
--- ChangeLog   2 Jan 2015 12:42:32 -0000       1.242
+++ ChangeLog   13 Jan 2015 07:31:30 -0000      1.243
@@ -1,6 +1,11 @@
 # ChangeLog for dev-libs/geoip
 # Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/geoip/ChangeLog,v 1.242 2015/01/02 
12:42:32 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/geoip/ChangeLog,v 1.243 2015/01/13 
07:31:30 jer Exp $
+
+*geoip-1.6.4 (13 Jan 2015)
+
+  13 Jan 2015; Jeroen Roovers <j...@gentoo.org> +geoip-1.6.4.ebuild:
+  Version bump.
 
   02 Jan 2015; Agostino Sarubbo <a...@gentoo.org> geoip-1.6.3.ebuild:
   Stable for sparc, wrt bug #533668



1.1                  dev-libs/geoip/geoip-1.6.4.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-libs/geoip/geoip-1.6.4.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-libs/geoip/geoip-1.6.4.ebuild?rev=1.1&content-type=text/plain

Index: geoip-1.6.4.ebuild
===================================================================
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/dev-libs/geoip/geoip-1.6.4.ebuild,v 1.1 
2015/01/13 07:31:30 jer Exp $

EAPI=5
inherit autotools eutils

DESCRIPTION="easily lookup countries by IP addresses, even when Reverse DNS 
entries don't exist"
HOMEPAGE="https://github.com/maxmind/geoip-api-c";
SRC_URI="
        https://github.com/maxmind/${PN}-api-c/archive/v${PV}.tar.gz -> 
${P}.tar.gz
"

# GPL-2 for md5.c - part of libGeoIPUpdate, MaxMind for GeoLite Country db
LICENSE="LGPL-2.1 GPL-2 MaxMind2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 
~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~ia64-linux 
~x86-linux ~x86-macos"
IUSE="static-libs"
RESTRICT="test"

DEPEND="net-misc/wget"
RDEPEND="${DEPEND}"

S="${WORKDIR}/${PN}-api-c-${PV}"

src_prepare() {
        eautoreconf
}

src_configure() {
        econf $(use_enable static-libs static)
        sed -e "s|@PREFIX@|${ROOT}|g" "${FILESDIR}"/geoipupdate-r5.sh > 
geoipupdate.sh || die
}

src_install() {
        default

        dodoc AUTHORS ChangeLog NEWS.md README*

        prune_libtool_files

        keepdir /usr/share/GeoIP

        dosbin geoipupdate.sh
}

pkg_postinst() {
        ewarn "WARNING: Databases are no longer installed by this ebuild."
        elog "Don't forget to run 'geoipupdate.sh -f' (or geoipupdate from"
        elog "net-misc/geoipupdate) to populate ${ROOT}/usr/share/GeoIP/"
        elog "with geo-located IP address databases."
}




Reply via email to