lejonet     14/05/14 20:51:58

  Modified:             hammer-9999.ebuild ChangeLog
  Log:
  Added USE-flags for the perl and python binding
  
  (Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key )

Revision  Changes    Path
1.2                  dev-libs/hammer/hammer-9999.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-libs/hammer/hammer-9999.ebuild?rev=1.2&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-libs/hammer/hammer-9999.ebuild?rev=1.2&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-libs/hammer/hammer-9999.ebuild?r1=1.1&r2=1.2

Index: hammer-9999.ebuild
===================================================================
RCS file: /var/cvsroot/gentoo-x86/dev-libs/hammer/hammer-9999.ebuild,v
retrieving revision 1.1
retrieving revision 1.2
diff -u -r1.1 -r1.2
--- hammer-9999.ebuild  6 Feb 2014 23:37:24 -0000       1.1
+++ hammer-9999.ebuild  14 May 2014 20:51:58 -0000      1.2
@@ -1,10 +1,14 @@
 # Copyright 1999-2014 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/hammer/hammer-9999.ebuild,v 1.1 
2014/02/06 23:37:24 lejonet Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/hammer/hammer-9999.ebuild,v 1.2 
2014/05/14 20:51:58 lejonet Exp $
 
 EAPI="5"
+# Hammer upstreams only supports python2.7
+PYTHON_COMPAT=( python2_7 )
+DISTUTILS_OPTIONAL="true"
+DISTUTILS_SINGLE_IMPL="true"
 
-inherit eutils toolchain-funcs scons-utils git-2
+inherit eutils toolchain-funcs scons-utils git-2 distutils-r1
 
 DESCRIPTION="Hammer is a parsing library, which is bit-oriented and features 
several parsing backends"
 HOMEPAGE="https://github.com/UpstandingHackers/hammer";
@@ -14,22 +18,46 @@
 LICENSE="GPL-2"
 SLOT="0"
 KEYWORDS=""
-IUSE="test"
+IUSE="debug perl php python test"
 
 DEPEND="dev-util/scons
->=dev-libs/glib-2.29"
+>=dev-libs/glib-2.29
+python? ( ${PYTHON_DEPS}
+dev-lang/swig )
+perl? ( >=dev-lang/swig-2.0.8 )
+php? ( dev-lang/swig )"
 RDEPEND=""
-
 src_prepare() {
        tc-export AR CC CXX RANLIB
 }
 
 src_configure() {
        myesconsargs="bindings=cpp"
+
+       if use python; then
+               myesconsargs+=",python"
+       fi
+
+       if use perl; then
+               myesconsargs+=",perl"
+       fi
+
+       if use debug; then
+               # Has to be before bindings parameter
+               # or else it whines about bogus bindings
+               myesconsarg+="--variant=debug ${myesconsarg}"
+       fi
 }
 
 src_compile() {
        escons prefix="/usr"
+
+       # Have to replace /usr/local in the Makefile for
+       # the perl binding because it doesn't inherit/honor the
+       # prefix set at scons commandline
+       if use perl; then
+               sed -i s:/usr/local:/usr: 
"${S}/build/opt/src/bindings/perl/Makefile"
+       fi
 }
 
 src_test() {
@@ -39,4 +67,5 @@
 src_install() {
        escons prefix="${D}/usr" install
        dodoc -r README.md NOTES HACKING TODO examples/
+
 }



1.2                  dev-libs/hammer/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-libs/hammer/ChangeLog?rev=1.2&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-libs/hammer/ChangeLog?rev=1.2&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-libs/hammer/ChangeLog?r1=1.1&r2=1.2

Index: ChangeLog
===================================================================
RCS file: /var/cvsroot/gentoo-x86/dev-libs/hammer/ChangeLog,v
retrieving revision 1.1
retrieving revision 1.2
diff -u -r1.1 -r1.2
--- ChangeLog   6 Feb 2014 23:37:24 -0000       1.1
+++ ChangeLog   14 May 2014 20:51:58 -0000      1.2
@@ -1,10 +1,12 @@
 # ChangeLog for dev-libs/hammer
 # Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/hammer/ChangeLog,v 1.1 2014/02/06 
23:37:24 lejonet Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/hammer/ChangeLog,v 1.2 2014/05/14 
20:51:58 lejonet Exp $
+
+  14 May 2014;  <lejo...@gentoo.org> hammer-9999.ebuild:
+  Added USE-flags for the perl and python binding
 
 *hammer-9999 (06 Feb 2014)
 
   06 Feb 2014; <lejo...@gentoo.org> +hammer-9999.ebuild, +metadata.xml:
   New ebuild for hammer, a parser library with several backends. Ebuild written
   by me.
-




Reply via email to