blueness    15/04/20 22:44:39

  Modified:             ChangeLog
  Added:                xapian-1.3.2.ebuild xapian-1.2.20.ebuild
  Log:
  Version bump.
  
  (Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key 
0xF52D4BBA)

Revision  Changes    Path
1.142                dev-libs/xapian/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-libs/xapian/ChangeLog?rev=1.142&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-libs/xapian/ChangeLog?rev=1.142&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-libs/xapian/ChangeLog?r1=1.141&r2=1.142

Index: ChangeLog
===================================================================
RCS file: /var/cvsroot/gentoo-x86/dev-libs/xapian/ChangeLog,v
retrieving revision 1.141
retrieving revision 1.142
diff -u -r1.141 -r1.142
--- ChangeLog   19 Apr 2015 06:55:54 -0000      1.141
+++ ChangeLog   20 Apr 2015 22:44:39 -0000      1.142
@@ -1,6 +1,13 @@
 # ChangeLog for dev-libs/xapian
 # Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/xapian/ChangeLog,v 1.141 
2015/04/19 06:55:54 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/xapian/ChangeLog,v 1.142 
2015/04/20 22:44:39 blueness Exp $
+
+*xapian-1.3.2 (20 Apr 2015)
+*xapian-1.2.20 (20 Apr 2015)
+
+  20 Apr 2015; Anthony G. Basile <bluen...@gentoo.org> +xapian-1.2.20.ebuild,
+  +xapian-1.3.2.ebuild:
+  Version bump.
 
   19 Apr 2015; Pacho Ramos <pa...@gentoo.org> xapian-1.2.19.ebuild:
   x86 stable wrt bug #531758



1.1                  dev-libs/xapian/xapian-1.3.2.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-libs/xapian/xapian-1.3.2.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-libs/xapian/xapian-1.3.2.ebuild?rev=1.1&content-type=text/plain

Index: xapian-1.3.2.ebuild
===================================================================
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/dev-libs/xapian/xapian-1.3.2.ebuild,v 1.1 
2015/04/20 22:44:39 blueness Exp $

EAPI="5"

MY_P="${PN}-core-${PV}"

DESCRIPTION="Xapian Probabilistic Information Retrieval library"
HOMEPAGE="http://www.xapian.org/";
SRC_URI="http://oligarchy.co.uk/xapian/${PV}/${MY_P}.tar.xz";

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
IUSE="doc static-libs -cpu_flags_x86_sse +cpu_flags_x86_sse2 +brass +chert 
+inmemory"

DEPEND="sys-libs/zlib"
RDEPEND="${DEPEND}"

S="${WORKDIR}/${MY_P}"

src_configure() {
        local myconf=""

        ewarn
        if use cpu_flags_x86_sse2; then
                ewarn "Using sse2"
                myconf="${myconf} --enable-sse=sse2"
        else
                if use cpu_flags_x86_sse; then
                        ewarn "Using sse"
                        myconf="${myconf} --enable-sse=sse"
                else
                        ewarn "Disabling sse and sse2"
                        myconf="${myconf} --disable-sse"
                fi
        fi
        ewarn

        myconf="${myconf} $(use_enable static-libs static)"

        use brass || myconf="${myconf} --disable-backend-brass"
        use chert || myconf="${myconf} --disable-backend-chert"
        use inmemory || myconf="${myconf} --disable-backend-inmemory"

        myconf="${myconf} --enable-backend-remote --program-suffix="

        econf $myconf
}

src_install() {
        emake DESTDIR="${D}" install

        mv "${D}usr/share/doc/xapian-core" "${D}usr/share/doc/${PF}"
        use doc || rm -rf "${D}usr/share/doc/${PF}"

        dodoc AUTHORS HACKING PLATFORMS README NEWS
}

src_test() {
        emake check VALGRIND=
}



1.1                  dev-libs/xapian/xapian-1.2.20.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-libs/xapian/xapian-1.2.20.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-libs/xapian/xapian-1.2.20.ebuild?rev=1.1&content-type=text/plain

Index: xapian-1.2.20.ebuild
===================================================================
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/dev-libs/xapian/xapian-1.2.20.ebuild,v 1.1 
2015/04/20 22:44:39 blueness Exp $

EAPI="5"

MY_P="${PN}-core-${PV}"

DESCRIPTION="Xapian Probabilistic Information Retrieval library"
HOMEPAGE="http://www.xapian.org/";
SRC_URI="http://oligarchy.co.uk/xapian/${PV}/${MY_P}.tar.xz";

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
IUSE="doc static-libs -cpu_flags_x86_sse +cpu_flags_x86_sse2 +brass +chert 
+inmemory"

DEPEND="sys-libs/zlib"
RDEPEND="${DEPEND}"

S="${WORKDIR}/${MY_P}"

src_configure() {
        local myconf=""

        ewarn
        if use cpu_flags_x86_sse2; then
                ewarn "Using sse2"
                myconf="${myconf} --enable-sse=sse2"
        else
                if use cpu_flags_x86_sse; then
                        ewarn "Using sse"
                        myconf="${myconf} --enable-sse=sse"
                else
                        ewarn "Disabling sse and sse2"
                        myconf="${myconf} --disable-sse"
                fi
        fi
        ewarn

        myconf="${myconf} $(use_enable static-libs static)"

        use brass || myconf="${myconf} --disable-backend-brass"
        use chert || myconf="${myconf} --disable-backend-chert"
        use inmemory || myconf="${myconf} --disable-backend-inmemory"

        myconf="${myconf} --enable-backend-flint --enable-backend-remote"

        econf $myconf
}

src_install() {
        emake DESTDIR="${D}" install

        mv "${D}usr/share/doc/xapian-core" "${D}usr/share/doc/${PF}"
        use doc || rm -rf "${D}usr/share/doc/${PF}"

        dodoc AUTHORS HACKING PLATFORMS README NEWS
}

src_test() {
        emake check VALGRIND=
}




Reply via email to