aballier    15/01/26 13:54:58

  Modified:             metadata.xml ChangeLog
  Added:                uutf-0.9.4.ebuild
  Log:
  version bump
  
  Signed-off-by: aball...@gentoo.org
  (Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key 
160F534A)

Revision  Changes    Path
1.2                  dev-ml/uutf/metadata.xml

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-ml/uutf/metadata.xml?rev=1.2&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-ml/uutf/metadata.xml?rev=1.2&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-ml/uutf/metadata.xml?r1=1.1&r2=1.2

Index: metadata.xml
===================================================================
RCS file: /var/cvsroot/gentoo-x86/dev-ml/uutf/metadata.xml,v
retrieving revision 1.1
retrieving revision 1.2
diff -u -r1.1 -r1.2
--- metadata.xml        29 Oct 2014 08:41:19 -0000      1.1
+++ metadata.xml        26 Jan 2015 13:54:58 -0000      1.2
@@ -2,4 +2,7 @@
 <!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd";>
 <pkgmetadata>
 <herd>ml</herd>
+<use>
+<flag name="utftrip">Builds and install the utftrip executable: Among other 
things, reads unicode on stdin and rewrites it on stdout.</flag>
+</use>
 </pkgmetadata>



1.2                  dev-ml/uutf/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-ml/uutf/ChangeLog?rev=1.2&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-ml/uutf/ChangeLog?rev=1.2&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-ml/uutf/ChangeLog?r1=1.1&r2=1.2

Index: ChangeLog
===================================================================
RCS file: /var/cvsroot/gentoo-x86/dev-ml/uutf/ChangeLog,v
retrieving revision 1.1
retrieving revision 1.2
diff -u -r1.1 -r1.2
--- ChangeLog   29 Oct 2014 08:41:19 -0000      1.1
+++ ChangeLog   26 Jan 2015 13:54:58 -0000      1.2
@@ -1,6 +1,12 @@
 # ChangeLog for dev-ml/uutf
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/uutf/ChangeLog,v 1.1 2014/10/29 
08:41:19 aballier Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/uutf/ChangeLog,v 1.2 2015/01/26 
13:54:58 aballier Exp $
+
+*uutf-0.9.4 (26 Jan 2015)
+
+  26 Jan 2015; Alexis Ballier <aball...@gentoo.org> +uutf-0.9.4.ebuild,
+  metadata.xml:
+  version bump
 
 *uutf-0.9.3 (29 Oct 2014)
 



1.1                  dev-ml/uutf/uutf-0.9.4.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-ml/uutf/uutf-0.9.4.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-ml/uutf/uutf-0.9.4.ebuild?rev=1.1&content-type=text/plain

Index: uutf-0.9.4.ebuild
===================================================================
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/dev-ml/uutf/uutf-0.9.4.ebuild,v 1.1 
2015/01/26 13:54:58 aballier Exp $

EAPI="5"

inherit findlib

DESCRIPTION="Non-blocking streaming Unicode codec for OCaml"
HOMEPAGE="http://erratique.ch/software/uutf";
SRC_URI="http://erratique.ch/software/uutf/releases/${P}.tbz";

LICENSE="BSD"
SLOT="0/${PV}"
KEYWORDS="~amd64"
IUSE="utftrip +ocamlopt doc"

RDEPEND=">=dev-lang/ocaml-3.12:=[ocamlopt?]
        utftrip? ( dev-ml/cmdliner:= )"
DEPEND="${RDEPEND}"
# https://github.com/dbuenzli/uutf/issues/3
RESTRICT="test"

src_compile() {
        ocaml pkg/build.ml \
                native=$(usex ocamlopt true false) \
                native-dynlink=$(usex ocamlopt true false) \
                cmdliner=$(usex utftrip true false) \
                || die
}

src_test() {
        if use ocamlopt ; then
                ocamlbuild tests.otarget || die
                cd _build/test || die
                ./test.native || die
        else
                ewarn "Sorry, ${PN} tests require native support (ocamlopt)"
        fi
}

src_install() {
        # Can't use opam-installer here as it is an opam dep...
        findlib_src_preinst
        local nativelibs=""
        use ocamlopt && nativelibs="$(echo _build/src/uutf.cm{x,xa,xs} 
_build/src/uutf.a)"
        ocamlfind install uutf _build/pkg/META _build/src/uutf.mli 
_build/src/uutf.cm{a,i} ${nativelibs} || die
        use utftrip && newbin utftrip.$(usex ocamlopt native byte) utftrip
        dodoc CHANGES.md README.md
        use doc && dohtml -r doc/*
}




Reply via email to