alunduil    14/10/19 20:17:06

  Modified:             ChangeLog
  Added:                clint-0.4.1.ebuild
  Log:
  add version 0.4.1
  
  (Portage version: 2.2.14_rc1/cvs/Linux x86_64, signed Manifest commit with 
key 11A8217C!)

Revision  Changes    Path
1.3                  dev-python/clint/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-python/clint/ChangeLog?rev=1.3&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-python/clint/ChangeLog?rev=1.3&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-python/clint/ChangeLog?r1=1.2&r2=1.3

Index: ChangeLog
===================================================================
RCS file: /var/cvsroot/gentoo-x86/dev-python/clint/ChangeLog,v
retrieving revision 1.2
retrieving revision 1.3
diff -u -r1.2 -r1.3
--- ChangeLog   11 Oct 2014 05:02:55 -0000      1.2
+++ ChangeLog   19 Oct 2014 20:17:06 -0000      1.3
@@ -1,6 +1,11 @@
 # ChangeLog for dev-python/clint
 # Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/clint/ChangeLog,v 1.2 2014/10/11 
05:02:55 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/clint/ChangeLog,v 1.3 2014/10/19 
20:17:06 alunduil Exp $
+
+*clint-0.4.1 (19 Oct 2014)
+
+  19 Oct 2014; Alex Brandt <alund...@gentoo.org> +clint-0.4.1.ebuild:
+  add version 0.4.1
 
 *clint-0.3.1-r1 (11 Oct 2014)
 



1.1                  dev-python/clint/clint-0.4.1.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-python/clint/clint-0.4.1.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-python/clint/clint-0.4.1.ebuild?rev=1.1&content-type=text/plain

Index: clint-0.4.1.ebuild
===================================================================
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/dev-python/clint/clint-0.4.1.ebuild,v 1.1 
2014/10/19 20:17:06 alunduil Exp $

EAPI=5
PYTHON_COMPAT=( python2_7 python3_3 python3_4 )

inherit distutils-r1 vcs-snapshot

DESCRIPTION="Python Command-line Application Tools"
HOMEPAGE="https://github.com/kennethreitz/clint";
SRC_URI="https://github.com/kennethreitz/${PN}/archive/v${PV}.tar.gz -> 
${P}.tar.gz"

LICENSE="ISC"
SLOT="0"
KEYWORDS="~amd64"
IUSE="doc examples test"

DEPEND="
        doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
        test? ( dev-python/pytest[${PYTHON_USEDEP}] )
"
RDEPEND="dev-python/args[${PYTHON_USEDEP}]"

python_compile_all() {
        use doc && emake -C docs html
}

python_test() {
        py.test || die "Tests failed under ${EPYTHON}"
}

python_install_all() {
        use doc && local HTML_DOCS=( docs/_build/html/. )
        use examples && local EXAMPLES=( examples/. )

        distutils-r1_python_install_all
}




Reply via email to