patrick     14/05/26 07:43:32

  Modified:             ChangeLog
  Added:                datashape-0.2.0.ebuild
  Log:
  Bump
  
  (Portage version: 2.2.10/cvs/Linux x86_64, unsigned Manifest commit)

Revision  Changes    Path
1.3                  dev-python/datashape/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-python/datashape/ChangeLog?rev=1.3&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-python/datashape/ChangeLog?rev=1.3&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-python/datashape/ChangeLog?r1=1.2&r2=1.3

Index: ChangeLog
===================================================================
RCS file: /var/cvsroot/gentoo-x86/dev-python/datashape/ChangeLog,v
retrieving revision 1.2
retrieving revision 1.3
diff -u -r1.2 -r1.3
--- ChangeLog   23 Feb 2014 00:02:51 -0000      1.2
+++ ChangeLog   26 May 2014 07:43:32 -0000      1.3
@@ -1,6 +1,11 @@
 # ChangeLog for dev-python/datashape
 # Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/datashape/ChangeLog,v 1.2 
2014/02/23 00:02:51 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/datashape/ChangeLog,v 1.3 
2014/05/26 07:43:32 patrick Exp $
+
+*datashape-0.2.0 (26 May 2014)
+
+  26 May 2014; Patrick Lauer <patr...@gentoo.org> +datashape-0.2.0.ebuild:
+  Bump
 
 *datashape-0.1.1 (23 Feb 2014)
 



1.1                  dev-python/datashape/datashape-0.2.0.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-python/datashape/datashape-0.2.0.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-python/datashape/datashape-0.2.0.ebuild?rev=1.1&content-type=text/plain

Index: datashape-0.2.0.ebuild
===================================================================
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: 
/var/cvsroot/gentoo-x86/dev-python/datashape/datashape-0.2.0.ebuild,v 1.1 
2014/05/26 07:43:32 patrick Exp $

EAPI=5

PYTHON_COMPAT=( python{2_7,3_2,3_3} )

inherit distutils-r1

DESCRIPTION="Language defining a data description protocol"
HOMEPAGE="https://github.com/ContinuumIO/datashape";
SRC_URI="https://github.com/ContinuumIO/${PN}/archive/${PV}.tar.gz -> 
${P}.tar.gz"

LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
IUSE="doc test"

RDEPEND="
        dev-python/ply[${PYTHON_USEDEP}]
        dev-python/numpy[${PYTHON_USEDEP}]
        dev-python/multipledispatch[${PYTHON_USEDEP}]
"
DEPEND="${RDEPEND}
        doc? ( dev-python/sphinx )
        test? ( dev-python/nose[${PYTHON_USEDEP}] )
"

python_compile_all() {
        use doc && emake -C docs html
}

python_test() {
        cd "${BUILD_DIR}"/lib* || die
        nosetests -v || die
}

python_install_all() {
        use doc && local HTML_DOCS=( docs/build/html/. )
        distutils-r1_python_install_all
}




Reply via email to