patrick     15/02/06 03:41:28

  Modified:             ChangeLog
  Added:                django-1.7.4.ebuild
  Log:
  Bump #538692
  
  (Portage version: 2.2.15/cvs/Linux x86_64, unsigned Manifest commit)

Revision  Changes    Path
1.150                dev-python/django/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-python/django/ChangeLog?rev=1.150&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-python/django/ChangeLog?rev=1.150&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-python/django/ChangeLog?r1=1.149&r2=1.150

Index: ChangeLog
===================================================================
RCS file: /var/cvsroot/gentoo-x86/dev-python/django/ChangeLog,v
retrieving revision 1.149
retrieving revision 1.150
diff -u -r1.149 -r1.150
--- ChangeLog   22 Dec 2014 03:44:07 -0000      1.149
+++ ChangeLog   6 Feb 2015 03:41:28 -0000       1.150
@@ -1,6 +1,11 @@
 # ChangeLog for dev-python/django
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/django/ChangeLog,v 1.149 
2014/12/22 03:44:07 idella4 Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/django/ChangeLog,v 1.150 
2015/02/06 03:41:28 patrick Exp $
+
+*django-1.7.4 (06 Feb 2015)
+
+  06 Feb 2015; Patrick Lauer <patr...@gentoo.org> +django-1.7.4.ebuild:
+  Bump #538692
 
   22 Dec 2014; Ian Delaney <idel...@gentoo.org> django-1.7.ebuild:
   postgres IUSE flag dropped and treated in the same as the dropped flag 
'mysql'



1.1                  dev-python/django/django-1.7.4.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-python/django/django-1.7.4.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-python/django/django-1.7.4.ebuild?rev=1.1&content-type=text/plain

Index: django-1.7.4.ebuild
===================================================================
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/dev-python/django/django-1.7.4.ebuild,v 1.1 
2015/02/06 03:41:28 patrick Exp $

EAPI=5
PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
PYTHON_REQ_USE='sqlite?'
WEBAPP_NO_AUTO_INSTALL="yes"

inherit bash-completion-r1 distutils-r1 readme.gentoo versionator webapp

MY_P="Django-${PV}"

DESCRIPTION="High-level Python web framework"
HOMEPAGE="http://www.djangoproject.com/ http://pypi.python.org/pypi/Django";
SRC_URI="https://www.djangoproject.com/m/releases/$(get_version_component_range 
1-2)/${MY_P}.tar.gz"

LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux 
~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
IUSE="doc sqlite test"

RDEPEND="virtual/python-imaging[${PYTHON_USEDEP}]
        dev-python/setuptools[${PYTHON_USEDEP}]"
DEPEND="${RDEPEND}
        doc? ( >=dev-python/sphinx-1.0.7[${PYTHON_USEDEP}] )
        test? ( ${PYTHON_DEPS//sqlite?/sqlite} )"

S="${WORKDIR}/${MY_P}"

WEBAPP_MANUAL_SLOT="yes"

pkg_setup() {
        webapp_pkg_setup
}

python_prepare_all() {
        # 
https://github.com/django/django/commit/d0c6016367c11d4d4cc42ace340f951f5b75738e
        # Courtesy of Arfrever
        sed -e "106a\\        with change_cwd(\"..\"):" \
                -e "107,117s/^/    /" \
                -i tests/test_runner/test_discover_runner.py

        # Prevent d'loading in the doc build
        sed -e '/^    "sphinx.ext.intersphinx",/d' -i docs/conf.py || die

        distutils-r1_python_prepare_all
}

python_compile_all() {
        if use doc; then
                emake -C docs html
        fi
}

python_test() {
        # Tests have non-standard assumptions about PYTHONPATH,
        # and don't work with ${BUILD_DIR}/lib.
        PYTHONPATH=. "${PYTHON}" tests/runtests.py --settings=test_sqlite -v1 \
                || die "Tests fail with ${EPYTHON}"
}

src_test() {
        # Port conflict in django.test.testcases.LiveServerTestCase.
        # Several other races with temp files.
        DISTUTILS_NO_PARALLEL_BUILD=1 distutils-r1_src_test
}

src_install() {
        distutils-r1_src_install
        webapp_src_install

        DOC_CONTENTS="Optional support for mysql as a backend to sql is 
available in the form of
        dev-python/mysql-python for support of python 2.7 support, or 
dev-python/mysql-connector-python
        for support of python 2.7, 3.3 & 3.4. Support of postgresql as a 
backend can be enabled via
        emerging dev-python/psycopg:2 in cpythons 2.7 3.3 & 3.4 but not in pypy.
        Just emerge the package to suit the needs."

        readme.gentoo_create_doc
}

python_install_all() {
        newbashcomp extras/django_bash_completion ${PN}

        if use doc; then
                rm -fr docs/_build/html/_sources
                local HTML_DOCS=( docs/_build/html/. )
        fi

        insinto "${MY_HTDOCSDIR#${EPREFIX}}"
        doins -r django/contrib/admin/static/admin/.
        distutils-r1_python_install_all
}

pkg_postinst() {
        elog "A copy of the admin media is available to webapp-config for 
installation in a"
        elog "webroot, as well as the traditional location in python's 
site-packages dir"
        elog "for easy development."
        webapp_pkg_postinst
}




Reply via email to