hasufell    14/05/10 22:40:51

  Modified:             ChangeLog
  Added:                jedi-0.8.0.ebuild
  Log:
  version bump
  
  (Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 
BDEED020)

Revision  Changes    Path
1.7                  dev-python/jedi/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-python/jedi/ChangeLog?rev=1.7&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-python/jedi/ChangeLog?rev=1.7&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-python/jedi/ChangeLog?r1=1.6&r2=1.7

Index: ChangeLog
===================================================================
RCS file: /var/cvsroot/gentoo-x86/dev-python/jedi/ChangeLog,v
retrieving revision 1.6
retrieving revision 1.7
diff -u -r1.6 -r1.7
--- ChangeLog   24 Nov 2013 13:48:46 -0000      1.6
+++ ChangeLog   10 May 2014 22:40:51 -0000      1.7
@@ -1,6 +1,11 @@
 # ChangeLog for dev-python/jedi
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/jedi/ChangeLog,v 1.6 2013/11/24 
13:48:46 ago Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/jedi/ChangeLog,v 1.7 2014/05/10 
22:40:51 hasufell Exp $
+
+*jedi-0.8.0 (10 May 2014)
+
+  10 May 2014; Julian Ospald <hasuf...@gentoo.org> +jedi-0.8.0.ebuild:
+  version bump
 
   24 Nov 2013; Agostino Sarubbo <a...@gentoo.org> jedi-0.7.0.ebuild:
   Stable for x86, wrt bug #491542



1.1                  dev-python/jedi/jedi-0.8.0.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-python/jedi/jedi-0.8.0.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-python/jedi/jedi-0.8.0.ebuild?rev=1.1&content-type=text/plain

Index: jedi-0.8.0.ebuild
===================================================================
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/dev-python/jedi/jedi-0.8.0.ebuild,v 1.1 
2014/05/10 22:40:51 hasufell Exp $

EAPI=5

PYTHON_COMPAT=( python2_7 python3_2 python3_3 )
inherit distutils-r1

MY_PV="${PV/_beta/b}-final0"

DESCRIPTION="Awesome autocompletion library for python"
HOMEPAGE="https://github.com/davidhalter/jedi";
SRC_URI="mirror://pypi/j/jedi/jedi-${MY_PV}.tar.gz"

LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="doc test"

DEPEND="app-arch/xz-utils
        dev-python/setuptools[${PYTHON_USEDEP}]
        doc? ( dev-python/sphinx )
        test? (
                dev-python/pytest[${PYTHON_USEDEP}]
                dev-python/tox[${PYTHON_USEDEP}]
        )"

S=${WORKDIR}/${PN}-${MY_PV}

python_test() {
        PYTHONPATH="${PYTHONPATH%:}${PYTHONPATH+:}${S}/test" py.test test || 
die "Tests failed under ${EPYTHON}"
}

src_compile() {
        if use doc ; then
                emake -C docs html
        fi
        distutils-r1_src_compile
}

python_install_all() {
        use doc && dohtml -r "${S}"/docs/_build/html/*
        distutils-r1_python_install_all
}




Reply via email to