patrick     14/08/28 09:34:30

  Modified:             ChangeLog
  Added:                peewee-2.3.1.ebuild
  Log:
  Bump
  
  (Portage version: 2.2.12/cvs/Linux x86_64, unsigned Manifest commit)

Revision  Changes    Path
1.14                 dev-python/peewee/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-python/peewee/ChangeLog?rev=1.14&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-python/peewee/ChangeLog?rev=1.14&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-python/peewee/ChangeLog?r1=1.13&r2=1.14

Index: ChangeLog
===================================================================
RCS file: /var/cvsroot/gentoo-x86/dev-python/peewee/ChangeLog,v
retrieving revision 1.13
retrieving revision 1.14
diff -u -r1.13 -r1.14
--- ChangeLog   20 Aug 2014 06:20:21 -0000      1.13
+++ ChangeLog   28 Aug 2014 09:34:30 -0000      1.14
@@ -1,6 +1,11 @@
 # ChangeLog for dev-python/peewee
 # Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/peewee/ChangeLog,v 1.13 
2014/08/20 06:20:21 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/peewee/ChangeLog,v 1.14 
2014/08/28 09:34:30 patrick Exp $
+
+*peewee-2.3.1 (28 Aug 2014)
+
+  28 Aug 2014; Patrick Lauer <patr...@gentoo.org> +peewee-2.3.1.ebuild:
+  Bump
 
 *peewee-2.3.0 (20 Aug 2014)
 



1.1                  dev-python/peewee/peewee-2.3.1.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-python/peewee/peewee-2.3.1.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-python/peewee/peewee-2.3.1.ebuild?rev=1.1&content-type=text/plain

Index: peewee-2.3.1.ebuild
===================================================================
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/dev-python/peewee/peewee-2.3.1.ebuild,v 1.1 
2014/08/28 09:34:30 patrick Exp $

EAPI=5
PYTHON_COMPAT=( python{2_7,3_3,3_4} )
PYTHON_REQ_USE="sqlite(+)"

inherit distutils-r1

DESCRIPTION="Small python ORM"
HOMEPAGE="https://github.com/coleifer/peewee/";
SRC_URI="https://github.com/coleifer/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="doc examples test"

RDEPEND=""
DEPEND="${RDEPEND}
        dev-python/setuptools[${PYTHON_USEDEP}]
        test? (
                dev-python/apsw[${PYTHON_USEDEP}]
                dev-python/psycopg[${PYTHON_USEDEP}]
                dev-python/django[${PYTHON_USEDEP}]
        )"
# Req'd to ensure a unique tmp.db for each python impl running the testsuite.
DISTUTILS_IN_SOURCE_BUILD=1

python_compile_all() {
        use doc && emake -C docs html
}

python_test() {
        "${PYTHON}" ./runtests.py || die "tests failed under ${EPYTHON}"
}

python_install_all() {
        use doc && local HTML_DOCS=( docs/_build/html/. )
        use examples && local EXAMPLES=( example/. )
        distutils-r1_python_install_all
}




Reply via email to