graaff      15/01/27 06:42:12

  Modified:             ChangeLog
  Added:                atomic-1.1.99.ebuild
  Log:
  Version bump. Add ruby22. Avoid dependency on rake-compiler completely.
  
  (Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 
0x8883FA56A308A8D7!)

Revision  Changes    Path
1.17                 dev-ruby/atomic/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-ruby/atomic/ChangeLog?rev=1.17&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-ruby/atomic/ChangeLog?rev=1.17&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-ruby/atomic/ChangeLog?r1=1.16&r2=1.17

Index: ChangeLog
===================================================================
RCS file: /var/cvsroot/gentoo-x86/dev-ruby/atomic/ChangeLog,v
retrieving revision 1.16
retrieving revision 1.17
diff -u -r1.16 -r1.17
--- ChangeLog   12 Aug 2014 21:27:22 -0000      1.16
+++ ChangeLog   27 Jan 2015 06:42:12 -0000      1.17
@@ -1,6 +1,11 @@
 # ChangeLog for dev-ruby/atomic
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/atomic/ChangeLog,v 1.16 2014/08/12 
21:27:22 blueness Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/atomic/ChangeLog,v 1.17 2015/01/27 
06:42:12 graaff Exp $
+
+*atomic-1.1.99 (27 Jan 2015)
+
+  27 Jan 2015; Hans de Graaff <gra...@gentoo.org> +atomic-1.1.99.ebuild:
+  Version bump. Add ruby22. Avoid dependency on rake-compiler completely.
 
   12 Aug 2014; Anthony G. Basile <bluen...@gentoo.org> atomic-1.1.16.ebuild:
   Keyword ~ppc and ~ppc64, bug #519170



1.1                  dev-ruby/atomic/atomic-1.1.99.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-ruby/atomic/atomic-1.1.99.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-ruby/atomic/atomic-1.1.99.ebuild?rev=1.1&content-type=text/plain

Index: atomic-1.1.99.ebuild
===================================================================
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/dev-ruby/atomic/atomic-1.1.99.ebuild,v 1.1 
2015/01/27 06:42:12 graaff Exp $

EAPI=5

USE_RUBY="ruby19 ruby20 ruby21 ruby22"

RUBY_FAKEGEM_TASK_DOC=""

inherit multilib ruby-fakegem

DESCRIPTION="An atomic reference implementation for JRuby, Rubinius, and MRI"
HOMEPAGE="https://github.com/headius/ruby-atomic";

LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86"
IUSE=""

all_ruby_prepare() {
        # Avoid compilation dependencies since we compile directly.
        sed -i -e '/:test => :compile/ s:^:#:' \
                -e '/extensiontask/,/end/ s:^:#:' Rakefile || die
}

each_ruby_configure() {
        ${RUBY} -Cext extconf.rb || die
}

each_ruby_compile() {
        emake V=1 -Cext
        cp ext/atomic_reference$(get_modname) lib/ || die
}




Reply via email to