graaff      15/03/29 07:14:31

  Modified:             ChangeLog fakeweb-1.3.0-r1.ebuild
  Added:                fakeweb-1.3.0-r2.ebuild
  Log:
  Create stable candidate.
  
  (Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 
0x8883FA56A308A8D7!)

Revision  Changes    Path
1.23                 dev-ruby/fakeweb/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-ruby/fakeweb/ChangeLog?rev=1.23&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-ruby/fakeweb/ChangeLog?rev=1.23&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-ruby/fakeweb/ChangeLog?r1=1.22&r2=1.23

Index: ChangeLog
===================================================================
RCS file: /var/cvsroot/gentoo-x86/dev-ruby/fakeweb/ChangeLog,v
retrieving revision 1.22
retrieving revision 1.23
diff -u -r1.22 -r1.23
--- ChangeLog   25 Nov 2014 11:32:48 -0000      1.22
+++ ChangeLog   29 Mar 2015 07:14:31 -0000      1.23
@@ -1,6 +1,12 @@
 # ChangeLog for dev-ruby/fakeweb
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/fakeweb/ChangeLog,v 1.22 
2014/11/25 11:32:48 mrueg Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/fakeweb/ChangeLog,v 1.23 
2015/03/29 07:14:31 graaff Exp $
+
+*fakeweb-1.3.0-r2 (29 Mar 2015)
+
+  29 Mar 2015; Hans de Graaff <gra...@gentoo.org> fakeweb-1.3.0-r1.ebuild,
+  +fakeweb-1.3.0-r2.ebuild:
+  Create stable candidate.
 
   25 Nov 2014; Manuel RĂ¼ger <mr...@gentoo.org> fakeweb-1.3.0-r1.ebuild:
   Drop jruby target.



1.5                  dev-ruby/fakeweb/fakeweb-1.3.0-r1.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-ruby/fakeweb/fakeweb-1.3.0-r1.ebuild?rev=1.5&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-ruby/fakeweb/fakeweb-1.3.0-r1.ebuild?rev=1.5&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-ruby/fakeweb/fakeweb-1.3.0-r1.ebuild?r1=1.4&r2=1.5

Index: fakeweb-1.3.0-r1.ebuild
===================================================================
RCS file: /var/cvsroot/gentoo-x86/dev-ruby/fakeweb/fakeweb-1.3.0-r1.ebuild,v
retrieving revision 1.4
retrieving revision 1.5
diff -u -r1.4 -r1.5
--- fakeweb-1.3.0-r1.ebuild     25 Nov 2014 11:32:48 -0000      1.4
+++ fakeweb-1.3.0-r1.ebuild     29 Mar 2015 07:14:31 -0000      1.5
@@ -1,10 +1,10 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/fakeweb/fakeweb-1.3.0-r1.ebuild,v 
1.4 2014/11/25 11:32:48 mrueg Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/fakeweb/fakeweb-1.3.0-r1.ebuild,v 
1.5 2015/03/29 07:14:31 graaff Exp $
 
 EAPI=5
 
-USE_RUBY="ruby19 ruby20 ruby21"
+USE_RUBY="ruby19 ruby20"
 
 RUBY_FAKEGEM_DOCDIR="html"
 RUBY_FAKEGEM_EXTRADOC="CHANGELOG README.rdoc"



1.1                  dev-ruby/fakeweb/fakeweb-1.3.0-r2.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-ruby/fakeweb/fakeweb-1.3.0-r2.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-ruby/fakeweb/fakeweb-1.3.0-r2.ebuild?rev=1.1&content-type=text/plain

Index: fakeweb-1.3.0-r2.ebuild
===================================================================
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/dev-ruby/fakeweb/fakeweb-1.3.0-r2.ebuild,v 
1.1 2015/03/29 07:14:31 graaff Exp $

EAPI=5

USE_RUBY="ruby19 ruby20 ruby21"

RUBY_FAKEGEM_DOCDIR="html"
RUBY_FAKEGEM_EXTRADOC="CHANGELOG README.rdoc"

inherit ruby-fakegem

DESCRIPTION="Helper for faking web requests in Ruby"
HOMEPAGE="http://github.com/chrisk/fakeweb";

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
IUSE=""

ruby_add_bdepend "
        test? (
                dev-ruby/mocha:0.13
                dev-ruby/test-unit
                dev-ruby/samuel
                dev-ruby/right_http_connection
        )"

all_ruby_prepare() {
        # The package bundles samuel and right_http_connection, remove
        # them and use the packages instead.
        rm -r test/vendor || die "failed to remove bundled gems"

        # We don't package sdoc and we don't have the direct template.
        sed -i -e 's/sdoc/rdoc/' -e '/template/d' Rakefile || die

        # Require an old enough version of mocha
        sed -i -e '1igem "mocha", "~> 0.13.0"' test/test_helper.rb || die

        # Use the test-unit gem to make jruby compatible with newer mocha.
        sed -i -e '1igem "test-unit"' test/test_helper.rb || die
}

each_ruby_prepare() {
        case ${RUBY} in
                *ruby2[01])
                        # Tests fail on mocking of TCPSocket, but fakeweb itself
                        # actually works as evidenced by the thor test suite.
                        rm test/test_fake_web_open_uri.rb 
test/test_allow_net_connect.rb test/test_fake_web.rb || die
                        ;;
        esac
}




Reply via email to