graaff      15/06/27 05:45:24

  Modified:             ChangeLog
  Added:                ffi-1.9.9.ebuild
  Log:
  Version bump.
  
  (Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key 
0x8883FA56A308A8D7!)

Revision  Changes    Path
1.103                dev-ruby/ffi/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-ruby/ffi/ChangeLog?rev=1.103&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-ruby/ffi/ChangeLog?rev=1.103&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-ruby/ffi/ChangeLog?r1=1.102&r2=1.103

Index: ChangeLog
===================================================================
RCS file: /var/cvsroot/gentoo-x86/dev-ruby/ffi/ChangeLog,v
retrieving revision 1.102
retrieving revision 1.103
diff -u -r1.102 -r1.103
--- ChangeLog   7 Jun 2015 17:48:49 -0000       1.102
+++ ChangeLog   27 Jun 2015 05:45:24 -0000      1.103
@@ -1,6 +1,11 @@
 # ChangeLog for dev-ruby/ffi
 # Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ffi/ChangeLog,v 1.102 2015/06/07 
17:48:49 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ffi/ChangeLog,v 1.103 2015/06/27 
05:45:24 graaff Exp $
+
+*ffi-1.9.9 (27 Jun 2015)
+
+  27 Jun 2015; Hans de Graaff <gra...@gentoo.org> +ffi-1.9.9.ebuild:
+  Version bump.
 
   07 Jun 2015; Justin Lecher <j...@gentoo.org> metadata.xml:
   Add github to remote-id in metadata.xml



1.1                  dev-ruby/ffi/ffi-1.9.9.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-ruby/ffi/ffi-1.9.9.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-ruby/ffi/ffi-1.9.9.ebuild?rev=1.1&content-type=text/plain

Index: ffi-1.9.9.ebuild
===================================================================
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ffi/ffi-1.9.9.ebuild,v 1.1 
2015/06/27 05:45:24 graaff Exp $

EAPI=5

USE_RUBY="ruby19 ruby20 ruby21 ruby22"

RUBY_FAKEGEM_RECIPE_TEST="rspec3"

RUBY_FAKEGEM_RECIPE_DOC="yard"
RUBY_FAKEGEM_DOCDIR="doc"
RUBY_FAKEGEM_EXTRADOC="README.md"

inherit ruby-fakegem

DESCRIPTION="Ruby extension for programmatically loading dynamic libraries"
HOMEPAGE="https://wiki.github.com/ffi/ffi";

SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> 
${PN}-git-${PV}.tgz"

IUSE=""
LICENSE="BSD"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux 
~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"

RDEPEND+=" virtual/libffi"
DEPEND+=" virtual/libffi"

ruby_add_bdepend "doc? ( dev-ruby/yard )"

all_ruby_prepare() {
        sed -i -e '/tasks/ s:^:#:' \
                -e '/Gem::Tasks/,/end/ s:^:#:' Rakefile || die

        # Fix Makefile for tests
        sed -i -e '/CCACHE :=/ s:^:#:' \
                -e 's/-O2//' \
                -e 's/^CFLAGS =/CFLAGS +=/' libtest/GNUmakefile || die

        # Remove bundled version of libffi.
        rm -rf ext/ffi_c/libffi || die
}

each_ruby_configure() {
        ${RUBY} -Cext/ffi_c extconf.rb || die
}

each_ruby_compile() {
        emake -Cext/ffi_c V=1
        cp ext/ffi_c/ffi_c.so lib/ || die

        ${RUBY} -S rake -f gen/Rakefile || die "types.conf generation failed"
}

each_ruby_test() {
        CC=$(tc-getCC) CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" ${RUBY} -S rspec 
spec || die
}

all_ruby_install() {
        all_fakegem_install

        docinto examples
        dodoc samples/*
}




Reply via email to