graaff      15/07/24 06:22:52

  Modified:             ChangeLog
  Added:                gpgme-2.0.9.ebuild
  Log:
  Version bump. Fix gemspec not to include mini-portile. Use correct mocha 
version.
  
  (Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key 
0x8883FA56A308A8D7!)

Revision  Changes    Path
1.6                  dev-ruby/gpgme/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-ruby/gpgme/ChangeLog?rev=1.6&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-ruby/gpgme/ChangeLog?rev=1.6&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-ruby/gpgme/ChangeLog?r1=1.5&r2=1.6

Index: ChangeLog
===================================================================
RCS file: /var/cvsroot/gentoo-x86/dev-ruby/gpgme/ChangeLog,v
retrieving revision 1.5
retrieving revision 1.6
diff -u -r1.5 -r1.6
--- ChangeLog   7 Jun 2015 17:53:35 -0000       1.5
+++ ChangeLog   24 Jul 2015 06:22:52 -0000      1.6
@@ -1,6 +1,12 @@
 # ChangeLog for dev-ruby/gpgme
 # Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/gpgme/ChangeLog,v 1.5 2015/06/07 
17:53:35 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/gpgme/ChangeLog,v 1.6 2015/07/24 
06:22:52 graaff Exp $
+
+*gpgme-2.0.9 (24 Jul 2015)
+
+  24 Jul 2015; Hans de Graaff <gra...@gentoo.org> +gpgme-2.0.9.ebuild:
+  Version bump. Fix gemspec not to include mini-portile. Use correct mocha
+  version.
 
   07 Jun 2015; Justin Lecher <j...@gentoo.org> metadata.xml:
   Add github to remote-id in metadata.xml



1.1                  dev-ruby/gpgme/gpgme-2.0.9.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-ruby/gpgme/gpgme-2.0.9.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-ruby/gpgme/gpgme-2.0.9.ebuild?rev=1.1&content-type=text/plain

Index: gpgme-2.0.9.ebuild
===================================================================
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/dev-ruby/gpgme/gpgme-2.0.9.ebuild,v 1.1 
2015/07/24 06:22:52 graaff Exp $

EAPI=5
USE_RUBY="ruby19 ruby20 ruby21 ruby22"

RUBY_FAKEGEM_RECIPE_DOC="rdoc"
RUBY_FAKEGEM_EXTRADOC="NEWS README.rdoc"

RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"

inherit ruby-ng ruby-fakegem flag-o-matic

DESCRIPTION="Ruby language binding for GnuPG Made Easy"
HOMEPAGE="https://github.com/ueno/ruby-gpgme";
SRC_URI="https://github.com/ueno/ruby-gpgme/archive/${PV}.tar.gz -> 
ruby-${P}.tar.gz"
RUBY_S="ruby-${P}"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""

DEPEND+=">=app-crypt/gpgme-1.1.3"
RDEPEND+=">=app-crypt/gpgme-1.1.3"

ruby_add_bdepend "test? ( dev-ruby/mocha:0.14 )"

all_ruby_prepare() {
        sed -i -e '/\(coverall\|bundler\|ruby-debug\|byebug\)/I s:^:#:' \
                -e '3igem "mocha", "~> 0.14"' \
                test/test_helper.rb || die

        # Remove failing tests for now. This package was added without
        # running any tests :-(
        rm -f test/{ctx,crypto}_test.rb || die

        sed -i -e '/portile/d' ${RUBY_FAKEGEM_GEMSPEC} || die
}

each_ruby_configure() {
        append-flags -fPIC
        export RUBY_GPGME_USE_SYSTEM_LIBRARIES=1
        ${RUBY} -C ext "${S}/ext/gpgme/extconf.rb" || die "extconf.rb failed"
}

each_ruby_compile() {
        emake V=1 -C ext archflag="${LDFLAGS}" || die "emake failed"
        cp -f "${S}/ext/gpgme_n.so" "${S}/lib" || die
}

each_ruby_test() {
        ${RUBY} -Ilib:test:. -e 'Dir["test/*_test.rb"].each{|f| require f}' || 
die
}




Reply via email to