graaff      14/05/14 18:13:59

  Modified:             ChangeLog hpricot-0.8.6-r2.ebuild
  Added:                hpricot-0.8.6-r3.ebuild
  Log:
  Add ruby21 revision to create a stable candidate.
  
  (Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 
0x8883FA56A308A8D7!)

Revision  Changes    Path
1.54                 dev-ruby/hpricot/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-ruby/hpricot/ChangeLog?rev=1.54&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-ruby/hpricot/ChangeLog?rev=1.54&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-ruby/hpricot/ChangeLog?r1=1.53&r2=1.54

Index: ChangeLog
===================================================================
RCS file: /var/cvsroot/gentoo-x86/dev-ruby/hpricot/ChangeLog,v
retrieving revision 1.53
retrieving revision 1.54
diff -u -r1.53 -r1.54
--- ChangeLog   20 Apr 2014 06:34:51 -0000      1.53
+++ ChangeLog   14 May 2014 18:13:59 -0000      1.54
@@ -1,6 +1,12 @@
 # ChangeLog for dev-ruby/hpricot
 # Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/hpricot/ChangeLog,v 1.53 
2014/04/20 06:34:51 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/hpricot/ChangeLog,v 1.54 
2014/05/14 18:13:59 graaff Exp $
+
+*hpricot-0.8.6-r3 (14 May 2014)
+
+  14 May 2014; Hans de Graaff <gra...@gentoo.org> hpricot-0.8.6-r2.ebuild,
+  +hpricot-0.8.6-r3.ebuild:
+  Add ruby21 revision to create a stable candidate.
 
   20 Apr 2014; Hans de Graaff <gra...@gentoo.org> hpricot-0.8.6-r2.ebuild:
   Add ruby21.



1.6                  dev-ruby/hpricot/hpricot-0.8.6-r2.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-ruby/hpricot/hpricot-0.8.6-r2.ebuild?rev=1.6&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-ruby/hpricot/hpricot-0.8.6-r2.ebuild?rev=1.6&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-ruby/hpricot/hpricot-0.8.6-r2.ebuild?r1=1.5&r2=1.6

Index: hpricot-0.8.6-r2.ebuild
===================================================================
RCS file: /var/cvsroot/gentoo-x86/dev-ruby/hpricot/hpricot-0.8.6-r2.ebuild,v
retrieving revision 1.5
retrieving revision 1.6
diff -u -r1.5 -r1.6
--- hpricot-0.8.6-r2.ebuild     20 Apr 2014 06:34:51 -0000      1.5
+++ hpricot-0.8.6-r2.ebuild     14 May 2014 18:13:59 -0000      1.6
@@ -1,10 +1,10 @@
 # Copyright 1999-2014 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/hpricot/hpricot-0.8.6-r2.ebuild,v 
1.5 2014/04/20 06:34:51 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/hpricot/hpricot-0.8.6-r2.ebuild,v 
1.6 2014/05/14 18:13:59 graaff Exp $
 
 EAPI=5
 
-USE_RUBY="ruby19 ruby20 ruby21 jruby"
+USE_RUBY="ruby19 ruby20 jruby"
 
 RUBY_FAKEGEM_DOCDIR="doc"
 RUBY_FAKEGEM_EXTRADOC="CHANGELOG README.md"



1.1                  dev-ruby/hpricot/hpricot-0.8.6-r3.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-ruby/hpricot/hpricot-0.8.6-r3.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-ruby/hpricot/hpricot-0.8.6-r3.ebuild?rev=1.1&content-type=text/plain

Index: hpricot-0.8.6-r3.ebuild
===================================================================
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/dev-ruby/hpricot/hpricot-0.8.6-r3.ebuild,v 
1.1 2014/05/14 18:13:59 graaff Exp $

EAPI=5

USE_RUBY="ruby19 ruby20 ruby21 jruby"

RUBY_FAKEGEM_DOCDIR="doc"
RUBY_FAKEGEM_EXTRADOC="CHANGELOG README.md"

inherit ruby-fakegem eutils

DESCRIPTION="A fast and liberal HTML parser for Ruby."
HOMEPAGE="http://wiki.github.com/hpricot/hpricot";

LICENSE="MIT"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd 
~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
IUSE=""

ruby_add_bdepend "dev-ruby/rake
        dev-ruby/rake-compiler"

# dev-ruby/fast_xs does not cover JRuby so still bundle it here for now
USE_RUBY="${USE_RUBY/jruby/}" \
        ruby_add_rdepend "dev-ruby/fast_xs"

# Probably needs the same jdk as JRuby but I'm not sure how to express
# that just yet.
DEPEND+="
        dev-util/ragel
        ruby_targets_jruby? ( >=virtual/jdk-1.5 )"

all_ruby_prepare() {
        sed -i -e '/[Bb]undler/ s:^:#:' Rakefile || die

        # Fix encoding assumption of environment for Ruby 1.9.
        # https://github.com/hpricot/hpricot/issues/52
        # sed -i -e '1 iEncoding.default_external=Encoding::UTF_8 if 
RUBY_VERSION =~ /1.9/' test/load_files.rb || die
}

each_ruby_prepare() {
        # dev-ruby/fast_xs does not cover JRuby so still bundle it here for now
        [[ ${RUBY} == */jruby ]] && return

        pushd .. &>/dev/null
        epatch "${FILESDIR}"/${P}-fast_xs.patch
        popd .. &>/dev/null
}

each_ruby_configure() {
        # dev-ruby/fast_xs does not cover JRuby so still bundle it here for now
        [[ ${RUBY} == */jruby ]] && return

        ${RUBY} -Cext/hpricot_scan extconf.rb || die "hpricot_scan/extconf.rb 
failed"
}

each_ruby_compile() {
        local modname=$(get_modname)

        # dev-ruby/fast_xs does not cover JRuby so still bundle it here for now
        if [[ ${RUBY} == */jruby ]]; then
                ${RUBY} -S rake compile_java || die "rake compile_java failed"
                return
        fi

        emake V=1 -Cext/hpricot_scan CFLAGS="${CFLAGS} -fPIC" 
archflag="${LDFLAGS}" || die "make hpricot_scan failed"
        cp ext/hpricot_scan/hpricot_scan${modname} lib/ || die
}




Reply via email to