mrueg       14/09/02 15:31:31

  Modified:             ChangeLog
  Added:                pygments_rb-0.6.0-r1.ebuild
  Removed:              pygments_rb-0.5.4.ebuild pygments_rb-0.6.0.ebuild
  Log:
  Add ruby21 target. Cleanup old.
  
  (Portage version: 2.2.12-r1/cvs/Linux x86_64, signed Manifest commit with key 
)

Revision  Changes    Path
1.5                  dev-ruby/pygments_rb/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-ruby/pygments_rb/ChangeLog?rev=1.5&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-ruby/pygments_rb/ChangeLog?rev=1.5&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-ruby/pygments_rb/ChangeLog?r1=1.4&r2=1.5

Index: ChangeLog
===================================================================
RCS file: /var/cvsroot/gentoo-x86/dev-ruby/pygments_rb/ChangeLog,v
retrieving revision 1.4
retrieving revision 1.5
diff -u -r1.4 -r1.5
--- ChangeLog   15 Aug 2014 15:01:29 -0000      1.4
+++ ChangeLog   2 Sep 2014 15:31:31 -0000       1.5
@@ -1,6 +1,12 @@
 # ChangeLog for dev-ruby/pygments_rb
 # Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/pygments_rb/ChangeLog,v 1.4 
2014/08/15 15:01:29 mrueg Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/pygments_rb/ChangeLog,v 1.5 
2014/09/02 15:31:31 mrueg Exp $
+
+*pygments_rb-0.6.0-r1 (02 Sep 2014)
+
+  02 Sep 2014; Manuel Rüger <mr...@gentoo.org> +pygments_rb-0.6.0-r1.ebuild,
+  -pygments_rb-0.5.4.ebuild, -pygments_rb-0.6.0.ebuild:
+  Add ruby21 target. Cleanup old.
 
   15 Aug 2014; Manuel Rüger <mr...@gentoo.org> pygments_rb-0.6.0.ebuild:
   Restrict yajl-ruby dependency to =1.1*.



1.1                  dev-ruby/pygments_rb/pygments_rb-0.6.0-r1.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-ruby/pygments_rb/pygments_rb-0.6.0-r1.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-ruby/pygments_rb/pygments_rb-0.6.0-r1.ebuild?rev=1.1&content-type=text/plain

Index: pygments_rb-0.6.0-r1.ebuild
===================================================================
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: 
/var/cvsroot/gentoo-x86/dev-ruby/pygments_rb/pygments_rb-0.6.0-r1.ebuild,v 1.1 
2014/09/02 15:31:31 mrueg Exp $

EAPI=5

USE_RUBY="ruby19 ruby20 ruby21"
PYTHON_COMPAT=( python2_7 )

RUBY_FAKEGEM_NAME="pygments.rb"
MY_P="${RUBY_FAKEGEM_NAME}-${PV}"

RUBY_FAKEGEM_RECIPE_TEST="rake"
RUBY_FAKEGEM_RECIPE_DOC="none"
RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"

inherit ruby-fakegem python-single-r1

DESCRIPTION="pygments syntax highlighting in ruby"
HOMEPAGE="https://github.com/tmm1/pygments.rb";

LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64"
IUSE=""
REQUIRED_USE+=" ${PYTHON_REQUIRED_USE}"

RUBY_S="${MY_P}"

RDEPEND+=" dev-python/pygments[${PYTHON_USEDEP}]
        dev-python/simplejson[${PYTHON_USEDEP}]"
DEPEND+=" test? ( ${RDEPEND} )"

ruby_add_rdepend ">=dev-ruby/yajl-ruby-1.1
        dev-ruby/posix-spawn"
ruby_add_bdepend "dev-ruby/rake-compiler"

pkg_setup() {
        ruby-ng_pkg_setup
        python-single-r1_pkg_setup
}

all_ruby_prepare() {
        sed -i -e '/[Bb]undler/d' Rakefile || die
        sed -i -e 's/~> 1.1.0/~> 1.1/' pygments.rb.gemspec || die
        python_fix_shebang lib/pygments/mentos.py
        # we are loosing a "custom github lexer here", no idea what it is,
        # but if we need it, it should go into dev-python/pygments
        rm -r vendor lexers || die "removing bundled libs failed"
}

each_ruby_compile() {
        # regenerate the lexer cache, based on the system pygments pkg
        ${RUBY} cache-lexers.rb || die "regenerating lexer cache failed"
}

each_ruby_install() {
        each_fakegem_install
        ruby_fakegem_doins lexers
}




Reply via email to