graaff      14/06/11 06:34:18

  Modified:             ChangeLog
  Added:                twitter-5.10.0.ebuild
  Log:
  Version bump. Add ruby20.
  
  (Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 
0x8883FA56A308A8D7!)

Revision  Changes    Path
1.41                 dev-ruby/twitter/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-ruby/twitter/ChangeLog?rev=1.41&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-ruby/twitter/ChangeLog?rev=1.41&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-ruby/twitter/ChangeLog?r1=1.40&r2=1.41

Index: ChangeLog
===================================================================
RCS file: /var/cvsroot/gentoo-x86/dev-ruby/twitter/ChangeLog,v
retrieving revision 1.40
retrieving revision 1.41
diff -u -r1.40 -r1.41
--- ChangeLog   16 May 2014 08:20:42 -0000      1.40
+++ ChangeLog   11 Jun 2014 06:34:18 -0000      1.41
@@ -1,6 +1,11 @@
 # ChangeLog for dev-ruby/twitter
 # Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/twitter/ChangeLog,v 1.40 
2014/05/16 08:20:42 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/twitter/ChangeLog,v 1.41 
2014/06/11 06:34:18 graaff Exp $
+
+*twitter-5.10.0 (11 Jun 2014)
+
+  11 Jun 2014; Hans de Graaff <gra...@gentoo.org> +twitter-5.10.0.ebuild:
+  Version bump. Add ruby20.
 
 *twitter-5.9.0 (16 May 2014)
 



1.1                  dev-ruby/twitter/twitter-5.10.0.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-ruby/twitter/twitter-5.10.0.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-ruby/twitter/twitter-5.10.0.ebuild?rev=1.1&content-type=text/plain

Index: twitter-5.10.0.ebuild
===================================================================
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/dev-ruby/twitter/twitter-5.10.0.ebuild,v 1.1 
2014/06/11 06:34:18 graaff Exp $

EAPI=5
USE_RUBY="ruby19 ruby20"

RUBY_FAKEGEM_RECIPE_DOC="yard"
RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"

inherit ruby-fakegem

DESCRIPTION="Ruby wrapper around the Twitter API"
HOMEPAGE="http://twitter.rubyforge.org/";

LICENSE="MIT"
SLOT="5"
KEYWORDS="~amd64"
IUSE=""

ruby_add_rdepend "
        >=dev-ruby/addressable-2.3
        >=dev-ruby/buftok-0.2.0
        >=dev-ruby/equalizer-0.0.9
        =dev-ruby/faraday-0*
        >=dev-ruby/faraday-0.9.0
        >=dev-ruby/http-0.6.0:0.6
        >=dev-ruby/http_parser_rb-0.6.0
        >=dev-ruby/json-1.8
        >=dev-ruby/memoizable-0.4.0
        >=dev-ruby/naught-1.0
        =dev-ruby/simple_oauth-0*
        >=dev-ruby/simple_oauth-0.2"

ruby_add_bdepend "test? (
        dev-ruby/rspec:2
        dev-ruby/webmock
        )
        doc? ( dev-ruby/yard )"

all_ruby_prepare() {
#       rm Gemfile || die
        sed -i -e '/[Bb]undler/d' Rakefile || die "Unable to remove bundler 
code."

        sed -i -e '/\(simplecov\|coveralls\)/ s:^:#:' spec/helper.rb || die
}

each_ruby_test() {
        CI=true ${RUBY} -S rspec spec || die
}




Reply via email to