bircoph     14/12/01 06:39:59

  Modified:             ChangeLog
  Added:                oprofile-1.0.0.ebuild
  Log:
  Version bump to 1.0.0 per bug 530754
  
  Signed-off-by: Andrew Savchenko <birc...@gentoo.org>
  (Portage version: 2.2.14/cvs/Linux i686, signed Manifest commit with key 
565953B95372756C)

Revision  Changes    Path
1.97                 dev-util/oprofile/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-util/oprofile/ChangeLog?rev=1.97&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-util/oprofile/ChangeLog?rev=1.97&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-util/oprofile/ChangeLog?r1=1.96&r2=1.97

Index: ChangeLog
===================================================================
RCS file: /var/cvsroot/gentoo-x86/dev-util/oprofile/ChangeLog,v
retrieving revision 1.96
retrieving revision 1.97
diff -u -r1.96 -r1.97
--- ChangeLog   16 Nov 2014 12:42:25 -0000      1.96
+++ ChangeLog   1 Dec 2014 06:39:59 -0000       1.97
@@ -1,6 +1,13 @@
 # ChangeLog for dev-util/oprofile
 # Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/oprofile/ChangeLog,v 1.96 
2014/11/16 12:42:25 bircoph Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/oprofile/ChangeLog,v 1.97 
2014/12/01 06:39:59 bircoph Exp $
+
+*oprofile-1.0.0 (01 Dec 2014)
+
+  01 Dec 2014; Andrew Savchenko <birc...@gentoo.org> +oprofile-1.0.0.ebuild,
+  +files/oprofile-1.0.0-athlon.patch:
+  Version bump to 1.0.0, see bug 530754.
+  Fix CPU detection for Athlon systems.
 
   16 Nov 2014; Andrew Savchenko <birc...@gentoo.org> metadata.xml:
   Add myself to maintainers



1.1                  dev-util/oprofile/oprofile-1.0.0.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-util/oprofile/oprofile-1.0.0.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-util/oprofile/oprofile-1.0.0.ebuild?rev=1.1&content-type=text/plain

Index: oprofile-1.0.0.ebuild
===================================================================
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/dev-util/oprofile/oprofile-1.0.0.ebuild,v 
1.1 2014/12/01 06:39:59 bircoph Exp $

EAPI="5"
inherit eutils java-pkg-opt-2 linux-info multilib user

MY_P=${PN}-${PV/_/-}
DESCRIPTION="A transparent low-overhead system-wide profiler"
HOMEPAGE="http://${PN}.sourceforge.net";
SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~mips ~ppc ~ppc64 ~sparc ~x86"
IUSE="java pch"

DEPEND=">=dev-libs/popt-1.7-r1
        >=sys-devel/binutils-2.14.90.0.6-r3
        >=sys-libs/glibc-2.3.2-r1
        java? ( >=virtual/jdk-1.5 )"
RDEPEND="${DEPEND}"

S="${WORKDIR}/${MY_P}"

CONFIG_CHECK="PERF_EVENTS"
ERROR_PERF_EVENTS="CONFIG_PERF_EVENTS is mandatory for ${PN} to work."

pkg_setup() {
        linux-info_pkg_setup
        if ! kernel_is -ge 2 6 ; then
                echo
                elog "Support for kernels before 2.6 has been dropped in 
${PN}-0.9.8."
                echo
        fi

        # Required for JIT support, see README_PACKAGERS
        enewgroup ${PN}
        enewuser ${PN} -1 -1 -1 ${PN}

        use java && java-pkg_init
}

src_prepare() {
        epatch "${FILESDIR}/${P}-athlon.patch"
}

src_configure() {
        econf \
                --disable-werror \
                $(use_enable pch) \
                $(use_with java java ${JAVA_HOME})
}

src_install() {
        emake DESTDIR="${D}" htmldir="/usr/share/doc/${PF}" install

        dodoc ChangeLog* README TODO
        echo "LDPATH=${PREFIX}/usr/$(get_libdir)/${PN}" > "${T}/10${PN}"
        doenvd "${T}/10${PN}"
}

pkg_postinst() {
        echo
        elog "Starting from ${PN}-1.0.0 opcontrol was removed, use operf 
instead."
        elog "CONFIG_OPROFILE is no longer used, you may remove it from your 
kernels."
        elog "Please read manpages and this html doc:"
        elog "  /usr/share/doc/${PF}/${PN}.html"
        echo
}




Reply via email to