tomwij      14/03/24 14:40:17

  Added:                ChangeLog metadata.xml libmatekeyring-1.6.1.ebuild
  Log:
  New ebuild for mate-base/libmatekeyring, compatibility library for accessing 
secrets for MATE; imported from the mate-overlay, reviewed and adjusted.
  
  (Portage version: HEAD/cvs/Linux x86_64, signed Manifest commit with key 
6D34E57D)

Revision  Changes    Path
1.1                  mate-base/libmatekeyring/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/mate-base/libmatekeyring/ChangeLog?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/mate-base/libmatekeyring/ChangeLog?rev=1.1&content-type=text/plain

Index: ChangeLog
===================================================================
# ChangeLog for mate-base/libmatekeyring
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
# $Header: /var/cvsroot/gentoo-x86/mate-base/libmatekeyring/ChangeLog,v 1.1 
2014/03/24 14:40:17 tomwij Exp $

*libmatekeyring-1.6.1 (24 Mar 2014)

  24 Mar 2014; Tom Wijsman <tom...@gentoo.org> +libmatekeyring-1.6.1.ebuild,
  +metadata.xml:
  New ebuild for mate-base/libmatekeyring, compatibility library for accessing
  secrets for MATE; imported from the mate-overlay, reviewed and adjusted.



1.1                  mate-base/libmatekeyring/metadata.xml

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/mate-base/libmatekeyring/metadata.xml?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/mate-base/libmatekeyring/metadata.xml?rev=1.1&content-type=text/plain

Index: metadata.xml
===================================================================
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd";>
<pkgmetadata>
        <maintainer>
                <email>tom...@gentoo.org</email>
                <name>Tom Wijsman</name>
        </maintainer>
</pkgmetadata>



1.1                  mate-base/libmatekeyring/libmatekeyring-1.6.1.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/mate-base/libmatekeyring/libmatekeyring-1.6.1.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/mate-base/libmatekeyring/libmatekeyring-1.6.1.ebuild?rev=1.1&content-type=text/plain

Index: libmatekeyring-1.6.1.ebuild
===================================================================
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: 
/var/cvsroot/gentoo-x86/mate-base/libmatekeyring/libmatekeyring-1.6.1.ebuild,v 
1.1 2014/03/24 14:40:17 tomwij Exp $

EAPI="5"

GCONF_DEBUG="yes"
GNOME2_LA_PUNT="yes"

inherit gnome2 versionator

MATE_BRANCH="$(get_version_component_range 1-2)"

SRC_URI="http://pub.mate-desktop.org/releases/${MATE_BRANCH}/${P}.tar.xz";
DESCRIPTION="Compatibility library for accessing secrets for MATE"
HOMEPAGE="http://mate-desktop.org";

LICENSE="LGPL-2"
SLOT="0"
KEYWORDS="~amd64"

IUSE="debug test"

RDEPEND=">=dev-libs/glib-2.31:2
        >=dev-libs/libgcrypt-1.2.2:0=
        >=mate-base/mate-keyring-1.6:0[test?]
        >=sys-apps/dbus-1:0
        virtual/libintl:0"

DEPEND="${RDEPEND}
        sys-devel/gettext:*
        >=dev-util/intltool-0.35:*
        virtual/pkgconfig:*"

src_prepare() {
        # Remove silly CFLAGS
        sed 's:CFLAGS="$CFLAGS -Werror:CFLAGS="$CFLAGS:' \
                -i configure.ac || die "sed CFLAGS failed"

        # Remove DISABLE_DEPRECATED flags
        sed -e '/-D[A-Z_]*DISABLE_DEPRECATED/d' \
                -i configure.ac || die "sed DISABLE_DEPRECATED failed"

        gnome2_src_prepare
}

src_configure() {
        gnome2_src_configure \
                $(use_enable debug) \
                $(use_enable test tests)
}

DOCS="AUTHORS ChangeLog NEWS README"

src_test() {
        unset DBUS_SESSION_BUS_ADDRESS
        emake check
}




Reply via email to