nativemad    14/10/27 15:58:35

  Modified:             ChangeLog ardour-9999.ebuild ardour-3.5.403.ebuild
  Log:
  A more sophisticated attempt at bug 526608
  
  (Portage version: 2.2.8-r2/cvs/Linux i686, signed Manifest commit with key 
C1DE54B2)

Revision  Changes    Path
1.136                media-sound/ardour/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/media-sound/ardour/ChangeLog?rev=1.136&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/media-sound/ardour/ChangeLog?rev=1.136&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/media-sound/ardour/ChangeLog?r1=1.135&r2=1.136

Index: ChangeLog
===================================================================
RCS file: /var/cvsroot/gentoo-x86/media-sound/ardour/ChangeLog,v
retrieving revision 1.135
retrieving revision 1.136
diff -u -r1.135 -r1.136
--- ChangeLog   24 Oct 2014 19:14:34 -0000      1.135
+++ ChangeLog   27 Oct 2014 15:58:35 -0000      1.136
@@ -1,6 +1,10 @@
 # ChangeLog for media-sound/ardour
 # Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/ardour/ChangeLog,v 1.135 
2014/10/24 19:14:34 nativemad Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/ardour/ChangeLog,v 1.136 
2014/10/27 15:58:35 nativemad Exp $
+
+  27 Oct 2014; Andreas Schuerch <native...@gentoo.org> ardour-3.5.403.ebuild,
+  ardour-9999.ebuild:
+  A more sophisticated attempt at bug 526608
 
   24 Oct 2014; Andreas Schuerch <native...@gentoo.org> ardour-9999.ebuild:
   update 9999 to 3.5.403 again



1.12                 media-sound/ardour/ardour-9999.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/media-sound/ardour/ardour-9999.ebuild?rev=1.12&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/media-sound/ardour/ardour-9999.ebuild?rev=1.12&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/media-sound/ardour/ardour-9999.ebuild?r1=1.11&r2=1.12

Index: ardour-9999.ebuild
===================================================================
RCS file: /var/cvsroot/gentoo-x86/media-sound/ardour/ardour-9999.ebuild,v
retrieving revision 1.11
retrieving revision 1.12
diff -u -r1.11 -r1.12
--- ardour-9999.ebuild  24 Oct 2014 19:14:34 -0000      1.11
+++ ardour-9999.ebuild  27 Oct 2014 15:58:35 -0000      1.12
@@ -1,6 +1,6 @@
 # Copyright 1999-2014 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/ardour/ardour-9999.ebuild,v 
1.11 2014/10/24 19:14:34 nativemad Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/ardour/ardour-9999.ebuild,v 
1.12 2014/10/27 15:58:35 nativemad Exp $
 
 EAPI=5
 inherit eutils toolchain-funcs flag-o-matic waf-utils
@@ -76,17 +76,6 @@
        fi
 }
 
-pkg_pretend() {
-       if use sse; then
-               MARCH=$(get-flag march)
-               for ARCHWOSSE in i686 i486; do
-                       if [[ ${MARCH} = ${ARCHWOSSE} ]]; then
-                               is-flag -msse || is-flag -msse2 || die "Ardour 
fails to build with USE=sse and an march that is not sse capable, unless the 
-msse or -msse2 cflag are set also!"
-                       fi
-               done
-       fi
-}
-
 src_prepare(){
        if ! [ ${PV} = 9999 ]; then
                PVTEMP=$(echo "${PV}" | sed "s/\./-/2")
@@ -102,6 +91,21 @@
 }
 
 src_configure() {
+       if use sse; then
+               MARCH=$(get-flag march)
+               for ARCHWOSSE in i686 i486; do
+                       if [[ ${MARCH} = ${ARCHWOSSE} ]]; then
+                               for SSEOPT in -msse -msse2 -msse3 -mssse3 
-msse4 -msse4.1 -msse4.2; do
+                                       is-flag ${SSEOPT} && SSEON="yes"
+                               done
+                               if [ -z ${SSEON} ]; then
+                                       append-flags -msse
+                                       elog "You enabled sse but use an march 
that does not support sse!"
+                                       elog "We add -msse to the cflags now, 
but please consider switching your march in make.conf!"
+                               fi
+                       fi
+               done
+       fi
        tc-export CC CXX
        mkdir -p "${D}"
        waf-utils_src_configure \
@@ -111,7 +115,7 @@
                $(use lv2 && echo "--lv2" || echo "--no-lv2") \
                $(use nls && echo "--nls" || echo "--no-nls") \
                $(use debug && echo "--stl-debug" || echo "--optimize") \
-               $((use altivec || use sse) && echo "--fpu-optimization" || echo 
"--no-fpu-optimization") \
+               $({ use altivec || use sse; } && echo "--fpu-optimization" || 
echo "--no-fpu-optimization") \
                $(use doc && echo "--docs")
 }
 



1.3                  media-sound/ardour/ardour-3.5.403.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/media-sound/ardour/ardour-3.5.403.ebuild?rev=1.3&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/media-sound/ardour/ardour-3.5.403.ebuild?rev=1.3&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/media-sound/ardour/ardour-3.5.403.ebuild?r1=1.2&r2=1.3

Index: ardour-3.5.403.ebuild
===================================================================
RCS file: /var/cvsroot/gentoo-x86/media-sound/ardour/ardour-3.5.403.ebuild,v
retrieving revision 1.2
retrieving revision 1.3
diff -u -r1.2 -r1.3
--- ardour-3.5.403.ebuild       24 Oct 2014 19:07:19 -0000      1.2
+++ ardour-3.5.403.ebuild       27 Oct 2014 15:58:35 -0000      1.3
@@ -1,6 +1,6 @@
 # Copyright 1999-2014 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/ardour/ardour-3.5.403.ebuild,v 
1.2 2014/10/24 19:07:19 nativemad Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/ardour/ardour-3.5.403.ebuild,v 
1.3 2014/10/27 15:58:35 nativemad Exp $
 
 EAPI=5
 inherit eutils toolchain-funcs flag-o-matic waf-utils
@@ -76,17 +76,6 @@
        fi
 }
 
-pkg_pretend() {
-       if use sse; then
-               MARCH=$(get-flag march)
-               for ARCHWOSSE in i686 i486; do
-                       if [[ ${MARCH} = ${ARCHWOSSE} ]]; then
-                               is-flag -msse || is-flag -msse2 || die "Ardour 
fails to build with USE=sse and an march that is not sse capable, unless the 
-msse or -msse2 cflag are set also!"
-                       fi
-               done
-       fi
-}
-
 src_prepare(){
        if ! [ ${PV} = 9999 ]; then
                PVTEMP=$(echo "${PV}" | sed "s/\./-/2")
@@ -102,6 +91,21 @@
 }
 
 src_configure() {
+       if use sse; then
+               MARCH=$(get-flag march)
+               for ARCHWOSSE in i686 i486; do
+                       if [[ ${MARCH} = ${ARCHWOSSE} ]]; then
+                               for SSEOPT in -msse -msse2 -msse3 -mssse3 
-msse4 -msse4.1 -msse4.2; do
+                                       is-flag ${SSEOPT} && SSEON="yes"
+                               done
+                               if [ -z ${SSEON} ]; then
+                                       append-flags -msse
+                                       elog "You enabled sse but use an march 
that does not support sse!"
+                                       elog "We add -msse to the cflags now, 
but please consider switching your march in make.conf!"
+                               fi
+                       fi
+               done
+       fi
        tc-export CC CXX
        mkdir -p "${D}"
        waf-utils_src_configure \
@@ -111,7 +115,7 @@
                $(use lv2 && echo "--lv2" || echo "--no-lv2") \
                $(use nls && echo "--nls" || echo "--no-nls") \
                $(use debug && echo "--stl-debug" || echo "--optimize") \
-               $((use altivec || use sse) && echo "--fpu-optimization" || echo 
"--no-fpu-optimization") \
+               $({ use altivec || use sse; } && echo "--fpu-optimization" || 
echo "--no-fpu-optimization") \
                $(use doc && echo "--docs")
 }
 




Reply via email to