radhermit    14/11/30 23:25:53

  Modified:             metadata.xml ChangeLog
  Added:                unbound-1.5.0-r1.ebuild
  Log:
  Add ecdsa use flag to support openssl compiled with bindist enabled (bug 
#531256).
  
  (Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 
4AB3E85B4F064CA3)

Revision  Changes    Path
1.12                 net-dns/unbound/metadata.xml

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/net-dns/unbound/metadata.xml?rev=1.12&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/net-dns/unbound/metadata.xml?rev=1.12&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/net-dns/unbound/metadata.xml?r1=1.11&r2=1.12

Index: metadata.xml
===================================================================
RCS file: /var/cvsroot/gentoo-x86/net-dns/unbound/metadata.xml,v
retrieving revision 1.11
retrieving revision 1.12
diff -u -r1.11 -r1.12
--- metadata.xml        27 Nov 2014 18:36:35 -0000      1.11
+++ metadata.xml        30 Nov 2014 23:25:53 -0000      1.12
@@ -24,6 +24,7 @@
   </longdescription>
   <use>
     <flag name='dnstap'>Enable dnstap support</flag>
+       <flag name='ecdsa'>Enable ECDSA support</flag>
     <flag name='gost'>Enable GOST support</flag>
   </use>
 </pkgmetadata>



1.79                 net-dns/unbound/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/net-dns/unbound/ChangeLog?rev=1.79&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/net-dns/unbound/ChangeLog?rev=1.79&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/net-dns/unbound/ChangeLog?r1=1.78&r2=1.79

Index: ChangeLog
===================================================================
RCS file: /var/cvsroot/gentoo-x86/net-dns/unbound/ChangeLog,v
retrieving revision 1.78
retrieving revision 1.79
diff -u -r1.78 -r1.79
--- ChangeLog   29 Nov 2014 12:47:20 -0000      1.78
+++ ChangeLog   30 Nov 2014 23:25:53 -0000      1.79
@@ -1,6 +1,13 @@
 # ChangeLog for net-dns/unbound
 # Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/unbound/ChangeLog,v 1.78 2014/11/29 
12:47:20 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dns/unbound/ChangeLog,v 1.79 2014/11/30 
23:25:53 radhermit Exp $
+
+*unbound-1.5.0-r1 (30 Nov 2014)
+
+  30 Nov 2014; Tim Harder <radher...@gentoo.org> +unbound-1.5.0-r1.ebuild,
+  metadata.xml:
+  Add ecdsa use flag to support openssl compiled with bindist enabled (bug
+  #531256).
 
   29 Nov 2014; Jeroen Roovers <j...@gentoo.org> unbound-1.5.0.ebuild:
   Marked ~hppa (bug #531068).



1.1                  net-dns/unbound/unbound-1.5.0-r1.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/net-dns/unbound/unbound-1.5.0-r1.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/net-dns/unbound/unbound-1.5.0-r1.ebuild?rev=1.1&content-type=text/plain

Index: unbound-1.5.0-r1.ebuild
===================================================================
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/net-dns/unbound/unbound-1.5.0-r1.ebuild,v 
1.1 2014/11/30 23:25:53 radhermit Exp $

EAPI=5
PYTHON_COMPAT=( python2_7 )

inherit eutils flag-o-matic multilib-minimal python-single-r1 systemd user

DESCRIPTION="A validating, recursive and caching DNS resolver"
HOMEPAGE="http://unbound.net/";
SRC_URI="http://unbound.net/downloads/${P}.tar.gz";

LICENSE="BSD GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~hppa ~x86"
IUSE="debug dnstap +ecdsa gost python selinux static-libs test threads"
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"

# Note: expat is needed by executable only but the Makefile is custom
# and doesn't make it possible to easily install the library without
# the executables. MULTILIB_USEDEP may be dropped once build system
# is fixed.

CDEPEND=">=dev-libs/expat-2.1.0-r3[${MULTILIB_USEDEP}]
        >=dev-libs/libevent-2.0.21[${MULTILIB_USEDEP}]
        >=dev-libs/openssl-1.0.1h-r2[${MULTILIB_USEDEP}]
        dnstap? (
                dev-libs/fstrm[${MULTILIB_USEDEP}]
                >=dev-libs/protobuf-c-1.0.2-r1[${MULTILIB_USEDEP}]
        )
        ecdsa? ( >=dev-libs/openssl-1.0.1h-r2[-bindist,${MULTILIB_USEDEP}] )
        python? ( ${PYTHON_DEPS} )"

DEPEND="${CDEPEND}
        python? ( dev-lang/swig )
        test? (
                net-dns/ldns-utils[examples]
                dev-util/splint
                app-text/wdiff
        )"

RDEPEND="${CDEPEND}
        selinux? ( sec-policy/selinux-bind )"

# bug #347415
RDEPEND="${RDEPEND}
        net-dns/dnssec-root"

pkg_setup() {
        enewgroup unbound
        enewuser unbound -1 -1 /etc/unbound unbound

        use python && python-single-r1_pkg_setup
}

src_prepare() {
        # To avoid below error messages, set 'trust-anchor-file' to same value 
in
        # 'auto-trust-anchor-file'.
        # [23109:0] error: Could not open autotrust file for writing,
        # /etc/dnssec/root-anchors.txt: Permission denied
        epatch "${FILESDIR}"/${PN}-1.4.12-gentoo.patch

        # required for the python part
        multilib_copy_sources
}

src_configure() {
        [[ ${CHOST} == *-darwin* ]] || append-ldflags -Wl,-z,noexecstack
        multilib-minimal_src_configure
}

multilib_src_configure() {
        econf \
                $(use_enable debug) \
                $(use_enable gost) \
                $(use_enable dnstap) \
                $(use_enable ecdsa) \
                $(use_enable static-libs static) \
                $(multilib_native_use_with python pythonmodule) \
                $(multilib_native_use_with python pyunbound) \
                $(use_with threads pthreads) \
                --disable-rpath \
                --with-libevent="${EPREFIX}"/usr \
                --with-pidfile="${EPREFIX}"/var/run/unbound.pid \
                --with-rootkey-file="${EPREFIX}"/etc/dnssec/root-anchors.txt \
                --with-ssl="${EPREFIX}"/usr \
                --with-libexpat="${EPREFIX}"/usr

                # 
http://unbound.nlnetlabs.nl/pipermail/unbound-users/2011-April/001801.html
                # $(use_enable debug lock-checks) \
                # $(use_enable debug alloc-checks) \
                # $(use_enable debug alloc-lite) \
                # $(use_enable debug alloc-nonregional) \
}

multilib_src_install_all() {
        prune_libtool_files --modules
        use python && python_optimize

        newinitd "${FILESDIR}"/unbound.initd unbound
        newconfd "${FILESDIR}"/unbound.confd unbound

        systemd_dounit "${FILESDIR}"/unbound.service
        systemd_newunit "${FILESDIR}"/unbound_at.service "unbound@.service"
        systemd_dounit "${FILESDIR}"/unbound-anchor.service

        dodoc doc/{README,CREDITS,TODO,Changelog,FEATURES}

        # bug #315519
        dodoc contrib/unbound_munin_

        docinto selinux
        dodoc contrib/selinux/*

        exeinto /usr/share/${PN}
        doexe contrib/update-anchor.sh
}




Reply via email to