pacho       15/01/26 12:31:05

  Modified:             ChangeLog
  Added:                farstream-0.2.6.ebuild
  Removed:              farstream-0.2.3.ebuild
  Log:
  Version bump, drop old
  
  (Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key 
A188FBD4)

Revision  Changes    Path
1.44                 net-libs/farstream/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/net-libs/farstream/ChangeLog?rev=1.44&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/net-libs/farstream/ChangeLog?rev=1.44&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/net-libs/farstream/ChangeLog?r1=1.43&r2=1.44

Index: ChangeLog
===================================================================
RCS file: /var/cvsroot/gentoo-x86/net-libs/farstream/ChangeLog,v
retrieving revision 1.43
retrieving revision 1.44
diff -u -r1.43 -r1.44
--- ChangeLog   19 Jan 2015 10:40:36 -0000      1.43
+++ ChangeLog   26 Jan 2015 12:31:05 -0000      1.44
@@ -1,6 +1,12 @@
 # ChangeLog for net-libs/farstream
 # Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/farstream/ChangeLog,v 1.43 
2015/01/19 10:40:36 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/farstream/ChangeLog,v 1.44 
2015/01/26 12:31:05 pacho Exp $
+
+*farstream-0.2.6 (26 Jan 2015)
+
+  26 Jan 2015; Pacho Ramos <pa...@gentoo.org> +farstream-0.2.6.ebuild,
+  -farstream-0.2.3.ebuild:
+  Version bump, drop old
 
   19 Jan 2015; Jeroen Roovers <j...@gentoo.org> farstream-0.1.2-r2.ebuild:
   Stable for HPPA (bug #536694).



1.1                  net-libs/farstream/farstream-0.2.6.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/net-libs/farstream/farstream-0.2.6.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/net-libs/farstream/farstream-0.2.6.ebuild?rev=1.1&content-type=text/plain

Index: farstream-0.2.6.ebuild
===================================================================
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/net-libs/farstream/farstream-0.2.6.ebuild,v 
1.1 2015/01/26 12:31:05 pacho Exp $

EAPI="5"
GCONF_DEBUG="no"
GNOME2_LA_PUNT="yes"
PYTHON_COMPAT=( python2_7 )

inherit gnome2 python-any-r1

DESCRIPTION="Audio/video conferencing framework specifically designed for 
instant messengers"
HOMEPAGE="http://www.freedesktop.org/wiki/Software/Farstream";
SRC_URI="http://freedesktop.org/software/farstream/releases/${PN}/${P}.tar.gz";

LICENSE="LGPL-2.1+"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux 
~x86-linux"
IUSE="+introspection msn test upnp"

SLOT="0.2"

# Tests need shmsink from gst-plugins-bad, which isn't packaged
RESTRICT="test"

COMMONDEPEND="
        >=media-libs/gstreamer-1.4:1.0
        >=media-libs/gst-plugins-base-1.4:1.0
        >=dev-libs/glib-2.32:2
        >=net-libs/libnice-0.1.8
        introspection? ( >=dev-libs/gobject-introspection-0.10.11 )
        upnp? ( >=net-libs/gupnp-igd-0.2:= )
"
RDEPEND="${COMMONDEPEND}
        media-libs/gst-plugins-good:1.0
        media-libs/gst-plugins-bad:1.0
        media-plugins/gst-plugins-libnice:1.0
        msn? ( media-plugins/gst-plugins-mimic:1.0 )
"
DEPEND="${COMMONDEPEND}
        ${PYTHON_DEPS}
        >=dev-util/gtk-doc-am-1.18
        virtual/pkgconfig
        test? (
                media-libs/gst-plugins-base:1.0[vorbis]
                media-libs/gst-plugins-good:1.0 )
"

pkg_setup() {
        python-any-r1_pkg_setup
}

src_configure() {
        
plugins="fsrawconference,fsrtpconference,fsfunnel,fsrtcpfilter,fsvideoanyrate"
        use msn && plugins="${plugins},fsmsnconference"
        gnome2_src_configure \
                --disable-static \
                $(use_enable introspection) \
                $(use_enable upnp gupnp) \
                --with-plugins=${plugins}
}

src_test() {
        # FIXME: do an out-of-tree build for tests if USE=-msn
        if ! use msn; then
                elog "Tests disabled without msn use flag"
                return
        fi

        emake -j1 check
}




Reply via email to