radhermit    14/04/11 02:09:50

  Modified:             ChangeLog
  Added:                gnutls-3.2.13.ebuild
  Log:
  Version bump.
  
  (Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 
4AB3E85B4F064CA3)

Revision  Changes    Path
1.484                net-libs/gnutls/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/net-libs/gnutls/ChangeLog?rev=1.484&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/net-libs/gnutls/ChangeLog?rev=1.484&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/net-libs/gnutls/ChangeLog?r1=1.483&r2=1.484

Index: ChangeLog
===================================================================
RCS file: /var/cvsroot/gentoo-x86/net-libs/gnutls/ChangeLog,v
retrieving revision 1.483
retrieving revision 1.484
diff -u -r1.483 -r1.484
--- ChangeLog   29 Mar 2014 21:15:05 -0000      1.483
+++ ChangeLog   11 Apr 2014 02:09:50 -0000      1.484
@@ -1,6 +1,11 @@
 # ChangeLog for net-libs/gnutls
 # Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/gnutls/ChangeLog,v 1.483 
2014/03/29 21:15:05 alonbl Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/gnutls/ChangeLog,v 1.484 
2014/04/11 02:09:50 radhermit Exp $
+
+*gnutls-3.2.13 (11 Apr 2014)
+
+  11 Apr 2014; Tim Harder <radher...@gentoo.org> +gnutls-3.2.13.ebuild:
+  Version bump.
 
 *gnutls-2.12.23-r5 (29 Mar 2014)
 



1.1                  net-libs/gnutls/gnutls-3.2.13.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/net-libs/gnutls/gnutls-3.2.13.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/net-libs/gnutls/gnutls-3.2.13.ebuild?rev=1.1&content-type=text/plain

Index: gnutls-3.2.13.ebuild
===================================================================
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/net-libs/gnutls/gnutls-3.2.13.ebuild,v 1.1 
2014/04/11 02:09:50 radhermit Exp $

EAPI=5

inherit autotools libtool eutils versionator

DESCRIPTION="A TLS 1.2 and SSL 3.0 implementation for the GNU project"
HOMEPAGE="http://www.gnutls.org/";
SRC_URI="ftp://ftp.gnutls.org/gcrypt/gnutls/v$(get_version_component_range 
1-2)/${P}.tar.xz"

# LGPL-3 for libgnutls library and GPL-3 for libgnutls-extra library.
# soon to be relicensed as LGPL-2.1 unless heartbeat extension enabled.
LICENSE="GPL-3 LGPL-3"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc 
~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x86-interix ~amd64-linux ~arm-linux 
~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
IUSE_LINGUAS=" en cs de fi fr it ms nl pl sv uk vi zh_CN"
IUSE="+cxx +crywrap dane doc examples guile nls pkcs11 static-libs test zlib 
${IUSE_LINGUAS// / linguas_}"
# heartbeat support is not disabled until re-licensing happens fullyf

# NOTICE: sys-devel/autogen is required at runtime as we
# use system libopts
RDEPEND=">=dev-libs/libtasn1-2.14
        >=dev-libs/nettle-2.7[gmp]
        dev-libs/gmp
        sys-devel/autogen
        crywrap? ( net-dns/libidn )
        dane? ( net-dns/unbound )
        guile? ( >=dev-scheme/guile-1.8[networking] )
        nls? ( virtual/libintl )
        pkcs11? ( >=app-crypt/p11-kit-0.19.2 )
        zlib? ( >=sys-libs/zlib-1.2.3.1 )"
DEPEND="${RDEPEND}
        >=sys-devel/automake-1.11.6
        virtual/pkgconfig
        doc? ( dev-util/gtk-doc )
        nls? ( sys-devel/gettext )
        test? ( app-misc/datefudge )"

DOCS=( AUTHORS ChangeLog NEWS README THANKS doc/TODO )

S=${WORKDIR}/${PN}-$(get_version_component_range 1-3)

src_prepare() {
        # tests/suite directory is not distributed
        sed -i \
                -e ':AC_CONFIG_FILES(\[tests/suite/Makefile\]):d' \
                -e '/^AM_INIT_AUTOMAKE/s/-Werror//' \
                configure.ac || die

        sed -i \
                -e 's/imagesdir = $(infodir)/imagesdir = $(htmldir)/' \
                doc/Makefile.am || die

        # force regeneration of autogen-ed files
        local file
        for file in $(grep -l AutoGen-ed src/*.c) ; do
                rm src/$(basename ${file} .c).{c,h} || die
        done

        epatch 
"${FILESDIR}/${PN}-2.12.23-gl-tests-getaddrinfo-skip-if-no-network.patch"

        # support user patches
        epatch_user

        eautoreconf

        # Use sane .so versioning on FreeBSD.
        elibtoolize

        # bug 497472
        use cxx || epunt_cxx
}

src_configure() {
        LINGUAS="${LINGUAS//en/en@boldquot en@quot}"

        # TPM needs to be tested before being enabled
        # hardware-accell is disabled on OSX because the asm files force
        #   GNU-stack (as doesn't support that) and when that's removed ld
        #   complains about duplicate symbols
        econf \
                --htmldir="${EPREFIX}/usr/share/doc/${PF}/html" \
                --disable-valgrind-tests \
                --enable-heartbeat-support \
                $(use_enable cxx) \
                $(use_enable dane libdane) \
                $(use_enable doc gtk-doc) \
                $(use_enable doc gtk-doc-pdf) \
                $(use_enable guile) \
                $(use_enable crywrap) \
                $(use_enable nls) \
                $(use_enable static-libs static) \
                $(use_with pkcs11 p11-kit) \
                $(use_with zlib) \
                --without-tpm \
                $([[ ${CHOST} == *-darwin* ]] && echo 
--disable-hardware-acceleration)
}

src_test() {
        # parallel testing often fails
        emake -j1 check
}

src_install() {
        default

        find "${ED}" -name '*.la' -delete

        dodoc doc/certtool.cfg

        if use doc; then
                dodoc doc/gnutls.pdf
                dohtml doc/gnutls.html
        fi

        if use examples; then
                docinto examples
                dodoc doc/examples/*.c
        fi
}




Reply via email to