patrick     15/01/27 03:01:33

  Added:                iojs-1.0.4.ebuild metadata.xml Manifest ChangeLog
  Log:
  Initial import, ebuild by jbergstroem
  
  (Portage version: 2.2.15/cvs/Linux x86_64, unsigned Manifest commit)

Revision  Changes    Path
1.1                  net-libs/iojs/iojs-1.0.4.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/net-libs/iojs/iojs-1.0.4.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/net-libs/iojs/iojs-1.0.4.ebuild?rev=1.1&content-type=text/plain

Index: iojs-1.0.4.ebuild
===================================================================
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/net-libs/iojs/iojs-1.0.4.ebuild,v 1.1 
2015/01/27 03:01:33 patrick Exp $

EAPI=5

# Sigh, this can't work ... silly upstream
RESTRICT="test"

PYTHON_COMPAT=( python2_7 )

MY_PV="v${PV}"
MY_P="${PN}-${MY_PV}"

inherit python-any-r1 pax-utils toolchain-funcs flag-o-matic

DESCRIPTION="An npm compatible platform originally based on node.js"
HOMEPAGE="http://iojs.org/";
SRC_URI="http://iojs.org/dist/${MY_PV}/${MY_P}.tar.xz";

LICENSE="Apache-1.1 Apache-2.0 BSD BSD-2 MIT"
SLOT="0"
KEYWORDS="~amd64 ~arm ~x86 ~x64-macos"
IUSE="icu +npm snapshot"

RDEPEND="!!net-libs/nodejs
        >=dev-libs/openssl-1.0.1j"
DEPEND="${PYTHON_DEPS}
        ${RDEPEND}
        icu? ( dev-libs/icu )
        >=net-libs/http-parser-2.4.1
        >=dev-libs/libuv-1.2.1"

S="${WORKDIR}/${MY_P}"

pkg_pretend() {
        if ! test-flag-CXX -std=c++11 ; then
                die "Your compiler doesn't support C++11. Use GCC 4.8, Clang 
3.3 or newer."
        fi
}

src_prepare() {
        # fix compilation on Darwin
        # http://code.google.com/p/gyp/issues/detail?id=260
        sed -i -e "/append('-arch/d" tools/gyp/pylib/gyp/xcode_emulation.py || 
die

        # make sure we use python2.* while using gyp
        sed -i -e "s/python/python2/" deps/npm/node_modules/node-gyp/gyp/gyp || 
die
        sed -i -e "s/|| 'python'/|| 'python2'/" 
deps/npm/node_modules/node-gyp/lib/configure.js || die

        # less verbose install output (stating the same as portage, basically)
        sed -i -e "/print/d" tools/install.py || die

        # proper libdir, hat tip @ryanpcmcquen 
https://github.com/iojs/io.js/issues/504
        local LIBDIR=$(get_libdir)
        sed -i -e "s|lib/|${LIBDIR}/|g" tools/install.py || die
        sed -i -e "s/'lib'/'${LIBDIR}'/" lib/module.js || die
        sed -i -e "s|\"lib\"|\"${LIBDIR}\"|" deps/npm/lib/npm.js || die

        tc-export CC CXX
}

src_configure() {
        local myconf=""
        local myarch=""
        ! use npm && myconf="--without-npm"
        use icu && myconf+=" --with-intl=system-icu"
        use snapshot && myconf+=" --with-snapshot"

        case ${CHOST} in
                i?86-*)
                        myarch="ia32"
                        myconf+=" -Dv8_target_arch=ia32" ;;
                x86_64-*)
                        if [[ $ABI = x86 ]]; then
                                myarch="ia32"
                        elif [[ $ABI = x32 ]]; then
                                myarch="x32"
                        else
                                myarch="x64"
                        fi ;;
                arm*-*)
                        myarch="arm"
                        ;;
                *) die "Unrecognized CHOST: ${CHOST}"
        esac

        "${PYTHON}" configure --prefix="${EPREFIX}"/usr \
                --shared-openssl \
                --shared-libuv \
                --shared-http-parser \
                --shared-zlib \
                --dest-cpu=${myarch} \
                --without-dtrace ${myconf} || die
}

src_compile() {
        export PYTHON="${PYTHON}"
        export V=1
        default
}

src_install() {
        local LIBDIR="${ED}/usr/$(get_libdir)"
        emake install DESTDIR="${D}"

        use npm && dohtml -r "${LIBDIR}"/node_modules/npm/html/*
        rm -rf "${LIBDIR}"/node_modules/npm/{doc,html}
        rm -rf "${LIBDIR}"/dtrace
        find "${LIBDIR}"/node_modules -type f -name "LICENSE" -delete

        pax-mark -m "${ED}"/usr/bin/iojs
}

src_test() {
        emake test || die
}



1.1                  net-libs/iojs/metadata.xml

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/net-libs/iojs/metadata.xml?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/net-libs/iojs/metadata.xml?rev=1.1&content-type=text/plain

Index: metadata.xml
===================================================================
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd";>
<pkgmetadata>
        <herd>proxy-maintainers</herd>
        <maintainer>
                <email>b...@bergstroem.nu</email>
                <name>Johan Bergstroem</name>
        </maintainer>
        <maintainer>
                <email>patr...@gentoo.org</email>
                <name>Patrick Lauer</name>
        </maintainer>
        <use>
        <flag name='npm'>Enable NPM package manager</flag>
        <flag name='snapshot'>Enable snapshot creation for faster startup</flag>
        </use>
</pkgmetadata>



1.1                  net-libs/iojs/Manifest

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/net-libs/iojs/Manifest?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/net-libs/iojs/Manifest?rev=1.1&content-type=text/plain

Index: Manifest
===================================================================
DIST iojs-v1.0.4.tar.xz 12284732 SHA256 
c902f5abbd59c56346680f0b4a71056c51610847b9576acf83a9c210bf664e98 SHA512 
0e3d4f66fc7f64e09f999b1fdb7bbbfe80a5cfd0396ec718bf166ae44bcb27eebf5b59c3cd4a74f050b59ee529678b1bdef1c3b9d71534c8ac0ab8caf8472021
 WHIRLPOOL 
cfd766a513877f6ccfddc4e1eb4e0be4fa987dbac7c7c8159f70556b72a01b26fdd7d92be3fcb7efc37691b6808c8d570199741f01f95df77dd9aa95312bac9e
EBUILD iojs-1.0.4.ebuild 2849 SHA256 
0a12b83263baefa64d994e6094eebf34e6bc7689361a9a2eb2d95c520343e2e6 SHA512 
968141538e6f6e09580bd2d2d9fd6e95385d3b2b8f045fd252d3dc9cf909697371f0f4c7483d312b4fe539b4adfa3bbcea6d812402c01af79a073cbda9e4f0d3
 WHIRLPOOL 
6a61dd5c8da54495f93424cee51a1ca5f8bb730ac996996ba86a25c60d0c25565685521178254bab6f17d24311ab2598f1153c7a6c4c36669b785c8e42409c3c
MISC metadata.xml 545 SHA256 
ea98b41b3fe8288a7b38649098871f33c897916aaa34c718f8b849bc35d15c12 SHA512 
f32b1eced5dada7827c10bb7b59986400d8dce58dc8c2c0b03d3acd0886b539d2c0afa7956c8a0d1b1ae1894eae31c520368c524bd4c7fb5930180fc8bc4b035
 WHIRLPOOL 
f3fe5d3c70386787eae1cc856f7a57d775738096777074b50678f45ed7e5c9c2575c21a452e75d9a5d06245c85c17434593a7b3d0b5f0c4ec932fd3c7a8b84aa



1.1                  net-libs/iojs/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/net-libs/iojs/ChangeLog?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/net-libs/iojs/ChangeLog?rev=1.1&content-type=text/plain

Index: ChangeLog
===================================================================
# ChangeLog for net-libs/iojs
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
# $Header: /var/cvsroot/gentoo-x86/net-libs/iojs/ChangeLog,v 1.1 2015/01/27 
03:01:33 patrick Exp $

*iojs-1.0.4 (27 Jan 2015)

  27 Jan 2015; Patrick Lauer <patr...@gentoo.org> +iojs-1.0.4.ebuild,
  +metadata.xml:
  Initial import, ebuild by jbergstroem




Reply via email to