tomka       14/06/11 12:52:01

  Modified:             ChangeLog
  Added:                offlineimap-6.5.6.ebuild
  Removed:              offlineimap-6.5.4.ebuild
                        offlineimap-6.5.4-r1.ebuild
                        offlineimap-6.3.4.ebuild
  Log:
  Bump to 6.5.6, remove old
  
  (Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 
565C32BC)

Revision  Changes    Path
1.97                 net-mail/offlineimap/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/net-mail/offlineimap/ChangeLog?rev=1.97&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/net-mail/offlineimap/ChangeLog?rev=1.97&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/net-mail/offlineimap/ChangeLog?r1=1.96&r2=1.97

Index: ChangeLog
===================================================================
RCS file: /var/cvsroot/gentoo-x86/net-mail/offlineimap/ChangeLog,v
retrieving revision 1.96
retrieving revision 1.97
diff -u -r1.96 -r1.97
--- ChangeLog   14 Jan 2014 15:10:17 -0000      1.96
+++ ChangeLog   11 Jun 2014 12:52:01 -0000      1.97
@@ -1,6 +1,15 @@
 # ChangeLog for net-mail/offlineimap
 # Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/offlineimap/ChangeLog,v 1.96 
2014/01/14 15:10:17 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/offlineimap/ChangeLog,v 1.97 
2014/06/11 12:52:01 tomka Exp $
+
+*offlineimap-6.5.6 (11 Jun 2014)
+
+  11 Jun 2014; Thomas Kahle <to...@gentoo.org> +offlineimap-6.5.6.ebuild,
+  -files/offlineimap-6.3.2-darwin10.patch,
+  -files/offlineimap-6.3.4-fix-manpage-headings.patch,
+  -offlineimap-6.3.4.ebuild, -offlineimap-6.5.4-r1.ebuild,
+  -offlineimap-6.5.4.ebuild:
+  Bump to 6.5.6, remove old
 
   14 Jan 2014; Agostino Sarubbo <a...@gentoo.org> offlineimap-6.5.5.ebuild:
   Stable for ppc, wrt bug #495866



1.1                  net-mail/offlineimap/offlineimap-6.5.6.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/net-mail/offlineimap/offlineimap-6.5.6.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/net-mail/offlineimap/offlineimap-6.5.6.ebuild?rev=1.1&content-type=text/plain

Index: offlineimap-6.5.6.ebuild
===================================================================
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: 
/var/cvsroot/gentoo-x86/net-mail/offlineimap/offlineimap-6.5.6.ebuild,v 1.1 
2014/06/11 12:52:01 tomka Exp $

EAPI=5

# Normally you need only one version of this.
DISTUTILS_SINGLE_IMPL=1
PYTHON_COMPAT=( python{2_6,2_7} )
PYTHON_REQ_USE="threads,sqlite?,ssl?"

inherit eutils distutils-r1

DESCRIPTION="Powerful IMAP/Maildir synchronization and reader support"
HOMEPAGE="http://offlineimap.org";
SRC_URI="https://github.com/OfflineIMAP/${PN}/tarball/v${PV} -> ${P}.tar.gz"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos 
~x64-macos ~x86-macos"
IUSE="doc ssl sqlite"

RDEPEND=""
DEPEND="doc? ( dev-python/docutils )"
S="${WORKDIR}/${PN}"

src_unpack() {
        unpack ${A}
        mv *-${PN}-* "${S}/"
}

src_prepare() {
        distutils-r1_src_prepare
        # see http://pogma.com/2009/09/09/snow-leopard-and-offlineimap/ and bug 
284925
        epatch "${FILESDIR}"/"${PN}-6.5.3.1"-darwin10.patch
}

src_compile() {
        distutils-r1_src_compile
        if use doc ; then
                cd docs
                rst2man.py MANUAL.rst offlineimap.1 || die "building manpage 
failed"
        fi
}

src_install() {
        distutils-r1_src_install
        dodoc offlineimap.conf offlineimap.conf.minimal
        if use doc ; then
                cd docs
                doman offlineimap.1 || die "installing manpage failed"
        fi
}

pkg_preinst() {
        if has_version "<${CATEGORY}/${PN}-6.4" ; then
                elog "If you upgraded from 6.3.* then you may need to update 
your config:"
                elog ""
                elog "If you use nametrans= settings on a remote repository, 
you will have"
                elog "to add a \"reverse\" nametrans setting to the local 
repository, so that"
                elog "it knows which folders it should (not) create on the 
remote side."
                elog ""
        fi
}

pkg_postinst() {
        elog ""
        elog "You will need to configure offlineimap by creating 
~/.offlineimaprc"
        elog "Sample configurations are in /usr/share/doc/${PF}/"
        elog ""
        elog "If you connect via ssl/tls and don't use CA cert checking, it 
will"
        elog "display the server's cert fingerprint and require you to add it 
to the"
        elog "configuration file to be sure it connects to the same server 
every"
        elog "time. This serves to help fixing CVE-2010-4532 (offlineimap 
doesn't"
        elog "check SSL server certificate) in cases where you have no CA cert."
        elog ""

        if use sqlite ; then
                elog "The sqlite USE flag only enables a dependency on sqlite. 
To use"
                elog "the sqlite backend you need to enable it in your 
.offlineimaprc"
        fi
}




Reply via email to