hwoarang    14/12/21 19:28:02

  Modified:             ChangeLog
  Added:                ntp-4.2.8.ebuild
  Log:
  Version bump. Bug #515494. Thanks to m...@marineau.org for the ebuild
  
  (Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key 
09BF4F54C2BA7F3C!)

Revision  Changes    Path
1.222                net-misc/ntp/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/net-misc/ntp/ChangeLog?rev=1.222&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/net-misc/ntp/ChangeLog?rev=1.222&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/net-misc/ntp/ChangeLog?r1=1.221&r2=1.222

Index: ChangeLog
===================================================================
RCS file: /var/cvsroot/gentoo-x86/net-misc/ntp/ChangeLog,v
retrieving revision 1.221
retrieving revision 1.222
diff -u -r1.221 -r1.222
--- ChangeLog   2 Nov 2014 09:09:15 -0000       1.221
+++ ChangeLog   21 Dec 2014 19:28:02 -0000      1.222
@@ -1,6 +1,11 @@
 # ChangeLog for net-misc/ntp
 # Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/ntp/ChangeLog,v 1.221 2014/11/02 
09:09:15 swift Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/ntp/ChangeLog,v 1.222 2014/12/21 
19:28:02 hwoarang Exp $
+
+*ntp-4.2.8 (21 Dec 2014)
+
+  21 Dec 2014; Markos Chandras <hwoar...@gentoo.org> +ntp-4.2.8.ebuild:
+  Version bump. Bug #515494. Thanks to m...@marineau.org for the ebuild
 
   02 Nov 2014; Sven Vermeulen <sw...@gentoo.org> ntp-4.2.6_p5-r10.ebuild,
   ntp-4.2.6_p5-r11.ebuild:



1.1                  net-misc/ntp/ntp-4.2.8.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/net-misc/ntp/ntp-4.2.8.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/net-misc/ntp/ntp-4.2.8.ebuild?rev=1.1&content-type=text/plain

Index: ntp-4.2.8.ebuild
===================================================================
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/net-misc/ntp/ntp-4.2.8.ebuild,v 1.1 
2014/12/21 19:28:02 hwoarang Exp $

EAPI="4"

inherit eutils toolchain-funcs flag-o-matic user systemd

MY_P=${P/_p/p}
DESCRIPTION="Network Time Protocol suite/programs"
HOMEPAGE="http://www.ntp.org/";
SRC_URI="http://www.eecis.udel.edu/~ntp/ntp_spool/ntp4/ntp-${PV:0:3}/${MY_P}.tar.gz
        mirror://gentoo/${MY_P}-manpages.tar.bz2"

LICENSE="HPND BSD ISC"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh 
~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux 
~ia64-linux ~x86-linux ~m68k-mint"
IUSE="caps debug ipv6 openntpd parse-clocks samba selinux snmp ssl vim-syntax 
zeroconf"

CDEPEND=">=sys-libs/ncurses-5.2
        >=sys-libs/readline-4.1
        >=dev-libs/libevent-2.0.9
        kernel_linux? ( caps? ( sys-libs/libcap ) )
        zeroconf? ( net-dns/avahi[mdnsresponder-compat] )
        !openntpd? ( !net-misc/openntpd )
        snmp? ( net-analyzer/net-snmp )
        ssl? ( dev-libs/openssl )
        parse-clocks? ( net-misc/pps-tools )"
DEPEND="${CDEPEND}
        virtual/pkgconfig"
RDEPEND="${CDEPEND}
        selinux? ( sec-policy/selinux-ntp )
        vim-syntax? ( app-vim/ntp-syntax )"
PDEPEND="openntpd? ( net-misc/openntpd )"

S=${WORKDIR}/${MY_P}

pkg_setup() {
        enewgroup ntp 123
        enewuser ntp 123 -1 /dev/null ntp
}

src_prepare() {
        epatch "${FILESDIR}"/${PN}-4.2.4_p7-nano.patch #270483
        append-cppflags -D_GNU_SOURCE #264109
}

src_configure() {
        # avoid libmd5/libelf
        export ac_cv_search_MD5Init=no ac_cv_header_md5_h=no
        export ac_cv_lib_elf_nlist=no
        # blah, no real configure options #176333
        export ac_cv_header_dns_sd_h=$(usex zeroconf)
        export ac_cv_lib_dns_sd_DNSServiceRegister=${ac_cv_header_dns_sd_h}
        econf \
                --with-lineeditlibs=readline,edit,editline \
                --with-yielding-select \
                --disable-local-libevent \
                $(use_enable caps linuxcaps) \
                $(use_enable parse-clocks) \
                $(use_enable ipv6) \
                $(use_enable debug debugging) \
                $(use_enable samba ntp-signd) \
                $(use_with snmp ntpsnmpd) \
                $(use_with ssl crypto)
}

src_install() {
        default
        # move ntpd/ntpdate to sbin #66671
        dodir /usr/sbin
        mv "${ED}"/usr/bin/{ntpd,ntpdate} "${ED}"/usr/sbin/ || die "move to 
sbin"

        dodoc INSTALL WHERE-TO-START
        doman "${WORKDIR}"/man/*.[58]
        dohtml -r html/*

        insinto /usr/share/ntp
        doins "${FILESDIR}"/ntp.conf
        cp -r scripts/* "${ED}"/usr/share/ntp/ || die
        use prefix || fperms -R go-w /usr/share/ntp
        find "${ED}"/usr/share/ntp \
                '(' \
                -name '*.in' -o \
                -name 'Makefile*' -o \
                -name support \
                ')' \
                -exec rm -r {} \;

        insinto /etc
        doins "${FILESDIR}"/ntp.conf
        newinitd "${FILESDIR}"/ntpd.rc ntpd
        newconfd "${FILESDIR}"/ntpd.confd ntpd
        newinitd "${FILESDIR}"/ntp-client.rc ntp-client
        newconfd "${FILESDIR}"/ntp-client.confd ntp-client
        newinitd "${FILESDIR}"/sntp.rc sntp
        newconfd "${FILESDIR}"/sntp.confd sntp
        if ! use caps ; then
                sed -i "s|-u ntp:ntp||" "${ED}"/etc/conf.d/ntpd || die
        fi
        sed -i "s:/usr/bin:/usr/sbin:" "${ED}"/etc/init.d/ntpd || die

        keepdir /var/lib/ntp
        use prefix || fowners ntp:ntp /var/lib/ntp

        if use openntpd ; then
                cd "${ED}"
                rm usr/sbin/ntpd || die
                rm -r var/lib
                rm etc/{conf,init}.d/ntpd
                rm usr/share/man/*/ntpd.8 || die
        else
                systemd_newunit "${FILESDIR}"/ntpd.service-r2 ntpd.service
                use caps && sed -i '/ExecStart/ s|$| -u ntp:ntp|' 
"${ED}"/usr/lib/systemd/system/ntpd.service
                systemd_enable_ntpunit 60-ntpd ntpd.service
        fi

        systemd_newunit "${FILESDIR}"/ntpdate.service-r1 ntpdate.service
        systemd_install_serviced "${FILESDIR}"/ntpdate.service.conf
        systemd_newunit "${FILESDIR}"/sntp.service-r2 sntp.service
        systemd_install_serviced "${FILESDIR}"/sntp.service.conf
}

pkg_postinst() {
        ewarn "You can find an example /etc/ntp.conf in /usr/share/ntp/"
        ewarn "Review /etc/ntp.conf to setup server info."
        ewarn "Review /etc/conf.d/ntpd to setup init.d info."
        echo
        elog "The way ntp sets and maintains your system time has changed."
        elog "Now you can use /etc/init.d/ntp-client to set your time at"
        elog "boot while you can use /etc/init.d/ntpd to maintain your time"
        elog "while your machine runs"
        if grep -qs '^[^#].*notrust' "${EROOT}"/etc/ntp.conf ; then
                echo
                eerror "The notrust option was found in your /etc/ntp.conf!"
                ewarn "If your ntpd starts sending out weird responses,"
                ewarn "then make sure you have keys properly setup and see"
                ewarn "http://bugs.gentoo.org/41827";
        fi
}




Reply via email to