tomjbe      14/08/10 17:07:58

  Modified:             ChangeLog
  Added:                systemc-2.3.1.ebuild
  Log:
  Version bump (bug #508568). Thanks Jeremiah
  
  (Portage version: 2.2.11-r1/cvs/Linux x86_64, signed Manifest commit with key 
0x762053D5)

Revision  Changes    Path
1.17                 sci-electronics/systemc/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sci-electronics/systemc/ChangeLog?rev=1.17&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sci-electronics/systemc/ChangeLog?rev=1.17&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sci-electronics/systemc/ChangeLog?r1=1.16&r2=1.17

Index: ChangeLog
===================================================================
RCS file: /var/cvsroot/gentoo-x86/sci-electronics/systemc/ChangeLog,v
retrieving revision 1.16
retrieving revision 1.17
diff -u -r1.16 -r1.17
--- ChangeLog   15 Sep 2013 14:40:07 -0000      1.16
+++ ChangeLog   10 Aug 2014 17:07:58 -0000      1.17
@@ -1,6 +1,11 @@
 # ChangeLog for sci-electronics/systemc
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-electronics/systemc/ChangeLog,v 1.16 
2013/09/15 14:40:07 tomjbe Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/systemc/ChangeLog,v 1.17 
2014/08/10 17:07:58 tomjbe Exp $
+
+*systemc-2.3.1 (10 Aug 2014)
+
+  10 Aug 2014; Thomas Beierlein <tom...@gentoo.org> +systemc-2.3.1.ebuild:
+  Version bump (bug #508568). Thanks Jeremiah
 
 *systemc-2.3.0 (15 Sep 2013)
 



1.1                  sci-electronics/systemc/systemc-2.3.1.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sci-electronics/systemc/systemc-2.3.1.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sci-electronics/systemc/systemc-2.3.1.ebuild?rev=1.1&content-type=text/plain

Index: systemc-2.3.1.ebuild
===================================================================
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: 
/var/cvsroot/gentoo-x86/sci-electronics/systemc/systemc-2.3.1.ebuild,v 1.1 
2014/08/10 17:07:58 tomjbe Exp $

EAPI=5

inherit eutils toolchain-funcs autotools-utils

DESCRIPTION="A C++ based modeling platform for VLSI and system-level co-design"
HOMEPAGE="http://www.systemc.org/";
SRC_URI="${P}.tgz"

SLOT="0"
LICENSE="SOPLA-3.0"
IUSE="doc static-libs"
KEYWORDS="~amd64 ~x86"

RESTRICT="fetch test"

AUTOTOOLS_IN_SOURCE_BUILD=1

pkg_nofetch() {
        elog "${PN} developers require end-users to accept their license 
agreement"
        elog "by registering on their Web site (${HOMEPAGE})."
        elog "Please download ${A} manually and place it in ${DISTDIR}."
}

src_prepare() {
        for sfile in src/sysc/qt/md/*.s ; do
                sed -i -e '$a \
#if defined(__linux__) && defined(__ELF__) \
.section .note.GNU-stack,"",%progbits \
#endif' "${sfile}" || die "Patching ${sfile} failed"
        done
}

src_configure() {
        econf $(use_enable static-libs static) CXX=$(tc-getCXX)\
        --with-unix-layout
}

src_install() {
        dodoc AUTHORS ChangeLog INSTALL NEWS README RELEASENOTES
        rm docs/SystemC_Open_Source_License.pdf || die
        rm docs/Makefile* || die
        use doc && dodoc -r docs/*
        cd src
        autotools-utils_src_install
}

pkg_postinst() {
        elog "If you want to run the examples, you need to :"
        elog "    tar xvfz ${PORTAGE_ACTUAL_DISTDIR}/${A}"
        elog "    cd ${P}"
        elog "    find examples -name 'Makefile.*' -exec sed -i -e 's/-lm/-lm 
-lpthread/' '{}' \;"
        elog "    ./configure"
        elog "    cd examples"
        elog "    make check"
}




Reply via email to