tomka       15/03/08 15:18:28

  Modified:             ChangeLog
  Added:                lrslib-051.ebuild
  Log:
  Bump to 051
  
  (Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 
565C32BC)

Revision  Changes    Path
1.10                 sci-libs/lrslib/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sci-libs/lrslib/ChangeLog?rev=1.10&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sci-libs/lrslib/ChangeLog?rev=1.10&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sci-libs/lrslib/ChangeLog?r1=1.9&r2=1.10

Index: ChangeLog
===================================================================
RCS file: /var/cvsroot/gentoo-x86/sci-libs/lrslib/ChangeLog,v
retrieving revision 1.9
retrieving revision 1.10
diff -u -r1.9 -r1.10
--- ChangeLog   24 Mar 2012 17:23:18 -0000      1.9
+++ ChangeLog   8 Mar 2015 15:18:28 -0000       1.10
@@ -1,6 +1,11 @@
 # ChangeLog for sci-libs/lrslib
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/lrslib/ChangeLog,v 1.9 2012/03/24 
17:23:18 phajdan.jr Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/lrslib/ChangeLog,v 1.10 2015/03/08 
15:18:28 tomka Exp $
+
+*lrslib-051 (08 Mar 2015)
+
+  08 Mar 2015; Thomas Kahle <to...@gentoo.org> +lrslib-051.ebuild:
+  Bump to 051
 
   24 Mar 2012; Pawel Hajdan jr <phajdan...@gentoo.org> lrslib-042c-r2.ebuild:
   x86 stable wrt bug #408085
@@ -37,4 +42,3 @@
   12 Nov 2010; Thomas Kahle <to...@gentoo.org> +lrslib-042c.ebuild,
   +metadata.xml:
   Initial import from science overlay. Fixes bug 338685
-



1.1                  sci-libs/lrslib/lrslib-051.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sci-libs/lrslib/lrslib-051.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sci-libs/lrslib/lrslib-051.ebuild?rev=1.1&content-type=text/plain

Index: lrslib-051.ebuild
===================================================================
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/sci-libs/lrslib/lrslib-051.ebuild,v 1.1 
2015/03/08 15:18:28 tomka Exp $

EAPI=5

inherit toolchain-funcs

DESCRIPTION="self-contained ANSI C implementation of the reverse search 
algorithm"
HOMEPAGE="http://cgm.cs.mcgill.ca/~avis/C/lrs.html";
SRC_URI="http://cgm.cs.mcgill.ca/~avis/C/lrslib/${P}.tar.gz";

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="gmp"

DEPEND="gmp? ( dev-libs/gmp )"
RDEPEND="${DEPEND}"

src_prepare(){
        sed -i "s/gcc/$(tc-getCC)/g" makefile || die
        sed -i "s/-O3/${CFLAGS} ${LDFLAGS}/g" makefile || die
        # Prefix for install
        sed -i "s,/usr/local,/usr,g" makefile || die
}

src_compile () {
        if use gmp ; then
                emake all
                emake all-shared
        else
                emake allmp
        fi
}

src_install() {
        dodoc readme
        # Library
        if use gmp ; then
                emake DESTDIR="${D}" install-shared
        fi
        # Install default set of binaries
        emake DESTDIR="${D}" install-common
}




Reply via email to