tomka       14/05/09 13:36:16

  Modified:             ChangeLog
  Added:                normaliz-2.11.ebuild
  Log:
  Bump to 2.11
  
  (Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 
565C32BC)

Revision  Changes    Path
1.16                 sci-mathematics/normaliz/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sci-mathematics/normaliz/ChangeLog?rev=1.16&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sci-mathematics/normaliz/ChangeLog?rev=1.16&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sci-mathematics/normaliz/ChangeLog?r1=1.15&r2=1.16

Index: ChangeLog
===================================================================
RCS file: /var/cvsroot/gentoo-x86/sci-mathematics/normaliz/ChangeLog,v
retrieving revision 1.15
retrieving revision 1.16
diff -u -r1.15 -r1.16
--- ChangeLog   27 Jul 2013 14:59:12 -0000      1.15
+++ ChangeLog   9 May 2014 13:36:16 -0000       1.16
@@ -1,6 +1,12 @@
 # ChangeLog for sci-mathematics/normaliz
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/normaliz/ChangeLog,v 1.15 
2013/07/27 14:59:12 tomka Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/normaliz/ChangeLog,v 1.16 
2014/05/09 13:36:16 tomka Exp $
+
+*normaliz-2.11 (09 May 2014)
+
+  09 May 2014; Thomas Kahle <to...@gentoo.org>
+  +files/normaliz-2.11-respect-flags.patch, +normaliz-2.11.ebuild:
+  Bump to 2.11
 
 *normaliz-2.10.1 (27 Jul 2013)
 



1.1                  sci-mathematics/normaliz/normaliz-2.11.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sci-mathematics/normaliz/normaliz-2.11.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sci-mathematics/normaliz/normaliz-2.11.ebuild?rev=1.1&content-type=text/plain

Index: normaliz-2.11.ebuild
===================================================================
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: 
/var/cvsroot/gentoo-x86/sci-mathematics/normaliz/normaliz-2.11.ebuild,v 1.1 
2014/05/09 13:36:16 tomka Exp $

EAPI=5

inherit eutils toolchain-funcs versionator

MYPV=$(get_version_component_range 1-2)
MYP="Normaliz${MYPV}"

DESCRIPTION="Tool for computations in affine monoids and more"
HOMEPAGE="http://www.mathematik.uni-osnabrueck.de/normaliz/";
SRC_URI="http://www.mathematik.uni-osnabrueck.de/${PN}/${MYP}/${MYP}.zip";

LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="extras openmp"

RDEPEND="dev-libs/gmp[cxx]"
DEPEND="${RDEPEND}
        app-arch/unzip
        dev-libs/boost"
# Only a boost header is needed -> not RDEPEND

S=${WORKDIR}/${MYP}

src_prepare () {
        epatch "${FILESDIR}/${PN}-${MYPV}-respect-flags.patch"

        # Respect users AR tool (Bug 474532)
        sed -e "s:ar -cr:$(tc-getAR) -cr:" -i source/libnormaliz/Makefile

        if use openmp && tc-has-openmp; then
                export OPENMP=yes
        else
                export OPENMP=no
        fi
}

src_compile(){
        emake CXX="$(tc-getCXX)" OPENMP="${OPENMP}" -C source
}

src_install() {
        dobin source/normaliz
        dodoc doc/"Normaliz_${MYPV}.pdf"
        dodoc doc/"NmzIntegrate_1.2.pdf"
        if use extras; then
                elog "You have selected to install extras which consist of 
Macaulay2"
                elog "and Singular packages. These have been installed into "
                elog "/usr/share/${PN}, and cannot be used without additional 
setup. Please refer"
                elog "to the homepages of the respective projects for 
additional information."
                elog "Note however, Gentoo's versions of Singular and Macaulay2 
bring their own"
                elog "copies of these interface packages. Usually you don't 
need normaliz's versions."
                insinto "/usr/share/${PN}"
                doins Singular/normaliz.lib
                doins Macaulay2/Normaliz.m2
        fi
}




Reply via email to