tomka       15/03/13 15:10:36

  Modified:             metadata.xml ChangeLog
  Added:                polymake-2.14-r1.ebuild
  Log:
  Various improvements, thanks Benjamin Lorenz.
  
  (Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 
565C32BC)

Revision  Changes    Path
1.3                  sci-mathematics/polymake/metadata.xml

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sci-mathematics/polymake/metadata.xml?rev=1.3&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sci-mathematics/polymake/metadata.xml?rev=1.3&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sci-mathematics/polymake/metadata.xml?r1=1.2&r2=1.3

Index: metadata.xml
===================================================================
RCS file: /var/cvsroot/gentoo-x86/sci-mathematics/polymake/metadata.xml,v
retrieving revision 1.2
retrieving revision 1.3
diff -u -r1.2 -r1.3
--- metadata.xml        20 Aug 2011 22:57:21 -0000      1.2
+++ metadata.xml        13 Mar 2015 15:10:36 -0000      1.3
@@ -7,6 +7,14 @@
 </maintainer>
 <herd>sci-mathematics</herd>
 <use>
+  <flag name="cdd">Enable sci-libs/cddlib interface for convex hull
+  computations (Should be kept enabled).</flag>
+  <flag name="lrs">Enable sci-libs/lrslib interface for convex hull 
computations.</flag>
+  <flag name="ppl">Enable dev-libs/ppl interface for convex hull 
computations.</flag>
+  <flag name="bliss">Enable sci-libs/bliss interface for graph and face 
lattice isomorphism computations.</flag>
+  <flag name="group">Build extension for dealing with permutation groups and 
symmetric objects.</flag>
+  <flag name="libnormaliz">Build the bundled extension for lattice related 
computations.</flag>
+  <flag name="singular">Enable the interface to sci-mathematics/singular for 
ideal related computations.</flag>
   <flag name="libpolymake">Build the polymake library to build applications 
using the C++ interface.</flag>
 </use>
 <longdescription lang="en">



1.16                 sci-mathematics/polymake/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sci-mathematics/polymake/ChangeLog?rev=1.16&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sci-mathematics/polymake/ChangeLog?rev=1.16&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sci-mathematics/polymake/ChangeLog?r1=1.15&r2=1.16

Index: ChangeLog
===================================================================
RCS file: /var/cvsroot/gentoo-x86/sci-mathematics/polymake/ChangeLog,v
retrieving revision 1.15
retrieving revision 1.16
diff -u -r1.15 -r1.16
--- ChangeLog   5 Mar 2015 15:09:25 -0000       1.15
+++ ChangeLog   13 Mar 2015 15:10:36 -0000      1.16
@@ -1,6 +1,12 @@
 # ChangeLog for sci-mathematics/polymake
 # Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/polymake/ChangeLog,v 1.15 
2015/03/05 15:09:25 tomka Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/polymake/ChangeLog,v 1.16 
2015/03/13 15:10:36 tomka Exp $
+
+*polymake-2.14-r1 (13 Mar 2015)
+
+  13 Mar 2015; Thomas Kahle <to...@gentoo.org> +polymake-2.14-r1.ebuild,
+  metadata.xml:
+  Various improvements, thanks Benjamin Lorenz.
 
 *polymake-2.14 (05 Mar 2015)
 



1.1                  sci-mathematics/polymake/polymake-2.14-r1.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sci-mathematics/polymake/polymake-2.14-r1.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sci-mathematics/polymake/polymake-2.14-r1.ebuild?rev=1.1&content-type=text/plain

Index: polymake-2.14-r1.ebuild
===================================================================
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: 
/var/cvsroot/gentoo-x86/sci-mathematics/polymake/polymake-2.14-r1.ebuild,v 1.1 
2015/03/13 15:10:36 tomka Exp $

EAPI=5

inherit eutils flag-o-matic

DESCRIPTION="research tool for polyhedral geometry and combinatorics"
SRC_URI="http://polymake.org/lib/exe/fetch.php/download/${P}-minimal.tar.bz2";
HOMEPAGE="http://polymake.org";

IUSE="+cdd lrs ppl bliss group +libnormaliz singular libpolymake"

REQUIRED_USE="group? ( cdd lrs )"

SLOT="0"
LICENSE="GPL-2"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"

# do not allow new perl versions because our testbuilds segfault
DEPEND="<dev-lang/perl-5.21
        dev-libs/gmp
        dev-libs/mpfr
        dev-libs/libxml2:2
        dev-libs/libxslt
        ppl? ( dev-libs/ppl )
        cdd? ( sci-libs/cddlib )
        lrs? ( >=sci-libs/lrslib-051[gmp] )
        bliss? ( sci-libs/bliss[gmp] )
        group? ( dev-libs/boost )
        libnormaliz? ( dev-libs/boost )
        singular? ( >=sci-mathematics/singular-4.0.1 )"
RDEPEND="${DEPEND}
        dev-perl/XML-LibXML
        dev-perl/XML-LibXSLT
        dev-perl/XML-Writer
        dev-perl/Term-ReadLine-Gnu"

src_prepare() {
        einfo "During compile this package uses up to"
        einfo "750MB of RAM per process. Use MAKEOPTS=\"-j1\" if"
        einfo "you run into trouble."
}

src_configure () {
        export CXXOPT=$(get-flag -O)

        # We need to define BLISS_USE_GMP if bliss was built with gmp support.
        # Therefore we require gmp support on bliss, so that the package
        # manager can prevent rebuilds with changed gmp flag.
        if use bliss ; then
                append-cxxflags -DBLISS_USE_GMP
        fi

        # Configure does not accept --host, therefore econf cannot be used

        # Some of the options do not support using just '--with-option'
        local myconf=""
        use !group && myconf="$myconf --without-group"
        use !libnormaliz && myconf="$myconf --without-libnormaliz"
        use !libpolymake && myconf="$myconf --without-callable"

        # And many other --with-arguments expect a path: --with-option=/path
        ./configure --prefix="${EPREFIX}/usr" \
                --libdir="${EPREFIX}/usr/$(get_libdir)" \
                --libexecdir="${EPREFIX}/usr/$(get_libdir)/polymake" \
                --without-prereq \
                --without-java \
                $(use_with cdd cdd "${EPREFIX}/usr") \
                $(use_with lrs lrs "${EPREFIX}/usr") \
                $(use_with ppl ppl "${EPREFIX}/usr") \
                $(use_with bliss bliss "${EPREFIX}/usr") \
                $(use_with singular singular "${EPREFIX}/usr") \
                ${myconf} || die
}

src_install(){
        emake -j1 DESTDIR="${D}" install
}

pkg_postinst(){
        elog "Docs can be found on 
http://www.polymake.org/doku.php/documentation";
        elog " "
        elog "Support for jreality is missing, sorry (see bug #346073)."
        elog " "
        elog "Additional features for polymake are available through external"
        elog "software such as sci-mathmatics/4ti2 and sci-mathematics/topcom."
        elog "After installing new external software run 'polymake 
--reconfigure'."
}




Reply via email to